diff options
author | Yu Mingli <mingli.yu@windriver.com> | 2018-01-21 22:47:41 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2018-02-05 10:40:19 -0500 |
commit | a14265678f9e3ae397d3fff9e453e6105dc66d48 (patch) | |
tree | 19fbb59758a5be9ea3ebefa6dbab441aeec0a6ee /meta-networking/recipes-protocols | |
parent | 5ed659dbe7d55d0470928fb3bfa717893b4ef019 (diff) | |
download | meta-openembedded-a14265678f9e3ae397d3fff9e453e6105dc66d48.tar.gz |
net-snmp: fix the invalid -fdebug-prefix-map
The previous path value to -fdebug-prefix-map
is null which may result in other package such as
quagga do_config error as below:
====================================================
add DISTRO_FEATURES_append = " snmp" to conf/local.conf
test@buildserver@ bitbake quagga
| checking for i586-poky-linux-net-snmp-config... no
| checking for net-snmp-config... $Prj/tmp/work/i586-poky-linux/quagga/1.2.1-r0/recipe-sysroot/usr/bin/crossscripts/net-snmp-config
| checking whether we can link to Net-SNMP... no
| configure: error: --enable-snmp given but not usable
| NOTE: The following config.log files may provide further information.
| NOTE: $Prj/tmp/work/i586-poky-linux/quagga/1.2.1-r0/build/config.log
| ERROR: configure failed
| WARNING: $Prj/tmp/work/i586-poky-linux/quagga/1.2.1-r0/temp/run.do_configure.80493:1 exit 1 from 'exit 1'
| ERROR: Function failed: do_configure (log file is located at $Prj/tmp/work/i586-poky-linux/quagga/1.2.1-r0/temp/log.do_configure.80493)
====================================================
Signed-off-by: Yu Mingli <mingli.yu@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r-- | meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb index 2f1b0bfe3..5a7773e08 100644 --- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb +++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb | |||
@@ -151,6 +151,7 @@ do_install_ptest() { | |||
151 | } | 151 | } |
152 | 152 | ||
153 | SYSROOT_PREPROCESS_FUNCS += "net_snmp_sysroot_preprocess" | 153 | SYSROOT_PREPROCESS_FUNCS += "net_snmp_sysroot_preprocess" |
154 | SNMP_DBGDIR = "/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" | ||
154 | 155 | ||
155 | net_snmp_sysroot_preprocess () { | 156 | net_snmp_sysroot_preprocess () { |
156 | if [ -e ${D}${bindir}/net-snmp-config ]; then | 157 | if [ -e ${D}${bindir}/net-snmp-config ]; then |
@@ -162,6 +163,12 @@ net_snmp_sysroot_preprocess () { | |||
162 | -e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \ | 163 | -e "s@^includedir=.*@includedir=${STAGING_INCDIR}@g" \ |
163 | -e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \ | 164 | -e "s@^libdir=.*@libdir=${STAGING_LIBDIR}@g" \ |
164 | -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=${S}@g" \ | 165 | -e "s@^NSC_SRCDIR=.*@NSC_SRCDIR=${S}@g" \ |
166 | -e "s@-fdebug-prefix-map=${SNMP_DBGDIR}@-fdebug-prefix-map=${WORKDIR}=${SNMP_DBGDIR}@g" \ | ||
167 | -e "s@-fdebug-prefix-map= -fdebug-prefix-map=@-fdebug-prefix-map=${STAGING_DIR_NATIVE}= \ | ||
168 | -fdebug-prefix-map=${STAGING_DIR_HOST}=@g" \ | ||
169 | -e "s@--sysroot=@--sysroot=${STAGING_DIR_HOST}@g" \ | ||
170 | -e "s@--with-libtool-sysroot=@--with-libtool-sysroot=${STAGING_DIR_HOST}@g" \ | ||
171 | -e "s@--with-install-prefix=@--with-install-prefix=${D}@g" \ | ||
165 | -i ${SYSROOT_DESTDIR}${bindir_crossscripts}/net-snmp-config | 172 | -i ${SYSROOT_DESTDIR}${bindir_crossscripts}/net-snmp-config |
166 | fi | 173 | fi |
167 | } | 174 | } |