summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:50 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-05-05 11:41:28 -0400
commit275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch)
tree4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-protocols
parent7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff)
downloadmeta-openembedded-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb2
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow.inc2
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga.inc12
3 files changed, 8 insertions, 8 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index ee8878f9d..79892a120 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -146,7 +146,7 @@ INITSCRIPT_PACKAGES = "${PN}-server"
146INITSCRIPT_NAME_${PN}-server = "snmpd" 146INITSCRIPT_NAME_${PN}-server = "snmpd"
147INITSCRIPT_PARAMS_${PN}-server = "start 90 2 3 4 5 . stop 60 0 1 6 ." 147INITSCRIPT_PARAMS_${PN}-server = "start 90 2 3 4 5 . stop 60 0 1 6 ."
148 148
149EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)}" 149EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)}"
150 150
151SYSTEMD_PACKAGES = "${PN}-server-snmpd \ 151SYSTEMD_PACKAGES = "${PN}-server-snmpd \
152 ${PN}-server-snmptrapd" 152 ${PN}-server-snmptrapd"
diff --git a/meta-networking/recipes-protocols/openflow/openflow.inc b/meta-networking/recipes-protocols/openflow/openflow.inc
index 5f465cea6..d309ae1a8 100644
--- a/meta-networking/recipes-protocols/openflow/openflow.inc
+++ b/meta-networking/recipes-protocols/openflow/openflow.inc
@@ -20,7 +20,7 @@ PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl, openssl, libssl"
20 20
21EXTRA_OECONF += " \ 21EXTRA_OECONF += " \
22 KARCH=${TARGET_ARCH} \ 22 KARCH=${TARGET_ARCH} \
23 ${@base_contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \ 23 ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \
24 " 24 "
25 25
26S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
diff --git a/meta-networking/recipes-protocols/quagga/quagga.inc b/meta-networking/recipes-protocols/quagga/quagga.inc
index de78e2679..4244fdf9e 100644
--- a/meta-networking/recipes-protocols/quagga/quagga.inc
+++ b/meta-networking/recipes-protocols/quagga/quagga.inc
@@ -9,8 +9,8 @@ HOMEPAGE = "http://www.nongnu.org/quagga/"
9SECTION = "net" 9SECTION = "net"
10LICENSE = "GPL-2.0 & LGPL-2.0" 10LICENSE = "GPL-2.0 & LGPL-2.0"
11DEPENDS = "readline ncurses perl-native" 11DEPENDS = "readline ncurses perl-native"
12DEPENDS += "${@base_contains('DISTRO_FEATURES', 'snmp', 'net-snmp', '', d)}" 12DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'snmp', 'net-snmp', '', d)}"
13SNMP_CONF="${@base_contains('DISTRO_FEATURES', 'snmp', '--enable-snmp', '', d)}" 13SNMP_CONF="${@bb.utils.contains('DISTRO_FEATURES', 'snmp', '--enable-snmp', '', d)}"
14 14
15LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d \ 15LIC_FILES_CHKSUM = "file://COPYING;md5=81bcece21748c91ba9992349a91ec11d \
16 file://COPYING.LIB;md5=01ef24401ded36cd8e5d18bfe947240c" 16 file://COPYING.LIB;md5=01ef24401ded36cd8e5d18bfe947240c"
@@ -41,7 +41,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/quagga${QUAGGASUBDIR}/quagga-${PV}.tar.gz; \
41 file://zebra.service \ 41 file://zebra.service \
42" 42"
43 43
44PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" 44PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
45PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap" 45PACKAGECONFIG[cap] = "--enable-capabilities,--disable-capabilities,libcap"
46PACKAGECONFIG[pam] = "--with-libpam, --without-libpam, libpam" 46PACKAGECONFIG[pam] = "--with-libpam, --without-libpam, libpam"
47 47
@@ -62,7 +62,7 @@ EXTRA_OECONF = "--sysconfdir=${sysconfdir}/quagga \
62 --enable-exampledir=${docdir}/quagga/examples/ \ 62 --enable-exampledir=${docdir}/quagga/examples/ \
63 --enable-vtysh \ 63 --enable-vtysh \
64 --enable-isisd \ 64 --enable-isisd \
65 ${@base_contains('DISTRO_FEATURES', 'sysvinit', '--enable-watchquagga', '--disable-watchquagga', d)} \ 65 ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '--enable-watchquagga', '--disable-watchquagga', d)} \
66 --enable-ospf-te \ 66 --enable-ospf-te \
67 --enable-opaque-lsa \ 67 --enable-opaque-lsa \
68 --enable-ospfclient=yes \ 68 --enable-ospfclient=yes \
@@ -125,7 +125,7 @@ do_install () {
125 fi 125 fi
126 done 126 done
127 127
128 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 128 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
129 install -d ${D}${sysconfdir}/tmpfiles.d 129 install -d ${D}${sysconfdir}/tmpfiles.d
130 echo "d /var/run/quagga 0755 quagga quagga -" \ 130 echo "d /var/run/quagga 0755 quagga quagga -" \
131 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf 131 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
@@ -162,7 +162,7 @@ pkg_postinst_${PN} () {
162# Split into a main package and separate per-protocol packages 162# Split into a main package and separate per-protocol packages
163PACKAGE_BEFORE_PN = "${PN}-ospfd ${PN}-ospf6d ${PN}-babeld ${PN}-bgpd \ 163PACKAGE_BEFORE_PN = "${PN}-ospfd ${PN}-ospf6d ${PN}-babeld ${PN}-bgpd \
164 ${PN}-ripd ${PN}-ripngd ${PN}-isisd \ 164 ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
165 ${PN}-ospfclient ${@base_contains('DISTRO_FEATURES', 'sysvinit', '${PN}-watchquagga', '', d)}" 165 ${PN}-ospfclient ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${PN}-watchquagga', '', d)}"
166 166
167RDEPENDS_${PN} += "${PN}-babeld ${PN}-bgpd ${PN}-isisd ${PN}-ospf6d ${PN}-ospfd ${PN}-ripd ${PN}-ripngd" 167RDEPENDS_${PN} += "${PN}-babeld ${PN}-bgpd ${PN}-isisd ${PN}-ospf6d ${PN}-ospfd ${PN}-ripd ${PN}-ripngd"
168 168