summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-04 07:40:35 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-04 07:43:14 -0700
commitd04f3c9bfe62a9f77f64a49f9b54551827e5f192 (patch)
tree92626a8909939f0cd763e8649ff2ccd9610fbf98 /meta-networking/recipes-protocols
parent118bfa649324be52640ce52d69df0a6e06ab5ae7 (diff)
downloadmeta-openembedded-d04f3c9bfe62a9f77f64a49f9b54551827e5f192.tar.gz
mdns: Upgrade to 1310.140.1
Fix build with musl while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch41
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb (renamed from meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb)6
2 files changed, 44 insertions, 3 deletions
diff --git a/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch b/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch
new file mode 100644
index 000000000..c743b3edd
--- /dev/null
+++ b/meta-networking/recipes-protocols/mdns/files/0001-dns-sd-Include-missing-headers.patch
@@ -0,0 +1,41 @@
1From ea442b57f7a9bcd41d5b5bd1cafde4dbe5685d41 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 4 Nov 2021 07:31:32 -0700
4Subject: [PATCH] dns-sd: Include missing headers
5
6Fixes build on Musl
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Clients/dns-sd.c | 2 ++
12 1 file changed, 2 insertions(+)
13
14--- a/Clients/dns-sd.c
15+++ b/Clients/dns-sd.c
16@@ -58,11 +58,13 @@
17 //#define TEST_NEW_CLIENTSTUB 1
18
19 #include <ctype.h>
20+#include <stdarg.h> // For va_args
21 #include <stdio.h> // For stdout, stderr
22 #include <stdlib.h> // For exit()
23 #include <string.h> // For strlen(), strcpy()
24 #include <errno.h> // For errno, EINTR
25 #include <time.h>
26+#include <sys/param.h> // For MIN
27 #include <sys/types.h> // For u_char
28 #ifdef APPLE_OSX_mDNSResponder
29 #include <inttypes.h> // For PRId64
30--- a/mDNSPosix/nss_mdns.c
31+++ b/mDNSPosix/nss_mdns.c
32@@ -89,6 +89,9 @@
33
34 #include <dns_sd.h>
35
36+#if !defined(NETDB_INTERNAL)
37+# define NETDB_INTERNAL (-1)
38+#endif
39
40 //----------
41 // Public functions
diff --git a/meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
index c9bfef2d1..5c6d22020 100644
--- a/meta-networking/recipes-protocols/mdns/mdns_1310.40.42.bb
+++ b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
4LICENSE = "Apache-2.0 & BSD-3-Clause" 4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf" 5LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
6 6
7COMPATIBLE_HOST:libc-musl = 'null' 7DEPENDS:append:libc-musl = " musl-nscd"
8 8
9RPROVIDES:${PN} += "libdns_sd.so" 9RPROVIDES:${PN} += "libdns_sd.so"
10 10
@@ -21,9 +21,9 @@ SRC_URI = "https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${P
21 file://0009-Fix-possible-NULL-dereference.patch;patchdir=.. \ 21 file://0009-Fix-possible-NULL-dereference.patch;patchdir=.. \
22 file://0010-Handle-errors-from-socket-calls.patch;patchdir=.. \ 22 file://0010-Handle-errors-from-socket-calls.patch;patchdir=.. \
23 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch;patchdir=.. \ 23 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch;patchdir=.. \
24 file://0001-dns-sd-Include-missing-headers.patch;patchdir=.. \
24 " 25 "
25SRC_URI[md5sum] = "dfcfd4d7f29a56ec99e7df1d21db5e7b" 26SRC_URI[sha256sum] = "040f6495c18b9f0557bcf9e00cbcfc82b03405f5ba6963dc147730ca0ca90d6f"
26SRC_URI[sha256sum] = "bea29e1616cd56ccb8f88c0fad2bcdc4031f4deb2d899c793e2f27a8384f0b34"
27 27
28CVE_PRODUCT = "apple:mdnsresponder" 28CVE_PRODUCT = "apple:mdnsresponder"
29 29