summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-protocols
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-protocols')
-rw-r--r--meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb2
-rw-r--r--meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb18
-rw-r--r--meta-networking/recipes-protocols/quagga/quagga.inc16
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc26
-rw-r--r--meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb12
5 files changed, 37 insertions, 37 deletions
diff --git a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb b/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
index d17cc78a1..a7c10f797 100644
--- a/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
+++ b/meta-networking/recipes-protocols/accel-ppp/accel-ppp_git.bb
@@ -23,7 +23,7 @@ EXTRA_OECMAKE = " \
23 -DLOG_PGSQL=FALSE \ 23 -DLOG_PGSQL=FALSE \
24 -DRADIUS=FALSE \ 24 -DRADIUS=FALSE \
25 -DNETSNMP=FALSE \ 25 -DNETSNMP=FALSE \
26 " 26"
27FILES_${PN}-dbg += "/usr/lib/${BPN}/.debug/*" 27FILES_${PN}-dbg += "/usr/lib/${BPN}/.debug/*"
28 28
29PACKAGES =+ "${PN}-libs" 29PACKAGES =+ "${PN}-libs"
diff --git a/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
index c173af434..6a90578bc 100644
--- a/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
+++ b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
@@ -1,9 +1,9 @@
1SUMMARY = "Client for Microsoft PPTP VPNs" 1SUMMARY = "Client for Microsoft PPTP VPNs"
2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \ 2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
3 and OpenBSD client for the proprietary Microsoft Point-to-Point \ 3 and OpenBSD client for the proprietary Microsoft Point-to-Point \
4 Tunneling Protocol, PPTP. Allows connection to a PPTP based \ 4 Tunneling Protocol, PPTP. Allows connection to a PPTP based \
5 Virtual Private Network (VPN) as used by employers and some \ 5 Virtual Private Network (VPN) as used by employers and some \
6 cable and ADSL internet service providers." 6 cable and ADSL internet service providers."
7HOMEPAGE = "http://pptpclient.sourceforge.net" 7HOMEPAGE = "http://pptpclient.sourceforge.net"
8SECTION = "network" 8SECTION = "network"
9LICENSE = "GPLv2+" 9LICENSE = "GPLv2+"
@@ -14,7 +14,7 @@ PR = "r1"
14SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \ 14SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
15 file://options.pptp \ 15 file://options.pptp \
16 file://fix-parallel-build.patch \ 16 file://fix-parallel-build.patch \
17 " 17"
18 18
19SRC_URI[md5sum] = "4c3d19286a37459a632c7128c92a9857" 19SRC_URI[md5sum] = "4c3d19286a37459a632c7128c92a9857"
20SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d37694bc" 20SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d37694bc"
@@ -22,10 +22,10 @@ SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d3
22S = "${WORKDIR}/pptp-${PV}" 22S = "${WORKDIR}/pptp-${PV}"
23 23
24do_install() { 24do_install() {
25 install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8 25 install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
26 install -m 555 pptp ${D}${sbindir} 26 install -m 555 pptp ${D}${sbindir}
27 install -m 644 pptp.8 ${D}${mandir}/man8 27 install -m 644 pptp.8 ${D}${mandir}/man8
28 install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp 28 install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
29} 29}
30 30
31RDEPENDS_${PN} = "ppp" 31RDEPENDS_${PN} = "ppp"
diff --git a/meta-networking/recipes-protocols/quagga/quagga.inc b/meta-networking/recipes-protocols/quagga/quagga.inc
index b40c85803..160c458cc 100644
--- a/meta-networking/recipes-protocols/quagga/quagga.inc
+++ b/meta-networking/recipes-protocols/quagga/quagga.inc
@@ -136,33 +136,33 @@ pkg_postinst_${PN} () {
136 136
137# Stop apps before uninstall 137# Stop apps before uninstall
138pkg_prerm_${PN} () { 138pkg_prerm_${PN} () {
139 ${sysconfdir}/init.d/quagga stop 139 ${sysconfdir}/init.d/quagga stop
140} 140}
141 141
142pkg_prerm_${PN}-ospfd () { 142pkg_prerm_${PN}-ospfd () {
143 ${sysconfdir}/init.d/quagga stop ospfd 143 ${sysconfdir}/init.d/quagga stop ospfd
144} 144}
145 145
146pkg_prerm_${PN}-ospf6d () { 146pkg_prerm_${PN}-ospf6d () {
147 ${sysconfdir}/init.d/quagga stop ospf6d 147 ${sysconfdir}/init.d/quagga stop ospf6d
148} 148}
149 149
150pkg_prerm_${PN}-babeld () { 150pkg_prerm_${PN}-babeld () {
151 ${sysconfdir}/init.d/quagga stop babeld 151 ${sysconfdir}/init.d/quagga stop babeld
152} 152}
153 153
154pkg_prerm_${PN}-bgpd () { 154pkg_prerm_${PN}-bgpd () {
155 ${sysconfdir}/init.d/quagga stop bgpd 155 ${sysconfdir}/init.d/quagga stop bgpd
156} 156}
157 157
158pkg_prerm_${PN}-ripd () { 158pkg_prerm_${PN}-ripd () {
159 ${sysconfdir}/init.d/quagga stop ripd 159 ${sysconfdir}/init.d/quagga stop ripd
160} 160}
161 161
162pkg_prerm_${PN}-ripngd () { 162pkg_prerm_${PN}-ripngd () {
163 ${sysconfdir}/init.d/quagga stop ripngd 163 ${sysconfdir}/init.d/quagga stop ripngd
164} 164}
165 165
166pkg_prerm_${PN}-isisd () { 166pkg_prerm_${PN}-isisd () {
167 ${sysconfdir}/init.d/quagga stop isisd 167 ${sysconfdir}/init.d/quagga stop isisd
168} 168}
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
index cea542732..f4ea2b826 100644
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
+++ b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
@@ -15,22 +15,22 @@ S = "${WORKDIR}/git"
15inherit update-rc.d 15inherit update-rc.d
16 16
17do_compile () { 17do_compile () {
18 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all 18 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
19} 19}
20 20
21do_install () { 21do_install () {
22 oe_runmake PREFIX="${D}${prefix}" install 22 oe_runmake PREFIX="${D}${prefix}" install
23 23
24 install -d ${D}${sysconfdir}/init.d 24 install -d ${D}${sysconfdir}/init.d
25 touch ${D}${sysconfdir}/xl2tpd.conf 25 touch ${D}${sysconfdir}/xl2tpd.conf
26 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd 26 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
27 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 27 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
28 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 28 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
29 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 29 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
30 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd 30 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
31 31
32 install -d ${D}${sysconfdir}/default 32 install -d ${D}${sysconfdir}/default
33 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd 33 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
34} 34}
35 35
36CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd" 36CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"
diff --git a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
index f755940f1..9307263c7 100644
--- a/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
+++ b/meta-networking/recipes-protocols/zeroconf/zeroconf_0.9.bb
@@ -25,10 +25,10 @@ SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2"
25SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b" 25SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b"
26 26
27do_install () { 27do_install () {
28 install -d ${D}${sbindir} 28 install -d ${D}${sbindir}
29 install -d ${D}${sysconfdir}/network/if-up.d 29 install -d ${D}${sysconfdir}/network/if-up.d
30 install -d ${D}${sysconfdir}/default 30 install -d ${D}${sysconfdir}/default
31 install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf 31 install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
32 install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf 32 install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
33 install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf 33 install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
34} 34}