summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/xl2tpd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-protocols/xl2tpd
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-protocols/xl2tpd')
-rw-r--r--meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc26
1 files changed, 13 insertions, 13 deletions
diff --git a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
index cea542732..f4ea2b826 100644
--- a/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
+++ b/meta-networking/recipes-protocols/xl2tpd/xl2tpd.inc
@@ -15,22 +15,22 @@ S = "${WORKDIR}/git"
15inherit update-rc.d 15inherit update-rc.d
16 16
17do_compile () { 17do_compile () {
18 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all 18 oe_runmake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" PREFIX="${prefix}" KERNELSRC=${STAGING_KERNEL_DIR} all
19} 19}
20 20
21do_install () { 21do_install () {
22 oe_runmake PREFIX="${D}${prefix}" install 22 oe_runmake PREFIX="${D}${prefix}" install
23 23
24 install -d ${D}${sysconfdir}/init.d 24 install -d ${D}${sysconfdir}/init.d
25 touch ${D}${sysconfdir}/xl2tpd.conf 25 touch ${D}${sysconfdir}/xl2tpd.conf
26 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd 26 install -m 0755 debian/xl2tpd.init ${D}${sysconfdir}/init.d/xl2tpd
27 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 27 sed -i 's!/usr/sbin/!${sbindir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
28 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 28 sed -i 's!/etc/!${sysconfdir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
29 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd 29 sed -i 's!/var/!${localstatedir}/!g' ${D}${sysconfdir}/init.d/xl2tpd
30 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd 30 sed -i 's!^PATH=.*!PATH=${base_sbindir}:${base_bindir}:${sbindir}:${bindir}!' ${D}${sysconfdir}/init.d/xl2tpd
31 31
32 install -d ${D}${sysconfdir}/default 32 install -d ${D}${sysconfdir}/default
33 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd 33 install -m 0644 debian/xl2tpd.default ${D}${sysconfdir}/default/xl2tpd
34} 34}
35 35
36CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd" 36CONFFILES_${PN} += "${sysconfdir}/xl2tpd.conf ${sysconfdir}/default/xl2tpd"