summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/pptp-linux
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-12-03 17:31:51 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2012-12-07 16:20:29 -0500
commit2cde4ab536a87c450092ccb89a2f2e2765ea89bc (patch)
tree6f00e3ddea87a1ef681df30a22565d9520e8535d /meta-networking/recipes-protocols/pptp-linux
parente4259f59e3e57e11624cc17f72416d535edd4df9 (diff)
downloadmeta-openembedded-2cde4ab536a87c450092ccb89a2f2e2765ea89bc.tar.gz
pptp-linux: add from OE-Classic, update and tidy up
* Update to 1.7.2 * Drop unnecessary override of do_compile * Make LICENSE more accurate * Add LIC_FILES_CHKSUM * Add SUMMARY * Minor formatting/ordering tweaks Based on a patch by Vladimir Redzhepoff <vladimir.redzhepoff@promwad.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-networking/recipes-protocols/pptp-linux')
-rw-r--r--meta-networking/recipes-protocols/pptp-linux/pptp-linux-1.7.2/options.pptp30
-rw-r--r--meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb29
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/pptp-linux/pptp-linux-1.7.2/options.pptp b/meta-networking/recipes-protocols/pptp-linux/pptp-linux-1.7.2/options.pptp
new file mode 100644
index 000000000..f446e22a6
--- /dev/null
+++ b/meta-networking/recipes-protocols/pptp-linux/pptp-linux-1.7.2/options.pptp
@@ -0,0 +1,30 @@
1#
2# Lock the port
3#
4lock
5
6#
7# We don't need the tunnel server to authenticate itself
8#
9noauth
10
11#
12# Turn off transmission protocols we know won't be used
13#
14nobsdcomp
15nodeflate
16
17#
18# We want MPPE
19# (option naming specific to ppp 2.4.0 with unofficial patch)
20#
21#mppe-40
22mppe-128
23#mppe-stateless
24
25#
26# We want a sane mtu/mru
27# (ppp 2.4.0 with unofficial patch)
28#
29#mtu 1000
30#mru 1000
diff --git a/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
new file mode 100644
index 000000000..ac3f8f664
--- /dev/null
+++ b/meta-networking/recipes-protocols/pptp-linux/pptp-linux_1.7.2.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Client for Microsoft PPTP VPNs"
2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
3 and OpenBSD client for the proprietary Microsoft Point-to-Point \
4 Tunneling Protocol, PPTP. Allows connection to a PPTP based \
5 Virtual Private Network (VPN) as used by employers and some \
6 cable and ADSL internet service providers."
7HOMEPAGE = "http://pptpclient.sourceforge.net"
8SECTION = "network"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
11
12PR = "r0"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
15 file://options.pptp"
16
17SRC_URI[md5sum] = "4c3d19286a37459a632c7128c92a9857"
18SRC_URI[sha256sum] = "e98ae0065d2a39fa3131654ff28cb7070e996f668ed6d0e7d9a445b8d37694bc"
19
20S = "${WORKDIR}/pptp-${PV}"
21
22do_install() {
23 install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
24 install -m 555 pptp ${D}${sbindir}
25 install -m 644 pptp.8 ${D}${mandir}/man8
26 install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
27}
28
29RDEPENDS_${PN} = "ppp"