diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-11-30 19:37:23 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-12-14 09:20:10 -0500 |
commit | 08492d166e8d8d3563a8aae47b05a02118e7f429 (patch) | |
tree | 88365db68e68dfeb18da7d4825ef86cd2b3b2f3d /meta-networking/recipes-protocols/dante | |
parent | 9db75b35431d3945489083c1e225419cbb3450f6 (diff) | |
download | meta-openembedded-08492d166e8d8d3563a8aae47b05a02118e7f429.tar.gz |
dante: Add recipe for 1.4.1
* Add packageconfig for krb5
* Require pam in distro
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-protocols/dante')
-rw-r--r-- | meta-networking/recipes-protocols/dante/dante_1.4.1.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/dante/dante_1.4.1.bb b/meta-networking/recipes-protocols/dante/dante_1.4.1.bb new file mode 100644 index 000000000..3b07ffe43 --- /dev/null +++ b/meta-networking/recipes-protocols/dante/dante_1.4.1.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SECTION = "console/utils" | ||
2 | SUMMARY = "A free SOCKS server" | ||
3 | DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\ | ||
4 | implementing RFC 1928 and related standards. It is a flexible product\ | ||
5 | that can be used to provide convenient and secure network\ | ||
6 | connectivity. Once installed, Dante can in most cases be made\ | ||
7 | transparent to clients, providing functionality somewhat similar to\ | ||
8 | what could be described as a non-transparent Layer 4 router." | ||
9 | HOMEPAGE = "http://www.inet.no/dante/" | ||
10 | |||
11 | LICENSE = "BSD-3-Clause" | ||
12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=221118dda731fe93a85d0ed973467249" | ||
13 | |||
14 | SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \ | ||
15 | " | ||
16 | SRC_URI[md5sum] = "68c2ce12119e12cea11a90c7a80efa8f" | ||
17 | SRC_URI[sha256sum] = "b6d232bd6fefc87d14bf97e447e4fcdeef4b28b16b048d804b50b48f261c4f53" | ||
18 | |||
19 | # without --without-gssapi, config.log will contain reference to /usr/lib | ||
20 | # as a consequence of GSSAPI path being set to /usr by default. | ||
21 | # --with-gssapi-path=PATH specify gssapi path | ||
22 | # --without-gssapi disable gssapi support | ||
23 | # --enable-release build prerelease as full release | ||
24 | EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}" | ||
25 | |||
26 | DEPENDS += "flex-native bison-native libpam" | ||
27 | |||
28 | inherit autotools-brokensep distro_features_check | ||
29 | |||
30 | REQUIRED_DISTRO_FEATURES = "pam" | ||
31 | |||
32 | EXTRA_AUTORECONF = "-I ${S}" | ||
33 | |||
34 | PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap" | ||
35 | PACKAGECONFIG[krb5] = ",--disable-krb5,krb5" | ||
36 | |||
37 | PACKAGECONFIG ??= "" | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}${sysconfdir} | ||
41 | cp ${S}/example/sock[sd].conf ${D}${sysconfdir} | ||
42 | } | ||
43 | |||
44 | PACKAGES =+ "${PN}-sockd ${PN}-libdsocks " | ||
45 | |||
46 | FILES_${PN}-libdsocks = "${libdir}/libdsocks.so" | ||
47 | FILES_${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf" | ||
48 | |||
49 | INSANE_SKIP_${PN}-libdsocks = "dev-elf" | ||