diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-08-11 22:32:33 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-08-12 09:11:01 -0700 |
commit | 28ae6b2cea0d940d66764b102595f0fe5447e93a (patch) | |
tree | e9225f98468aa61cfe7689b4f26902d1c63067e9 /meta-networking/recipes-netkit | |
parent | 1ed7486a876d23bc3f9ec5b0af314bf450fa08af (diff) | |
download | meta-openembedded-28ae6b2cea0d940d66764b102595f0fe5447e93a.tar.gz |
netkit-rusers: Fix cross-build after glibc dropped rpc
Remove runtime checks from configure script which wont run correctly
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch | 71 | ||||
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb | 17 |
2 files changed, 61 insertions, 27 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch index 55926468d..3655a5716 100644 --- a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch +++ b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers/0001-Link-with-libtirpc.patch | |||
@@ -13,21 +13,69 @@ Upstream-Status: Pending | |||
13 | rup/rup.c | 2 +- | 13 | rup/rup.c | 2 +- |
14 | 4 files changed, 4 insertions(+), 13 deletions(-) | 14 | 4 files changed, 4 insertions(+), 13 deletions(-) |
15 | 15 | ||
16 | diff --git a/configure b/configure | ||
17 | index 85f6ca6..2d2d4b7 100755 | ||
18 | --- a/configure | 16 | --- a/configure |
19 | +++ b/configure | 17 | +++ b/configure |
20 | @@ -147,7 +147,7 @@ else | 18 | @@ -92,7 +92,6 @@ else |
19 | echo -n 'Checking if C compiler works... ' | ||
20 | if ( | ||
21 | $CC __conftest.c -o __conftest || exit 1 | ||
22 | - ./__conftest || exit 1 | ||
23 | ) >/dev/null 2>&1; then | ||
24 | echo 'yes' | ||
25 | else | ||
26 | @@ -146,8 +145,7 @@ else | ||
27 | |||
21 | fi | 28 | fi |
22 | 29 | ||
23 | LDFLAGS= | 30 | -LDFLAGS= |
24 | -LIBS= | 31 | -LIBS= |
25 | +LIBS="-ltirpc" | 32 | +LIBS="$LIBS -ltirpc" |
26 | 33 | ||
27 | rm -f __conftest* | 34 | rm -f __conftest* |
28 | 35 | ||
29 | diff --git a/rpc.rusersd/rusers_proc.c b/rpc.rusersd/rusers_proc.c | 36 | @@ -172,13 +170,11 @@ int main() { |
30 | index 9ae6306..f9e237c 100644 | 37 | EOF |
38 | if ( | ||
39 | $CC $CFLAGS __conftest.c -o __conftest || exit 1 | ||
40 | - ./__conftest || exit 1 | ||
41 | ) >/dev/null 2>&1; then | ||
42 | echo 'yes' | ||
43 | else | ||
44 | if ( | ||
45 | $CC $CFLAGS -D__USE_BSD_SIGNAL __conftest.c -o __conftest || exit 1 | ||
46 | - ./__conftest || exit 1 | ||
47 | ) >/dev/null 2>&1; then | ||
48 | echo '-D__USE_BSD_SIGNAL' | ||
49 | CFLAGS="$CFLAGS -D__USE_BSD_SIGNAL" | ||
50 | @@ -231,7 +227,6 @@ if ( | ||
51 | else | ||
52 | if ( | ||
53 | $CC $CFLAGS -D_GNU_SOURCE __conftest.c -o __conftest || exit 1 | ||
54 | - ./__conftest || exit 1 | ||
55 | ) >/dev/null 2>&1; then | ||
56 | echo '-D_GNU_SOURCE' | ||
57 | CFLAGS="$CFLAGS -D_GNU_SOURCE" | ||
58 | @@ -262,20 +257,17 @@ int main() { | ||
59 | EOF | ||
60 | if ( | ||
61 | $CC $CFLAGS __conftest.c $LIBBSD -o __conftest || exit 1 | ||
62 | - ./__conftest || exit 1 | ||
63 | ) >/dev/null 2>&1; then | ||
64 | echo 'ok' | ||
65 | else | ||
66 | if ( | ||
67 | $CC $CFLAGS __conftest.c -lsnprintf $LIBBSD -o __conftest || exit 1 | ||
68 | - ./__conftest || exit 1 | ||
69 | ) >/dev/null 2>&1; then | ||
70 | echo '-lsnprintf' | ||
71 | LIBS="$LIBS -lsnprintf" | ||
72 | else | ||
73 | if ( | ||
74 | $CC $CFLAGS __conftest.c -ldb $LIBBSD -o __conftest || exit 1 | ||
75 | - ./__conftest || exit 1 | ||
76 | ) >/dev/null 2>&1; then | ||
77 | echo '-ldb' | ||
78 | LIBS="$LIBS -ldb" | ||
31 | --- a/rpc.rusersd/rusers_proc.c | 79 | --- a/rpc.rusersd/rusers_proc.c |
32 | +++ b/rpc.rusersd/rusers_proc.c | 80 | +++ b/rpc.rusersd/rusers_proc.c |
33 | @@ -57,12 +57,7 @@ char rp_rcsid[] = | 81 | @@ -57,12 +57,7 @@ char rp_rcsid[] = |
@@ -44,8 +92,6 @@ index 9ae6306..f9e237c 100644 | |||
44 | 92 | ||
45 | void rusers_service(struct svc_req *rqstp, SVCXPRT *transp); | 93 | void rusers_service(struct svc_req *rqstp, SVCXPRT *transp); |
46 | 94 | ||
47 | diff --git a/rpc.rusersd/rusersd.c b/rpc.rusersd/rusersd.c | ||
48 | index 762be9b..dd355ac 100644 | ||
49 | --- a/rpc.rusersd/rusersd.c | 95 | --- a/rpc.rusersd/rusersd.c |
50 | +++ b/rpc.rusersd/rusersd.c | 96 | +++ b/rpc.rusersd/rusersd.c |
51 | @@ -38,11 +38,7 @@ char rusersd_rcsid[] = | 97 | @@ -38,11 +38,7 @@ char rusersd_rcsid[] = |
@@ -61,11 +107,9 @@ index 762be9b..dd355ac 100644 | |||
61 | 107 | ||
62 | #include "../version.h" | 108 | #include "../version.h" |
63 | 109 | ||
64 | diff --git a/rup/rup.c b/rup/rup.c | ||
65 | index e5669ff..887f89d 100644 | ||
66 | --- a/rup/rup.c | 110 | --- a/rup/rup.c |
67 | +++ b/rup/rup.c | 111 | +++ b/rup/rup.c |
68 | @@ -48,7 +48,7 @@ char rcsid[] = "$Id: rup.c,v 1.8 2000/07/22 19:51:40 dholland Exp $"; | 112 | @@ -48,7 +48,7 @@ char rcsid[] = "$Id: rup.c,v 1.8 2000/07 |
69 | 113 | ||
70 | #undef FSHIFT /* Use protocol's shift and scale values */ | 114 | #undef FSHIFT /* Use protocol's shift and scale values */ |
71 | #undef FSCALE | 115 | #undef FSCALE |
@@ -74,6 +118,3 @@ index e5669ff..887f89d 100644 | |||
74 | 118 | ||
75 | #include "../version.h" | 119 | #include "../version.h" |
76 | 120 | ||
77 | -- | ||
78 | 2.17.0 | ||
79 | |||
diff --git a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb index 77d739d72..296ebcad2 100644 --- a/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb +++ b/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb | |||
@@ -4,7 +4,7 @@ HOMEPAGE = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit" | |||
4 | SECTION = "net" | 4 | SECTION = "net" |
5 | LICENSE = "BSD" | 5 | LICENSE = "BSD" |
6 | LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e" | 6 | LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e" |
7 | DEPENDS = " tcp-wrappers libtirpc rpcbind rpcsvc-proto-native" | 7 | DEPENDS = " tcp-wrappers libtirpc rpcbind rpcsvc-proto rpcsvc-proto-native" |
8 | 8 | ||
9 | SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ | 9 | SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ |
10 | http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ | 10 | http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ |
@@ -17,16 +17,12 @@ SRC_URI[archive.sha256sum] = "f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bb | |||
17 | SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc" | 17 | SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc" |
18 | SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067" | 18 | SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067" |
19 | 19 | ||
20 | inherit autotools-brokensep | ||
21 | |||
22 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" | 20 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
23 | LIBS += "-ltirpc" | 21 | |
22 | EXTRA_OEMAKE = "RUSERSX=${STAGING_INCDIR}/rpcsvc/rusers.x" | ||
24 | 23 | ||
25 | do_configure () { | 24 | do_configure () { |
26 | ./configure --prefix=${prefix} | 25 | ./configure --prefix=${prefix} --installroot=${D} --with-c-compiler="${CC}" |
27 | echo "LDFLAGS=${LDFLAGS}" >> MCONFIG | ||
28 | echo "USE_GLIBC=1" >> MCONFIG | ||
29 | echo "LIBS=${LIBS}" >> MCONFIG | ||
30 | } | 26 | } |
31 | 27 | ||
32 | do_install () { | 28 | do_install () { |
@@ -62,9 +58,6 @@ EOF | |||
62 | install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd | 58 | install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd |
63 | } | 59 | } |
64 | 60 | ||
65 | |||
66 | INSANE_SKIP_${PN} = "already-stripped" | ||
67 | |||
68 | PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg" | 61 | PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg" |
69 | FILES_${PN}-client = "${bindir}/*" | 62 | FILES_${PN}-client = "${bindir}/*" |
70 | FILES_${PN}-server = "${sbindir}/* ${sysconfdir}" | 63 | FILES_${PN}-server = "${sbindir}/* ${sysconfdir}" |
@@ -72,7 +65,7 @@ FILES_${PN}-doc = "${mandir}" | |||
72 | FILES_${PN}-dbg = "${prefix}/src/debug \ | 65 | FILES_${PN}-dbg = "${prefix}/src/debug \ |
73 | ${bindir}/.debug ${sbindir}/.debug" | 66 | ${bindir}/.debug ${sbindir}/.debug" |
74 | 67 | ||
75 | RDEPENDS_${PN}-server = "tcp-wrappers xinetd rpcbind" | 68 | RDEPENDS_${PN}-server += "tcp-wrappers xinetd rpcbind" |
76 | 69 | ||
77 | # http://errors.yoctoproject.org/Errors/Details/186962/ | 70 | # http://errors.yoctoproject.org/Errors/Details/186962/ |
78 | EXCLUDE_FROM_WORLD_libc-musl = "1" | 71 | EXCLUDE_FROM_WORLD_libc-musl = "1" |