diff options
author | Armin Kuster <akuster808@gmail.com> | 2014-12-01 17:49:56 -0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2014-12-03 16:30:57 -0500 |
commit | 9bacae2ff83c7f89be184c48eb981861b1e7c68b (patch) | |
tree | 0f5ffba4f386a8b4ddaf86c2c42e853984f5210e /meta-networking/recipes-netkit | |
parent | 9444c179d8aec0046c8b8df873e1eaffda4b3888 (diff) | |
download | meta-openembedded-9bacae2ff83c7f89be184c48eb981861b1e7c68b.tar.gz |
netkit-rpc: New package
this adds rpcinfo and rpcgen
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rpc/netkit-rpc/gcc4.patch | 39 | ||||
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rpc/netkit-rpc_0.17.bb | 38 |
2 files changed, 77 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc/gcc4.patch b/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc/gcc4.patch new file mode 100644 index 000000000..d54cea9fd --- /dev/null +++ b/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc/gcc4.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | This fixes an issue when building with gcc 4.x | ||
2 | |||
3 | https://github.com/openembedded/openembedded/tree/master/recipes/netkit-rpc/netkit-rpc | ||
4 | |||
5 | Upstream-status: Backported | ||
6 | |||
7 | Signed-off-By: Armin Kuster <akuster808@gmail.com> | ||
8 | |||
9 | --- netkit-rpc-0.17/rpcgen/rpc_cout.c~gcc4 | ||
10 | +++ netkit-rpc-0.17/rpcgen/rpc_cout.c | ||
11 | @@ -101,8 +101,6 @@ | ||
12 | case DEF_TYPEDEF: | ||
13 | emit_typedef(def); | ||
14 | break; | ||
15 | - default: | ||
16 | - /* can't happen */ | ||
17 | } | ||
18 | print_trailer(); | ||
19 | } | ||
20 | @@ -664,9 +662,6 @@ | ||
21 | decl->name,decl->array_max); | ||
22 | emit_single_in_line(decl,flag,REL_VECTOR); | ||
23 | f_print(fout,"\t\t }\n\t\t };\n"); | ||
24 | - | ||
25 | - default: | ||
26 | - /* ?... do nothing I guess */ | ||
27 | } | ||
28 | } | ||
29 | |||
30 | --- netkit-rpc-0.17/rpcgen/rpc_hout.c~gcc4 | ||
31 | +++ netkit-rpc-0.17/rpcgen/rpc_hout.c | ||
32 | @@ -106,8 +106,6 @@ | ||
33 | f_print(fout, "\n"); | ||
34 | pprogramdef(def); | ||
35 | break; | ||
36 | - default: | ||
37 | - /* ?... shouldn't happen I guess */ | ||
38 | } | ||
39 | } | ||
diff --git a/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc_0.17.bb b/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc_0.17.bb new file mode 100644 index 000000000..4d8d95ac3 --- /dev/null +++ b/meta-networking/recipes-netkit/netkit-rpc/netkit-rpc_0.17.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "netkit-rpc includes rpcinfo and rpcgen." | ||
2 | HOMEPAGE = "http://ftp.linux.org.uk/pub/linux/Networking/netkit" | ||
3 | SECTION = "networking" | ||
4 | LICENSE = "SPL-1.0" | ||
5 | LIC_FILES_CHKSUM = "file://rpcinfo/rpcinfo.c;beginline=2;endline=3;md5=3e6339e3ce266e1122c5ba293e04bc89" | ||
6 | |||
7 | SRC_URI = "http://sources.openembedded.org/${BPN}-${PV}.tar.gz \ | ||
8 | file://gcc4.patch" | ||
9 | SRC_URI[md5sum] = "67212720482ea1aea9182a98653a9642" | ||
10 | SRC_URI[sha256sum] = "421d63b414162237a72867061f1bd3e3752a0d962cd5d30b5e933ddad8a14d3b" | ||
11 | |||
12 | do_configure () { | ||
13 | ./configure --prefix=${prefix} | ||
14 | echo "LDFLAGS=${LDFLAGS}" > MCONFIG | ||
15 | echo "CC=${CC}" >> MCONFIG | ||
16 | echo "LD=${LD}" >> MCONFIG | ||
17 | echo "CFLAGS=${CFLAGS}" >> MCONFIG | ||
18 | echo "LDFLAGS=${LDFLAGS}" >> MCONFIG | ||
19 | } | ||
20 | |||
21 | do_compile () { | ||
22 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -d ${D}${bindir} | ||
27 | install -d ${D}${mandir}/man1 | ||
28 | install -d ${D}${mandir}/man8 | ||
29 | |||
30 | # remove strip flag | ||
31 | sed -i 's/install -s/install/' rpcinfo/Makefile | ||
32 | sed -i 's/install -s/install/' rpcgen/Makefile | ||
33 | |||
34 | oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \ | ||
35 | 'DAEMONMODE=0755' 'MANMODE=0644' \ | ||
36 | 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \ | ||
37 | 'MANDIR=${mandir}' install | ||
38 | } | ||