diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-03-29 17:04:03 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-03-29 17:32:21 -0700 |
commit | 4d01b009bb08a23f4eea64fcef329c321fbcf04e (patch) | |
tree | beac6b4f3488cf5272142c296d4959678f385fcd /meta-networking/recipes-netkit | |
parent | 1ba4d9baa9ad621df79265022f8d60e2d72bd0c7 (diff) | |
download | meta-openembedded-4d01b009bb08a23f4eea64fcef329c321fbcf04e.tar.gz |
netkit-rwho: Add logic to apply patches from tarball
This recipe fetches from debian archives, therefore we need logic to
apply the patches which are part of tarball
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-netkit')
-rw-r--r-- | meta-networking/recipes-netkit/netkit-rwho/netkit-rwho_0.17.bb | 34 |
1 files changed, 29 insertions, 5 deletions
diff --git a/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho_0.17.bb b/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho_0.17.bb index 60a8d95b0..ad543b0fb 100644 --- a/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho_0.17.bb +++ b/meta-networking/recipes-netkit/netkit-rwho/netkit-rwho_0.17.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "BSD-4-Clause" | |||
5 | LIC_FILES_CHKSUM = "file://rwho/rwho.c;beginline=2;endline=3;md5=5a85f13c0142d72fc378e00f15da5b9e" | 5 | LIC_FILES_CHKSUM = "file://rwho/rwho.c;beginline=2;endline=3;md5=5a85f13c0142d72fc378e00f15da5b9e" |
6 | 6 | ||
7 | SRC_URI = "${DEBIAN_MIRROR}/main/n/netkit-rwho/netkit-rwho_${PV}.orig.tar.gz;name=archive \ | 7 | SRC_URI = "${DEBIAN_MIRROR}/main/n/netkit-rwho/netkit-rwho_${PV}.orig.tar.gz;name=archive \ |
8 | ${DEBIAN_MIRROR}/main/n/netkit-rwho/netkit-rwho_${PV}-13.debian.tar.gz;name=patch13 \ | 8 | ${DEBIAN_MIRROR}/main/n/netkit-rwho/netkit-rwho_${PV}-13.debian.tar.gz;subdir=${BP};name=patch13 \ |
9 | file://rwhod \ | 9 | file://rwhod \ |
10 | file://rwhod.default \ | 10 | file://rwhod.default \ |
11 | file://0001-Add-missing-include-path-to-I-options.patch \ | 11 | file://0001-Add-missing-include-path-to-I-options.patch \ |
@@ -20,13 +20,37 @@ inherit autotools-brokensep useradd update-rc.d update-alternatives | |||
20 | 20 | ||
21 | CFLAGS += " -D_GNU_SOURCE" | 21 | CFLAGS += " -D_GNU_SOURCE" |
22 | 22 | ||
23 | debian_do_patch() { | 23 | # Unlike other Debian packages, net-tools *.diff.gz contains another series of |
24 | cd ${S} | 24 | # patches maintained by quilt. So manually apply them before applying other local |
25 | while read line; do patch -p1 < ${WORKDIR}/debian/patches/$line; done < ${WORKDIR}/debian/patches/series | 25 | # patches. Also remove all temp files before leaving, because do_patch() will pop |
26 | # up all previously applied patches in the start | ||
27 | do_patch[depends] += "quilt-native:do_populate_sysroot" | ||
28 | netkit_do_patch() { | ||
29 | cd ${S} | ||
30 | # it's important that we only pop the existing patches when they've | ||
31 | # been applied, otherwise quilt will climb the directory tree | ||
32 | # and reverse out some completely different set of patches | ||
33 | if [ -d ${S}/patches ]; then | ||
34 | # whilst this is the default directory, doing it like this | ||
35 | # defeats the directory climbing that quilt will otherwise | ||
36 | # do; note the directory must exist to defeat this, hence | ||
37 | # the test inside which we operate | ||
38 | QUILT_PATCHES=${S}/patches quilt pop -a | ||
39 | fi | ||
40 | if [ -d ${S}/.pc-${BPN} ]; then | ||
41 | rm -rf ${S}/.pc | ||
42 | mv ${S}/.pc-${BPN} ${S}/.pc | ||
43 | QUILT_PATCHES=${S}/debian/patches quilt pop -a | ||
44 | rm -rf ${S}/.pc ${S}/debian | ||
45 | fi | ||
46 | QUILT_PATCHES=${S}/debian/patches quilt push -a | ||
47 | mv ${S}/.pc ${S}/.pc-${BPN} | ||
26 | } | 48 | } |
27 | 49 | ||
50 | do_unpack[cleandirs] += "${S}" | ||
51 | |||
28 | python do_patch() { | 52 | python do_patch() { |
29 | bb.build.exec_func('debian_do_patch', d) | 53 | bb.build.exec_func('netkit_do_patch', d) |
30 | bb.build.exec_func('patch_do_patch', d) | 54 | bb.build.exec_func('patch_do_patch', d) |
31 | } | 55 | } |
32 | 56 | ||