diff options
author | Li xin <lixin.fnst@cn.fujitsu.com> | 2015-01-28 17:51:31 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-02-11 21:25:30 -0500 |
commit | 56e58865851a3160c49d9929011a0eccc9b0c8e2 (patch) | |
tree | 9da577f949475f71022dd67836281f59d77957d6 /meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb | |
parent | 2d9f8ffb490ea13c9ab70e8825ecb99d2ffefbcc (diff) | |
download | meta-openembedded-56e58865851a3160c49d9929011a0eccc9b0c8e2.tar.gz |
netkit-telnet: add new recipe
netkit-telnet includes the telnetd and client.
telnetd: daemon for telnet protocol.
telnet: client for telnet protocol.
Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb')
-rw-r--r-- | meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb | 52 |
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb new file mode 100644 index 000000000..a2dc1c270 --- /dev/null +++ b/meta-networking/recipes-netkit/netkit-telnet/netkit-telnet_0.17.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | DESCRIPTION = "netkit-telnet includes the telnet daemon and client." | ||
2 | SECTION = "base" | ||
3 | DEPENDS = "ncurses" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://telnet/telnet.cc;beginline=2;endline=3;md5=780868e7b566313e70cb701560ca95ef" | ||
6 | |||
7 | SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${BP}.tar.gz \ | ||
8 | file://To-aviod-buffer-overflow-in-telnet.patch \ | ||
9 | file://Warning-fix-in-the-step-of-install.patch \ | ||
10 | file://telnet-xinetd \ | ||
11 | " | ||
12 | |||
13 | EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \ | ||
14 | MANMODE=644 MANDIR=${mandir}" | ||
15 | |||
16 | do_configure () { | ||
17 | ./configure --prefix=${prefix} | ||
18 | echo "LDFLAGS=${LDFLAGS}" > MCONFIG | ||
19 | } | ||
20 | |||
21 | do_compile () { | ||
22 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet | ||
23 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' LIBS=-lutil SUB=telnetd | ||
24 | } | ||
25 | |||
26 | do_install () { | ||
27 | install -d ${D}${bindir} | ||
28 | install -m 0755 telnet/telnet ${D}${bindir}/telnet.${PN} | ||
29 | install -d ${D}${sbindir} | ||
30 | install -d ${D}${mandir}/man1 | ||
31 | install -d ${D}${mandir}/man5 | ||
32 | install -d ${D}${mandir}/man8 | ||
33 | oe_runmake SUB=telnetd install | ||
34 | rm -rf ${D}${mandir}/man1 | ||
35 | # fix up hardcoded paths | ||
36 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/telnet-xinetd | ||
37 | install -d ${D}/etc/xinetd.d/ | ||
38 | install -p -m644 ${WORKDIR}/telnet-xinetd ${D}/etc/xinetd.d/telnet | ||
39 | } | ||
40 | |||
41 | pkg_postinst_${PN} () { | ||
42 | #!/bin/sh | ||
43 | update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100 | ||
44 | } | ||
45 | |||
46 | pkg_prerm_${PN} () { | ||
47 | #!/bin/sh | ||
48 | update-alternatives --remove telnet telnet.${PN} 100 | ||
49 | } | ||
50 | |||
51 | SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36" | ||
52 | SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00" | ||