summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:04:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commitec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch)
treee16d2a838f4561d5538928a58f805e5f1373225a /meta-networking/recipes-kernel
parent6775acb048dabd624c5c8197b683aba45ed91569 (diff)
downloadmeta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/netmap/files/0001-testmmap-fix-compile-issue-with-gcc-5.x.patch33
-rw-r--r--meta-networking/recipes-kernel/netmap/files/makefile_fixup.patch97
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb92
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap.inc17
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap_git.bb37
5 files changed, 0 insertions, 276 deletions
diff --git a/meta-networking/recipes-kernel/netmap/files/0001-testmmap-fix-compile-issue-with-gcc-5.x.patch b/meta-networking/recipes-kernel/netmap/files/0001-testmmap-fix-compile-issue-with-gcc-5.x.patch
deleted file mode 100644
index ea36b1cd9..000000000
--- a/meta-networking/recipes-kernel/netmap/files/0001-testmmap-fix-compile-issue-with-gcc-5.x.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1Upstream-Status: Pending
2
3From c81bf54d6eb870286662a11d3b4a994717c47696 Mon Sep 17 00:00:00 2001
4From: Armin Kuster <akuster808@gmail.com>
5Date: Tue, 8 Sep 2015 05:36:27 -0700
6Subject: [PATCH] testmmap: fix compile issue with gcc 5.x
7
8this fixes:
9examples/testmmap.c:540:10: error: format '%ld' expects argument of type 'long int', but argument 3 has type 'ssize_t {aka const int}' [-Werror=format=]
10| printf("ring_ofs[%d] %ld\n", i, nifp->ring_ofs[i]);
11| ^
12
13Signed-off-by: Armin Kuster <akuster808@gmail.com>
14---
15 examples/testmmap.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/examples/testmmap.c b/examples/testmmap.c
19index d7f6acc..934489a 100644
20--- a/examples/testmmap.c
21+++ b/examples/testmmap.c
22@@ -537,7 +537,7 @@ do_if()
23 for (i = 0; i < 5; i++)
24 printf("spare1[%d] %u\n", i, nifp->ni_spare1[i]);
25 for (i = 0; i < (nifp->ni_tx_rings + nifp->ni_rx_rings + 2); i++)
26- printf("ring_ofs[%d] %ld\n", i, nifp->ring_ofs[i]);
27+ printf("ring_ofs[%d] %zd\n", i, nifp->ring_ofs[i]);
28 }
29
30 struct netmap_ring *
31--
322.3.5
33
diff --git a/meta-networking/recipes-kernel/netmap/files/makefile_fixup.patch b/meta-networking/recipes-kernel/netmap/files/makefile_fixup.patch
deleted file mode 100644
index b050bf001..000000000
--- a/meta-networking/recipes-kernel/netmap/files/makefile_fixup.patch
+++ /dev/null
@@ -1,97 +0,0 @@
1The makefile assumes building locally.
2
3Upstream Status: Inappropriate [Native]
4
5The configure is not auto-make based
6
7Signed-of-by: Armin Kuster <akuster@mvista.com>
8
9Index: LINUX/netmap.mak.in
10===================================================================
11--- a/LINUX/netmap.mak.in
12+++ b/LINUX/netmap.mak.in
13@@ -12,10 +12,9 @@ SRCDIR:=@SRCDIR@
14 # The following commands are needed to build the modules as out-of-tree,
15 # in fact the kernel sources path must be specified.
16
17-PWD ?= $(CURDIR)
18
19 # Additional compile flags (e.g. header location)
20-EXTRA_CFLAGS := -I$(PWD) -I$(SRCDIR) -I$(SRCDIR)/../sys -I$(SRCDIR)/../sys/dev -DCONFIG_NETMAP
21+EXTRA_CFLAGS := -I$(SRCDIR) -I$(SRCDIR)/../sys -I$(SRCDIR)/../sys/dev -DCONFIG_NETMAP
22 EXTRA_CFLAGS += -Wno-unused-but-set-variable
23 EXTRA_CFLAGS += $(foreach s,$(SUBSYS),-DCONFIG_NETMAP_$(shell echo $s|tr a-z- A-Z_))
24
25Index: LINUX/configure
26===================================================================
27--- a/LINUX/configure
28+++ b/LINUX/configure
29@@ -349,52 +349,6 @@ reset_tests() {
30 EOF
31 }
32
33-# run_tests: run all accumulated tests and exec the pertinent
34-# success/failure actions for each one.
35-run_tests() {
36- local t= # prevent -EOF to eat the make TAB
37- cat > $TMPDIR/Makefile <<-EOF
38- ifneq (\$(KERNELRELEASE),)
39- obj-m := $TESTOBJS
40- else
41- S_DRIVERS := $(drv print)
42- all: \$(S_DRIVERS:%=get-%)
43- $t \$(MAKE) -C $ksrc M=\$\$PWD $kopts
44-
45- -include $TOPDIR/drivers.mak
46- EOF
47- for d in $(drv print); do
48- cat >> $TMPDIR/Makefile <<-EOF
49- get-$d:
50- $t [ -z "\$($d-src)" ] || cp -Rp \$($d-src) \$(if \$($d-dst),\$($d-dst),.)
51- $t touch get-$d
52- EOF
53- done
54- echo endif >> $TMPDIR/Makefile
55- {
56- cat <<-EOF
57-##############################################################################
58-## BEGIN RUNNING TESTS: $(date)
59-##############################################################################
60-## Makefile:
61- EOF
62- cat $TMPDIR/Makefile
63- cat <<-EOF
64-##############################################################################
65- EOF
66- } >> config.log
67- (
68- cd $TMPDIR
69- make -k -j $(grep -c processor /proc/cpuinfo)
70- ) >> config.log
71- eval "$TESTPOSTPROC"
72- cat >> config.log <<-EOF
73-##############################################################################
74-## END RUNNING TESTS: $(date)
75-##############################################################################
76- EOF
77-}
78-
79 configh=netmap_linux_config.h
80 # succes/failure actions are expected to write some macros
81 # in netma_linux_config.h. The following functions can be
82@@ -619,7 +573,6 @@ configuration. Please check 'config.log'
83 reset_tests
84 rm -f drivers.mak
85 add_test true broken_buildsystem < /dev/null
86-run_tests
87
88 drvname2config() {
89 local name=$1
90@@ -1280,7 +1233,6 @@ cat > $configh <<-EOF
91 EOF
92
93 # the TESTPOSTPROC script will add macros to $configh
94-run_tests
95
96 define DRIVER_SUFFIX \"$drvsuffix\"
97
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
deleted file mode 100644
index 192ece0e9..000000000
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ /dev/null
@@ -1,92 +0,0 @@
1require netmap.inc
2
3DEPENDS = "virtual/kernel"
4do_configure[depends] += "virtual/kernel:do_shared_workdir"
5
6inherit module
7
8CLEANBROKEN = "1"
9
10export INSTALL_MOD_DIR="kernel/netmap-modules"
11
12EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
13 --kernel-sources=${STAGING_KERNEL_DIR} \
14 --install-mod-path=${D} \
15 --driver-suffix="-netmap" \
16 "
17
18# The driver builds are optional, but for deterministic builds,
19# we should be able to explicitly enable/disable the builds
20# for them in a proper place (maybe in BSP).
21# But we can't use PACKAGECONFIG since there is no option for
22# each driver, and the options are:
23# --no-drivers do not compile any driver
24# --no-drivers= do not compile the given drivers (comma sep.)
25# --drivers= only compile the given drivers (comma sep.)
26#
27# So use NETMAP_DRIVERS and the following python code to add proper
28# configs to EXTRA_OECONF.
29#
30# The default is no-drivers, and all supported drivers are listed
31# in NETMAP_ALL_DRIVERS.
32NETMAP_DRIVERS ??= ""
33NETMAP_ALL_DRIVERS = "ixgbe igb e1000e e1000 veth.c forcedeth.c virtio_net.c r8169.c"
34
35python __anonymous () {
36 drivers_list = d.getVar("NETMAP_DRIVERS").split()
37 all_drivers_list = d.getVar("NETMAP_ALL_DRIVERS").split()
38 config_drivers = "--drivers=" + ",".join(drivers_list)
39
40 extra_oeconf_drivers = bb.utils.contains_any('NETMAP_DRIVERS', all_drivers_list, config_drivers, '--no-drivers', d)
41 d.appendVar("EXTRA_OECONF", extra_oeconf_drivers)
42}
43
44LDFLAGS := "${@'${LDFLAGS}'.replace('-Wl,-O1', '')}"
45LDFLAGS := "${@'${LDFLAGS}'.replace('-Wl,--as-needed', '')}"
46
47do_configure () {
48 cd ${S}/LINUX
49 ./configure ${EXTRA_OECONF}
50}
51
52do_configure_append () {
53 cat >> ${S}/LINUX/netmap_linux_config.h <<EOF
54#define NETMAP_LINUX_HAVE_HRTIMER_MODE_REL
55#define NETMAP_LINUX_HAVE_HRTIMER_FORWARD_NOW
56#define NETMAP_LINUX_HAVE_PHYS_ADDR_T
57#define NETMAP_LINUX_HAVE_ACCESS_ONCE
58#define NETMAP_LINUX_HAVE_NETDEV_OPS
59#define NETMAP_LINUX_HAVE_INIT_NET
60#define NETMAP_LINUX_HAVE_LIVE_ADDR_CHANGE
61#define NETMAP_LINUX_HAVE_TX_SKB_SHARING
62#define NETMAP_LINUX_HAVE_UNLOCKED_IOCTL
63#define NETMAP_LINUX_HAVE_PERNET_OPS_ID
64#define NETMAP_LINUX_VIRTIO_FUNCTIONS
65#define NETMAP_LINUX_VIRTIO_FREE_PAGES
66#define NETMAP_LINUX_VIRTIO_GET_VRSIZE
67#define NETMAP_LINUX_TIMER_RTYPE enum hrtimer_restart
68#define NETMAP_LINUX_VIRTIO_MULTI_QUEUE
69#define NETMAP_LINUX_HAVE_E1000E_EXT_RXDESC
70#define NETMAP_LINUX_HAVE_E1000E_DOWN2
71EOF
72
73if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION') or "0", '3.17') < 0) else 'true' } ; then
74 echo OK
75 cat >> ${S}/LINUX/netmap_linux_config.h <<EOF
76#define NETMAP_LINUX_ALLOC_NETDEV_4ARGS
77EOF
78fi
79}
80
81do_compile () {
82 cd ${S}/LINUX
83 oe_runmake
84}
85
86do_install () {
87 cd ${S}/LINUX
88 oe_runmake install
89}
90
91# http://errors.yoctoproject.org/Errors/Details/83335/
92PNBLACKLIST[netmap-modules] ?= "BROKEN: not compatible with default kernel version 4.8 - the recipe will be removed on 2017-09-01 unless the issue is fixed"
diff --git a/meta-networking/recipes-kernel/netmap/netmap.inc b/meta-networking/recipes-kernel/netmap/netmap.inc
deleted file mode 100644
index ab33e765d..000000000
--- a/meta-networking/recipes-kernel/netmap/netmap.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "netmap and VALE - very fast packet I/O from userspace (FreeBSD/Linux)"
2DESCRIPTION= "NETMAP is a framework for very fast packet I/O from userspace. VALE is an equally fast in-kernel software switch using the netmap API. Both are implemented as a single kernel module for FreeBSD and Linux, and can deal with line rate on real or emulated 10 Gbit ports."
3SECTION = "networking"
4HOMEPAGE = "http://code.google.com/p/netmap/"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;beginline=13;endline=14;md5=56ae0b9c7ba0476ab9098de94c2714d6"
8
9SRCREV = "da9e19e69b84e4f6f8ae125f8d01b42a4abade6a"
10PV = "master+git${SRCPV}"
11
12SRC_URI = "git://github.com/luigirizzo/netmap.git"
13SRC_URI += "file://makefile_fixup.patch"
14
15S = "${WORKDIR}/git"
16
17COMPATIBLE_HOST = '(x86_64|i.86|mips|arm).*-linux'
diff --git a/meta-networking/recipes-kernel/netmap/netmap_git.bb b/meta-networking/recipes-kernel/netmap/netmap_git.bb
deleted file mode 100644
index 2d8509c74..000000000
--- a/meta-networking/recipes-kernel/netmap/netmap_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require netmap.inc
2
3DEPENDS = "netmap-modules"
4PACKAGE_ARCH = "${MACHINE_ARCH}"
5
6EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
7 --kernel-sources=${STAGING_KERNEL_DIR} \
8 --no-drivers \
9 --disable-generic \
10 --prefix=${prefix} \
11 --destdir=${D} \
12 --cc='${CC}' \
13 --ld='${LD}' \
14 "
15SRC_URI += "file://0001-testmmap-fix-compile-issue-with-gcc-5.x.patch"
16
17do_configure () {
18 cd ${S}/LINUX
19 ./configure ${EXTRA_OECONF}
20}
21
22do_compile () {
23 cd ${S}/LINUX
24 make apps
25}
26
27do_install () {
28 cd ${S}/LINUX
29 make install-apps DESTDIR=${D}
30}
31
32FILES_${PN} += "${bindir}"
33RDEPENDS_${PN} = "kernel-module-netmap"
34RRECOMMENDS_${PN} = "kernel-module-netmap"
35
36# http://errors.yoctoproject.org/Errors/Details/69733/
37PNBLACKLIST[netmap] ?= "BROKEN: Tries to build kernel module and fails, either it should be disabled or there should be dependency on kernel like in netmap-modules - the recipe will be removed on 2017-09-01 unless the issue is fixed"