summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/ebtables
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-networking/recipes-filter/ebtables
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-networking/recipes-filter/ebtables')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index d6d803add..78e069ac8 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -11,7 +11,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/ebtables/ebtables-v${PV}.tar.gz \
11 file://01debian_defaultconfig.patch \ 11 file://01debian_defaultconfig.patch \
12 file://ebtables.init \ 12 file://ebtables.init \
13 file://no-as-needed.patch \ 13 file://no-as-needed.patch \
14 " 14"
15 15
16SRC_URI[md5sum] = "506742a3d44b9925955425a659c1a8d0" 16SRC_URI[md5sum] = "506742a3d44b9925955425a659c1a8d0"
17SRC_URI[sha256sum] = "dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d" 17SRC_URI[sha256sum] = "dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d"
@@ -31,24 +31,24 @@ EXTRA_OEMAKE = " \
31 'CFLAGS=${CFLAGS}' \ 31 'CFLAGS=${CFLAGS}' \
32 'LDFLAGS=${LDFLAGS} -Wl,--no-as-needed' \ 32 'LDFLAGS=${LDFLAGS} -Wl,--no-as-needed' \
33 'LD=${LD}' \ 33 'LD=${LD}' \
34 " 34"
35 35
36do_install () { 36do_install () {
37 install -d ${D}${sysconfdir}/init.d 37 install -d ${D}${sysconfdir}/init.d
38 install -d ${D}${sysconfdir}/default 38 install -d ${D}${sysconfdir}/default
39 install -d ${D}${sysconfdir}/ebtables 39 install -d ${D}${sysconfdir}/ebtables
40 oe_runmake DESTDIR='${D}' install 40 oe_runmake DESTDIR='${D}' install
41 install -m 0755 ${WORKDIR}/ebtables.init ${D}/${sysconfdir}/init.d/ebtables 41 install -m 0755 ${WORKDIR}/ebtables.init ${D}/${sysconfdir}/init.d/ebtables
42 mv ${D}${sysconfdir}/default/ebtables-config ${D}${sysconfdir}/default/ebtables 42 mv ${D}${sysconfdir}/default/ebtables-config ${D}${sysconfdir}/default/ebtables
43 43
44 # Fix hardcoded paths in scripts 44 # Fix hardcoded paths in scripts
45 sed -i 's!/sbin/!${base_sbindir}/!g' ${D}/${sysconfdir}/init.d/ebtables 45 sed -i 's!/sbin/!${base_sbindir}/!g' ${D}/${sysconfdir}/init.d/ebtables
46 sed -i 's!/etc/!${sysconfdir}/!g' ${D}/${sysconfdir}/init.d/ebtables 46 sed -i 's!/etc/!${sysconfdir}/!g' ${D}/${sysconfdir}/init.d/ebtables
47 47
48 # The script ebtables-save refernces perl in exec_prefix, so 48 # The script ebtables-save refernces perl in exec_prefix, so
49 # move it to sbindir to avoid QA issue 49 # move it to sbindir to avoid QA issue
50 install -d ${D}/${sbindir} 50 install -d ${D}/${sbindir}
51 mv ${D}/${base_sbindir}/ebtables-save ${D}/${sbindir} 51 mv ${D}/${base_sbindir}/ebtables-save ${D}/${sbindir}
52} 52}
53 53
54CONFFILES_${PN} += "${sysconfdir}/default/ebtables" 54CONFFILES_${PN} += "${sysconfdir}/default/ebtables"