summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-11-07 13:22:03 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2018-01-08 11:58:56 -0500
commit4f3289fe4d5de73be7113110b4efc903a3c69e28 (patch)
treea87c548483d4b54a11a178d6ceea68fdf84c9836 /meta-networking/recipes-extended
parentf0764a12deb3a64c6824669ca41e0c07f4ab8080 (diff)
downloadmeta-openembedded-4f3289fe4d5de73be7113110b4efc903a3c69e28.tar.gz
corosync: 2.4.2 -> 2.4.3
Upgrade corosync from 2.4.2 to 2.4.3. * remove patch which is merged by upstream * remove gcc option '-fpie' by append configure cache value 'ap_cv_cc_pie=no' to fix TEXTREL QA issue for linker gold * disable autostart of corosync. It only works after configured and config file /etc/corosync/corosync.conf exists. * use bb.utils.filter * corosync init script requires command pidof. But pidof from busybox doesn't work well to filter the calling process itself, so update runtime dependency Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-extended')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch28
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.3.bb (renamed from meta-networking/recipes-extended/corosync/corosync_2.4.2.bb)21
2 files changed, 10 insertions, 39 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch b/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
deleted file mode 100644
index fe4b0793f..000000000
--- a/meta-networking/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 85ea47fedbc96ed9180e08b0d371d9966e3a88da Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 30 Aug 2017 17:28:55 -0700
4Subject: [PATCH] Include fcntl.h for F_* and O_* defines
5
6Fixes errors like
7utils.c:95:22: error: use of undeclared identifier 'O_WRONLY'
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 qdevices/utils.c | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/qdevices/utils.c b/qdevices/utils.c
15index 41850b8c..87090853 100644
16--- a/qdevices/utils.c
17+++ b/qdevices/utils.c
18@@ -39,6 +39,7 @@
19
20 #include <err.h>
21 #include <errno.h>
22+#include <fcntl.h>
23 #include <inttypes.h>
24 #include <libgen.h>
25 #include <stdio.h>
26--
272.14.1
28
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.3.bb
index 33e74e2ff..9673fa362 100644
--- a/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.3.bb
@@ -7,11 +7,10 @@ SECTION = "base"
7 7
8inherit autotools pkgconfig systemd useradd 8inherit autotools pkgconfig systemd useradd
9 9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \ 10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz"
11 file://0001-Include-fcntl.h-for-F_-and-O_-defines.patch \ 11
12 " 12SRC_URI[md5sum] = "bf0ede13018aadc8a046183bc593b0e0"
13SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f" 13SRC_URI[sha256sum] = "b1e7e422e8d2f7af8e5315fa329b1dbd1175fff32efaa55e8054584c80a2c597"
14SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9"
15 14
16LICENSE = "BSD" 15LICENSE = "BSD"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d" 16LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
@@ -22,7 +21,7 @@ SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \
22 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \ 21 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \
23 ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'corosync-qnetd.service', '', d)} \ 22 ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'corosync-qnetd.service', '', d)} \
24" 23"
25SYSTEMD_AUTO_ENABLE = "enable" 24SYSTEMD_AUTO_ENABLE = "disable"
26 25
27INITSCRIPT_NAME = "corosync-daemon" 26INITSCRIPT_NAME = "corosync-daemon"
28 27
@@ -37,7 +36,7 @@ PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma"
37PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" 36PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
38PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd" 37PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
39 38
40EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash" 39EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash ap_cv_cc_pie=no"
41EXTRA_OEMAKE = "tmpfilesdir_DATA=" 40EXTRA_OEMAKE = "tmpfilesdir_DATA="
42 41
43do_configure_prepend() { 42do_configure_prepend() {
@@ -55,22 +54,22 @@ do_install_append() {
55 install -d ${D}${sysconfdir}/default/volatiles 54 install -d ${D}${sysconfdir}/default/volatiles
56 echo "d root root 0755 ${localstatedir}/log/cluster none" > ${D}${sysconfdir}/default/volatiles/05_corosync 55 echo "d root root 0755 ${localstatedir}/log/cluster none" > ${D}${sysconfdir}/default/volatiles/05_corosync
57 56
58 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then 57 if [ ${@bb.utils.filter('PACKAGECONFIG', 'qnetd', d)} ]; then
59 chown -R coroqnetd:coroqnetd ${D}${sysconfdir}/${BPN}/qnetd 58 chown -R coroqnetd:coroqnetd ${D}${sysconfdir}/${BPN}/qnetd
60 echo "d coroqnetd coroqnetd 0770 /var/run/corosync-qnetd none" >> ${D}${sysconfdir}/default/volatiles/05_corosync 59 echo "d coroqnetd coroqnetd 0770 /var/run/corosync-qnetd none" >> ${D}${sysconfdir}/default/volatiles/05_corosync
61 fi 60 fi
62 61
63 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 62 if [ ${@bb.utils.filter('DISTRO_FEATURES','systemd',d)} ]; then
64 install -d ${D}${sysconfdir}/tmpfiles.d 63 install -d ${D}${sysconfdir}/tmpfiles.d
65 echo "d ${localstatedir}/log/cluster - - - -" > ${D}${sysconfdir}/tmpfiles.d/corosync.conf 64 echo "d ${localstatedir}/log/cluster - - - -" > ${D}${sysconfdir}/tmpfiles.d/corosync.conf
66 65
67 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then 66 if [ ${@bb.utils.filter('PACKAGECONFIG', 'qnetd', d)} ]; then
68 install -m 0644 ${S}/conf/tmpfiles.d/corosync-qnetd.conf ${D}${sysconfdir}/tmpfiles.d 67 install -m 0644 ${S}/conf/tmpfiles.d/corosync-qnetd.conf ${D}${sysconfdir}/tmpfiles.d
69 fi 68 fi
70 fi 69 fi
71} 70}
72 71
73RDEPENDS_${PN} += "bash" 72RDEPENDS_${PN} += "bash ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
74 73
75FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug" 74FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
76FILES_${PN}-doc += "${datadir}/snmp/mibs/COROSYNC-MIB.txt" 75FILES_${PN}-doc += "${datadir}/snmp/mibs/COROSYNC-MIB.txt"