summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-08-20 14:19:04 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-23 22:00:39 -0700
commitb43314b6a50dae3038c098adee746171e8609ed9 (patch)
tree08fb364f8ef50a99beb99036a220cd6e71c00e44 /meta-networking/recipes-daemons
parent8500bbbf2c426a42882a80f35d1649f686032417 (diff)
downloadmeta-openembedded-b43314b6a50dae3038c098adee746171e8609ed9.tar.gz
vsftpd: Upgrade to 3.0.5
Drop 2 seccomp patches as seccomp sandbox policy tweaks in new version [1]. [1] https://security.appspot.com/vsftpd/Changelog.txt Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch51
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-vsftpd-allow-syscalls-in-the-seccomp-sandbox.patch46
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-destdir.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-destdir.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-libs.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-strip.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-strip.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam-with-tcp_wrappers.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam-with-tcp_wrappers.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-2.1.0-filter.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-2.1.0-filter.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-tcp_wrappers-support.patch (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-tcp_wrappers-support.patch)0
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.5.bb (renamed from meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb)5
11 files changed, 1 insertions, 101 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch
deleted file mode 100644
index 29ce85cc1..000000000
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From 7bc261076ec94efa3197beaca39eba095d162b5e Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Fri, 26 Feb 2021 16:32:27 +0800
4Subject: [PATCH] seccompsandbox.c: allow newfstatat and pselect6 syscalls in
5 the seccomp sandbox
6
7Allow newfstatat and pselect6 in the seccomp sanbox for glibc 2.33.
8
9Fixes the following OOPS error:
10root@qemux86-64:~# tnftp 192.168.1.1
11Connected to 192.168.1.1.
12220 (vsFTPd 3.0.3)
13Name (192.168.1.1:root): anonymous
14331 Please specify the password.
15Password:
16230 Login successful.
17Remote system type is UNIX.
18Using binary mode to transfer files.
19ftp> ls
20OOPS: priv_sock_get_cmd
21
22Upstream-Status: Pending
23
24Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
25---
26 seccompsandbox.c | 2 ++
27 1 file changed, 2 insertions(+)
28
29diff --git a/seccompsandbox.c b/seccompsandbox.c
30index 377c50e..f601241 100644
31--- a/seccompsandbox.c
32+++ b/seccompsandbox.c
33@@ -267,6 +267,7 @@ seccomp_sandbox_setup_data_connections()
34 3, IPPROTO_TCP);
35 allow_nr(__NR_bind);
36 allow_nr(__NR_select);
37+ allow_nr(__NR_pselect6);
38 if (tunable_port_enable)
39 {
40 allow_nr(__NR_connect);
41@@ -411,6 +412,7 @@ seccomp_sandbox_setup_postlogin(const struct vsf_session* p_sess)
42 allow_nr(__NR_getdents);
43 allow_nr(__NR_getdents64);
44 allow_nr(__NR_sysinfo);
45+ allow_nr(__NR_newfstatat);
46 /* Misc */
47 allow_nr(__NR_umask);
48
49--
502.17.1
51
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-vsftpd-allow-syscalls-in-the-seccomp-sandbox.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-vsftpd-allow-syscalls-in-the-seccomp-sandbox.patch
deleted file mode 100644
index 7573c967f..000000000
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-vsftpd-allow-syscalls-in-the-seccomp-sandbox.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From dd353303f62d1dfe32cb000e482616b021708fbe Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 29 Nov 2018 00:47:34 -0800
4Subject: [PATCH] vsftpd: allow syscalls in the seccomp sandbox
5
6* Allow sysinfo() and getdents64 in the seccomp
7 sandbox otherwise comes below OOPS: priv_sock_get_cmd
8 as the syscall sysinfo() and getdents64 not allowed
9
10root@qemux86-64:~# tnftp 192.168.1.1
11Connected to 192.168.1.1.
12220 (vsFTPd 3.0.3)
13Name (192.168.1.1:root): anonymous
14331 Please specify the password.
15Password:
16230 Login successful.
17Remote system type is UNIX.
18Using binary mode to transfer files.
19ftp> prompt
20Interactive mode off.
21ftp> mget small*
22OOPS: priv_sock_get_cmd
23
24Upstream-Status: Pending
25
26Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
27---
28 seccompsandbox.c | 2 ++
29 1 file changed, 2 insertions(+)
30
31diff --git a/seccompsandbox.c b/seccompsandbox.c
32index 2c350a9..377c50e 100644
33--- a/seccompsandbox.c
34+++ b/seccompsandbox.c
35@@ -409,6 +409,8 @@ seccomp_sandbox_setup_postlogin(const struct vsf_session* p_sess)
36 allow_nr(__NR_getcwd);
37 allow_nr(__NR_chdir);
38 allow_nr(__NR_getdents);
39+ allow_nr(__NR_getdents64);
40+ allow_nr(__NR_sysinfo);
41 /* Misc */
42 allow_nr(__NR_umask);
43
44--
452.17.1
46
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch
index d81c94a4a..d81c94a4a 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-destdir.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-destdir.patch
index 5ad5c14e7..5ad5c14e7 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-destdir.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-destdir.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-libs.patch
index d2e58a325..d2e58a325 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-libs.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-libs.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-strip.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-strip.patch
index e59607388..e59607388 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/makefile-strip.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/makefile-strip.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam-with-tcp_wrappers.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam-with-tcp_wrappers.patch
index a4387c132..a4387c132 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam-with-tcp_wrappers.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam-with-tcp_wrappers.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam.patch
index cf0d68e27..cf0d68e27 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/nopam.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/nopam.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-2.1.0-filter.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-2.1.0-filter.patch
index 590eb5857..590eb5857 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-2.1.0-filter.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-2.1.0-filter.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-tcp_wrappers-support.patch b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-tcp_wrappers-support.patch
index c558aee0a..c558aee0a 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.3/vsftpd-tcp_wrappers-support.patch
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd-3.0.5/vsftpd-tcp_wrappers-support.patch
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.5.bb
index cf3d7fc96..08238c1a3 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.5.bb
@@ -18,11 +18,9 @@ SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
18 file://volatiles.99_vsftpd \ 18 file://volatiles.99_vsftpd \
19 file://vsftpd.service \ 19 file://vsftpd.service \
20 file://vsftpd-2.1.0-filter.patch \ 20 file://vsftpd-2.1.0-filter.patch \
21 file://0001-vsftpd-allow-syscalls-in-the-seccomp-sandbox.patch \
22 ${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)} \ 21 ${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)} \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)} \ 22 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)} \
24 file://0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch \ 23 file://0001-sysdeputil.c-Fix-with-musl-which-does-not-have-utmpx.patch \
25 file://0001-seccompsandbox.c-allow-newfstatat-and-pselect6-sysca.patch \
26 " 24 "
27 25
28UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/v/vsftpd/" 26UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/v/vsftpd/"
@@ -31,8 +29,7 @@ UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.orig\.tar"
31LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271 \ 29LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271 \
32 file://COPYRIGHT;md5=04251b2eb0f298dae376d92454f6f72e \ 30 file://COPYRIGHT;md5=04251b2eb0f298dae376d92454f6f72e \
33 file://LICENSE;md5=654df2042d44b8cac8a5654fc5be63eb" 31 file://LICENSE;md5=654df2042d44b8cac8a5654fc5be63eb"
34SRC_URI[md5sum] = "da119d084bd3f98664636ea05b5bb398" 32SRC_URI[sha256sum] = "26b602ae454b0ba6d99ef44a09b6b9e0dfa7f67228106736df1f278c70bc91d3"
35SRC_URI[sha256sum] = "9d4d2bf6e6e2884852ba4e69e157a2cecd68c5a7635d66a3a8cf8d898c955ef7"
36 33
37 34
38PACKAGECONFIG ??= "tcp-wrappers" 35PACKAGECONFIG ??= "tcp-wrappers"