diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-07-16 15:52:43 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-07-17 10:15:51 -0700 |
commit | 7d64ce0490e2a8799ab2f64a24b4f63094da4f08 (patch) | |
tree | e3810f3ef58af5a27760d11023b34ddd3a746e5a /meta-networking/recipes-daemons | |
parent | d774c880236ee67f0e15455c3ef2171c8d0fef40 (diff) | |
download | meta-openembedded-7d64ce0490e2a8799ab2f64a24b4f63094da4f08.tar.gz |
autofs: Upgrade to 5.1.7
License-Update: correct fsf address [1]
- Drop upstreamed autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch
- Forward port remaining patches
- Package libautofs.so which is new
- Add a patch to fix build on musl systems
- Detailed ChangeLog [2]
[1] https://git.kernel.org/pub/scm/linux/storage/autofs/autofs.git/commit/COPYING?id=b74dcdd3f6b05522388729141c29286829c302fc
[2] https://www.spinics.net/lists/autofs/msg02344.html
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/0001-Define-__SWORD_TYPE-if-undefined.patch | 124 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch | 7 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/0002-Replace-__S_IEXEC-with-S_IEXEC.patch | 19 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch | 30 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/fix-the-YACC-rule-to-fix-a-building-failure.patch | 43 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch | 28 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb (renamed from meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb) | 15 |
7 files changed, 175 insertions, 91 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-Define-__SWORD_TYPE-if-undefined.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-Define-__SWORD_TYPE-if-undefined.patch new file mode 100644 index 000000000..117b1e58a --- /dev/null +++ b/meta-networking/recipes-daemons/autofs/autofs/0001-Define-__SWORD_TYPE-if-undefined.patch | |||
@@ -0,0 +1,124 @@ | |||
1 | From 9fe90ab1e333b2e2bed370ff13ba552eb54c3aaf Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 17 Jul 2021 09:56:28 -0700 | ||
4 | Subject: [PATCH] Define __SWORD_TYPE if undefined | ||
5 | |||
6 | These fixes are inspired when building autofs on musl | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | daemon/automount.c | 20 ++++++++++++++------ | ||
12 | include/hash.h | 5 +++++ | ||
13 | lib/log.c | 6 +++++- | ||
14 | 3 files changed, 24 insertions(+), 7 deletions(-) | ||
15 | |||
16 | diff --git a/daemon/automount.c b/daemon/automount.c | ||
17 | index e476f6b..3a1514b 100644 | ||
18 | --- a/daemon/automount.c | ||
19 | +++ b/daemon/automount.c | ||
20 | @@ -1,7 +1,7 @@ | ||
21 | /* ----------------------------------------------------------------------- * | ||
22 | * | ||
23 | * automount.c - Linux automounter daemon | ||
24 | - * | ||
25 | + * | ||
26 | * Copyright 1997 Transmeta Corporation - All Rights Reserved | ||
27 | * Copyright 1999-2000 Jeremy Fitzhardinge <jeremy@goop.org> | ||
28 | * Copyright 2001-2005 Ian Kent <raven@themaw.net> | ||
29 | @@ -11,7 +11,7 @@ | ||
30 | * the Free Software Foundation, Inc., 675 Mass Ave, Cambridge MA 02139, | ||
31 | * USA; either version 2 of the License, or (at your option) any later | ||
32 | * version. | ||
33 | - * | ||
34 | + * | ||
35 | * This program is distributed in the hope that it will be useful, | ||
36 | * but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
37 | * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
38 | @@ -40,6 +40,14 @@ | ||
39 | #include <systemd/sd-daemon.h> | ||
40 | #endif | ||
41 | |||
42 | +#ifndef __SWORD_TYPE | ||
43 | +# if __WORDSIZE == 32 /* System word size */ | ||
44 | +# define __SWORD_TYPE int | ||
45 | +# else /* __WORDSIZE == 64 */ | ||
46 | +# define __SWORD_TYPE long int | ||
47 | +# endif | ||
48 | +#endif | ||
49 | + | ||
50 | #include "automount.h" | ||
51 | #if defined(LIBXML2_WORKAROUND) || defined(TIRPC_WORKAROUND) | ||
52 | #include <dlfcn.h> | ||
53 | @@ -282,7 +290,7 @@ int rmdir_path(struct autofs_point *ap, const char *path, dev_t dev) | ||
54 | dev, buf, st.st_dev); | ||
55 | return -1; | ||
56 | } | ||
57 | - | ||
58 | + | ||
59 | /* | ||
60 | * Last element of path may be a symbolic link; all others | ||
61 | * are directories (and the last directory element is | ||
62 | @@ -455,7 +463,7 @@ int count_mounts(struct autofs_point *ap, const char *path, dev_t dev) | ||
63 | |||
64 | counter.count = 0; | ||
65 | counter.dev = dev; | ||
66 | - | ||
67 | + | ||
68 | if (walk_tree(path, counter_fn, 1, ap, &counter) == -1) | ||
69 | return -1; | ||
70 | |||
71 | @@ -811,7 +819,7 @@ static char *automount_path_to_fifo(unsigned logopt, const char *path) | ||
72 | /* | ||
73 | * An automount path can be made up of subdirectories. So, to | ||
74 | * create the fifo name, we will just replace instances of '/' with | ||
75 | - * '-'. | ||
76 | + * '-'. | ||
77 | */ | ||
78 | p = fifo_name + strlen(fifodir); | ||
79 | while (*p != '\0') { | ||
80 | @@ -1640,7 +1648,7 @@ static void return_start_status(void *arg) | ||
81 | sc->done = 1; | ||
82 | |||
83 | /* | ||
84 | - * Startup condition mutex must be locked during | ||
85 | + * Startup condition mutex must be locked during | ||
86 | * the startup process. | ||
87 | */ | ||
88 | status = pthread_cond_signal(&sc->cond); | ||
89 | diff --git a/include/hash.h b/include/hash.h | ||
90 | index 2447f29..6f0dee6 100644 | ||
91 | --- a/include/hash.h | ||
92 | +++ b/include/hash.h | ||
93 | @@ -5,6 +5,11 @@ | ||
94 | |||
95 | #include <sys/types.h> | ||
96 | #include <stdint.h> | ||
97 | +#include <linux/stddef.h> | ||
98 | + | ||
99 | +#ifndef __GLIBC__ | ||
100 | +#include <sys/reg.h> | ||
101 | +#endif | ||
102 | |||
103 | /* | ||
104 | * The "GOLDEN_RATIO_PRIME" is used in ifs/btrfs/brtfs_inode.h and | ||
105 | diff --git a/lib/log.c b/lib/log.c | ||
106 | index 0cb47d7..39b1e3b 100644 | ||
107 | --- a/lib/log.c | ||
108 | +++ b/lib/log.c | ||
109 | @@ -38,7 +38,11 @@ static char *prepare_attempt_prefix(const char *msg) | ||
110 | char buffer[ATTEMPT_ID_SIZE + 1]; | ||
111 | char *prefixed_msg = NULL; | ||
112 | |||
113 | - attempt_id = pthread_getspecific(key_thread_attempt_id); | ||
114 | + if (key_thread_attempt_id) { | ||
115 | + attempt_id = pthread_getspecific(key_thread_attempt_id); | ||
116 | + } else { | ||
117 | + attempt_id = 0; | ||
118 | + } | ||
119 | if (attempt_id) { | ||
120 | int len = sizeof(buffer) + 1 + strlen(msg) + 1; | ||
121 | |||
122 | -- | ||
123 | 2.32.0 | ||
124 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch index b991acad3..d5ea417fb 100644 --- a/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch +++ b/meta-networking/recipes-daemons/autofs/autofs/0001-Do-not-hardcode-path-for-pkg.m4.patch | |||
@@ -15,12 +15,10 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com> | |||
15 | configure.in | 2 +- | 15 | configure.in | 2 +- |
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | 16 | 1 file changed, 1 insertion(+), 1 deletion(-) |
17 | 17 | ||
18 | diff --git a/configure.in b/configure.in | ||
19 | index 493b9f1..268d06b 100644 | ||
20 | --- a/configure.in | 18 | --- a/configure.in |
21 | +++ b/configure.in | 19 | +++ b/configure.in |
22 | @@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl | 20 | @@ -12,7 +12,7 @@ define([AC_CACHE_SAVE], )dnl |
23 | AC_INIT(.autofs-5.1.6) | 21 | AC_INIT(.autofs-5.1.7) |
24 | 22 | ||
25 | # for pkg-config macros | 23 | # for pkg-config macros |
26 | -m4_include([/usr/share/aclocal/pkg.m4]) | 24 | -m4_include([/usr/share/aclocal/pkg.m4]) |
@@ -28,6 +26,3 @@ index 493b9f1..268d06b 100644 | |||
28 | 26 | ||
29 | # | 27 | # |
30 | # autofs installs by default in /usr | 28 | # autofs installs by default in /usr |
31 | -- | ||
32 | 2.7.4 | ||
33 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs/0002-Replace-__S_IEXEC-with-S_IEXEC.patch b/meta-networking/recipes-daemons/autofs/autofs/0002-Replace-__S_IEXEC-with-S_IEXEC.patch index e7fdd10aa..1a2eb4fc2 100644 --- a/meta-networking/recipes-daemons/autofs/autofs/0002-Replace-__S_IEXEC-with-S_IEXEC.patch +++ b/meta-networking/recipes-daemons/autofs/autofs/0002-Replace-__S_IEXEC-with-S_IEXEC.patch | |||
@@ -16,29 +16,27 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com> | |||
16 | modules/lookup_multi.c | 2 +- | 16 | modules/lookup_multi.c | 2 +- |
17 | 2 files changed, 4 insertions(+), 4 deletions(-) | 17 | 2 files changed, 4 insertions(+), 4 deletions(-) |
18 | 18 | ||
19 | diff --git a/daemon/lookup.c b/daemon/lookup.c | ||
20 | index 18df935..d35d484 100644 | ||
21 | --- a/daemon/lookup.c | 19 | --- a/daemon/lookup.c |
22 | +++ b/daemon/lookup.c | 20 | +++ b/daemon/lookup.c |
23 | @@ -382,7 +382,7 @@ static int read_file_source_instance(struct autofs_point *ap, struct map_source | 21 | @@ -397,7 +397,7 @@ static int read_file_source_instance(str |
24 | if (!S_ISREG(st.st_mode)) | ||
25 | return NSS_STATUS_NOTFOUND; | 22 | return NSS_STATUS_NOTFOUND; |
23 | } | ||
26 | 24 | ||
27 | - if (st.st_mode & __S_IEXEC) | 25 | - if (st.st_mode & __S_IEXEC) |
28 | + if (st.st_mode & S_IEXEC) | 26 | + if (st.st_mode & S_IEXEC) |
29 | type = src_prog; | 27 | type = src_prog; |
30 | else | 28 | else |
31 | type = src_file; | 29 | type = src_file; |
32 | @@ -942,7 +942,7 @@ static int lookup_name_file_source_instance(struct autofs_point *ap, struct map_ | 30 | @@ -930,7 +930,7 @@ static int lookup_name_file_source_insta |
33 | if (!S_ISREG(st.st_mode)) | ||
34 | return NSS_STATUS_NOTFOUND; | 31 | return NSS_STATUS_NOTFOUND; |
32 | } | ||
35 | 33 | ||
36 | - if (st.st_mode & __S_IEXEC) | 34 | - if (st.st_mode & __S_IEXEC) |
37 | + if (st.st_mode & S_IEXEC) | 35 | + if (st.st_mode & S_IEXEC) |
38 | type = src_prog; | 36 | type = src_prog; |
39 | else | 37 | else |
40 | type = src_file; | 38 | type = src_file; |
41 | @@ -1118,7 +1118,7 @@ static struct map_source *lookup_get_map_source(struct master_mapent *entry) | 39 | @@ -1077,7 +1077,7 @@ static struct map_source *lookup_get_map |
42 | if (!S_ISREG(st.st_mode)) | 40 | if (!S_ISREG(st.st_mode)) |
43 | return NULL; | 41 | return NULL; |
44 | 42 | ||
@@ -47,11 +45,9 @@ index 18df935..d35d484 100644 | |||
47 | type = "program"; | 45 | type = "program"; |
48 | else | 46 | else |
49 | type = "file"; | 47 | type = "file"; |
50 | diff --git a/modules/lookup_multi.c b/modules/lookup_multi.c | ||
51 | index bb9f88c..cf109de 100644 | ||
52 | --- a/modules/lookup_multi.c | 48 | --- a/modules/lookup_multi.c |
53 | +++ b/modules/lookup_multi.c | 49 | +++ b/modules/lookup_multi.c |
54 | @@ -247,7 +247,7 @@ static struct lookup_mod *nss_open_lookup(const char *format, int argc, const ch | 50 | @@ -247,7 +247,7 @@ static struct lookup_mod *nss_open_looku |
55 | continue; | 51 | continue; |
56 | } | 52 | } |
57 | 53 | ||
@@ -60,6 +56,3 @@ index bb9f88c..cf109de 100644 | |||
60 | type = src_prog; | 56 | type = src_prog; |
61 | else | 57 | else |
62 | type = src_file; | 58 | type = src_file; |
63 | -- | ||
64 | 2.7.4 | ||
65 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch b/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch deleted file mode 100644 index 9b0942ebf..000000000 --- a/meta-networking/recipes-daemons/autofs/autofs/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From 2256b8aa98cff15ddf2a8d36496e6c9125927901 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andreas Oberritter <obi@opendreambox.org> | ||
3 | Date: Wed, 13 Mar 2013 16:17:08 +0100 | ||
4 | Subject: [PATCH] autofs-5.0.7: include linux/nfs.h directly in rpc_subs.h | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Fixes compile error with uclibc. Glibc's nfs/nfs.h contains | ||
9 | nothing but "#include linux/nfs.h". rpc_subs.h already includes | ||
10 | other linux/nfs*.h files directly. | ||
11 | |||
12 | Signed-off-by: Andreas Oberritter <obi@opendreambox.org> | ||
13 | |||
14 | --- | ||
15 | include/rpc_subs.h | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/include/rpc_subs.h b/include/rpc_subs.h | ||
19 | index e744e89..83db47e 100644 | ||
20 | --- a/include/rpc_subs.h | ||
21 | +++ b/include/rpc_subs.h | ||
22 | @@ -18,7 +18,7 @@ | ||
23 | |||
24 | #include <rpc/rpc.h> | ||
25 | #include <rpc/pmap_prot.h> | ||
26 | -#include <nfs/nfs.h> | ||
27 | +#include <linux/nfs.h> | ||
28 | #include <linux/nfs2.h> | ||
29 | #include <linux/nfs3.h> | ||
30 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs/fix-the-YACC-rule-to-fix-a-building-failure.patch b/meta-networking/recipes-daemons/autofs/autofs/fix-the-YACC-rule-to-fix-a-building-failure.patch index 21a97c8f5..8ad3b22de 100644 --- a/meta-networking/recipes-daemons/autofs/autofs/fix-the-YACC-rule-to-fix-a-building-failure.patch +++ b/meta-networking/recipes-daemons/autofs/autofs/fix-the-YACC-rule-to-fix-a-building-failure.patch | |||
@@ -23,21 +23,9 @@ Signed-off-by: Roy Li <rongqing.li@windriver.com> | |||
23 | modules/Makefile | 3 ++- | 23 | modules/Makefile | 3 ++- |
24 | 2 files changed, 6 insertions(+), 3 deletions(-) | 24 | 2 files changed, 6 insertions(+), 3 deletions(-) |
25 | 25 | ||
26 | diff --git a/lib/Makefile b/lib/Makefile | ||
27 | index 4798a4b..c40cf86 100644 | ||
28 | --- a/lib/Makefile | 26 | --- a/lib/Makefile |
29 | +++ b/lib/Makefile | 27 | +++ b/lib/Makefile |
30 | @@ -57,7 +57,8 @@ mount_xdr.o: mount_xdr.c | 28 | @@ -53,7 +53,8 @@ mount_xdr.o: mount_xdr.c |
31 | master_tok.c: master_tok.l | ||
32 | $(LEX) -o$@ -Pmaster_ $? | ||
33 | |||
34 | -master_parse.tab.c master_parse.tab.h: master_parse.y | ||
35 | +master_parse.tab.h: master_parse.tab.c | ||
36 | +master_parse.tab.c: master_parse.y | ||
37 | $(YACC) -v -d -p master_ -b master_parse $? | ||
38 | |||
39 | master_tok.o: master_tok.c master_parse.tab.h | ||
40 | @@ -67,7 +68,8 @@ master_parse.tab.o: master_parse.tab.c master_parse.tab.h | ||
41 | nss_tok.c: nss_tok.l | 29 | nss_tok.c: nss_tok.l |
42 | $(LEX) -o$@ -Pnss_ $? | 30 | $(LEX) -o$@ -Pnss_ $? |
43 | 31 | ||
@@ -47,8 +35,6 @@ index 4798a4b..c40cf86 100644 | |||
47 | $(YACC) -v -d -p nss_ -b nss_parse $? | 35 | $(YACC) -v -d -p nss_ -b nss_parse $? |
48 | 36 | ||
49 | nss_tok.o: nss_tok.c nss_parse.tab.h | 37 | nss_tok.o: nss_tok.c nss_parse.tab.h |
50 | diff --git a/modules/Makefile b/modules/Makefile | ||
51 | index d9ab06c..abc7698 100644 | ||
52 | --- a/modules/Makefile | 38 | --- a/modules/Makefile |
53 | +++ b/modules/Makefile | 39 | +++ b/modules/Makefile |
54 | @@ -103,7 +103,8 @@ amd_tok.c: amd_tok.l | 40 | @@ -103,7 +103,8 @@ amd_tok.c: amd_tok.l |
@@ -61,3 +47,30 @@ index d9ab06c..abc7698 100644 | |||
61 | $(YACC) -v -d -p amd_ -b amd_parse $? | 47 | $(YACC) -v -d -p amd_ -b amd_parse $? |
62 | 48 | ||
63 | amd_parse.tab.o: amd_parse.tab.c amd_parse.tab.h | 49 | amd_parse.tab.o: amd_parse.tab.c amd_parse.tab.h |
50 | --- a/daemon/Makefile | ||
51 | +++ b/daemon/Makefile | ||
52 | @@ -16,7 +16,7 @@ YACCSRC = master_tok.c master_parse.tab. | ||
53 | version := $(shell cat ../.version) | ||
54 | |||
55 | CFLAGS += -rdynamic $(DAEMON_CFLAGS) -D_GNU_SOURCE -I../include | ||
56 | -CFLAGS += -DAUTOFS_LIB_DIR=\"$(autofslibdir)\" | ||
57 | +CFLAGS += -DAUTOFS_LIB_DIR=\"$(autofslibdir)\" | ||
58 | CFLAGS += -DAUTOFS_MAP_DIR=\"$(autofsmapdir)\" | ||
59 | CFLAGS += -DAUTOFS_CONF_DIR=\"$(autofsconfdir)\" | ||
60 | CFLAGS += -DAUTOFS_FIFO_DIR=\"$(autofsfifodir)\" | ||
61 | @@ -44,7 +44,8 @@ automount: $(OBJS) $(AUTOFS_LIB) | ||
62 | master_tok.c: master_tok.l | ||
63 | $(LEX) -o$@ -Pmaster_ $? | ||
64 | |||
65 | -master_parse.tab.c master_parse.tab.h: master_parse.y | ||
66 | +master_parse.tab.h: master_parse.tab.c | ||
67 | +master_parse.tab.c: master_parse.y | ||
68 | $(YACC) -v -d -p master_ -b master_parse $? | ||
69 | |||
70 | master_tok.o: master_tok.c master_parse.tab.h | ||
71 | @@ -57,5 +58,3 @@ clean: | ||
72 | install: all | ||
73 | install -d -m 755 $(INSTALLROOT)$(sbindir) | ||
74 | install -c automount -m 755 $(INSTALLROOT)$(sbindir) | ||
75 | - | ||
76 | - | ||
diff --git a/meta-networking/recipes-daemons/autofs/autofs/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch b/meta-networking/recipes-daemons/autofs/autofs/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch index d1f9f3493..41de373fd 100644 --- a/meta-networking/recipes-daemons/autofs/autofs/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch +++ b/meta-networking/recipes-daemons/autofs/autofs/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch | |||
@@ -16,33 +16,21 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com> | |||
16 | configure.in | 16 ++++++++++++++-- | 16 | configure.in | 16 ++++++++++++++-- |
17 | 1 file changed, 14 insertions(+), 2 deletions(-) | 17 | 1 file changed, 14 insertions(+), 2 deletions(-) |
18 | 18 | ||
19 | diff --git a/configure.in b/configure.in | ||
20 | index f5fbb35..76ecb40 100644 | ||
21 | --- a/configure.in | 19 | --- a/configure.in |
22 | +++ b/configure.in | 20 | +++ b/configure.in |
23 | @@ -211,8 +211,20 @@ fi | 21 | @@ -215,7 +215,14 @@ PKG_CHECK_MODULES([XML], [libxml-2.0], [ |
24 | AC_SUBST(ENABLE_FEDFS) | 22 | AC_DEFINE(LIBXML2_WORKAROUND, 1, [Use libxml2 tsd usage workaround]) |
25 | 23 | ], [HAVE_LIBXML=0]) | |
26 | # LDAP SASL auth needs libxml and Kerberos | 24 | |
27 | -AF_CHECK_LIBXML() | ||
28 | -AF_CHECK_KRB5() | 25 | -AF_CHECK_KRB5() |
29 | +PKG_CHECK_MODULES(XML, [libxml-2.0],HAVE_LIBXML=1,HAVE_LIBXML=0) | 26 | +PKG_CHECK_MODULES(KRB5, [krb5], [ |
30 | +AC_SUBST([HAVE_LIBXML]) | 27 | + HAVE_KRB5=1 |
31 | +XML_FLAGS=$XML_CFLAGS | ||
32 | + | ||
33 | +PKG_CHECK_MODULES(KRB5, [krb5],HAVE_KRB5=1,HAVE_KRB5=0) | ||
34 | +AC_SUBST([HAVE_KRB5]) | ||
35 | +if test "x$HAVE_KRB5" = "x1"; then | ||
36 | + SAVE_CFLAGS=$CFLAGS | 28 | + SAVE_CFLAGS=$CFLAGS |
37 | + SAVE_LIBS=$LIBS | 29 | + SAVE_LIBS=$LIBS |
38 | + CFLAGS="$CFLAGS $KRB5_FLAGS" | 30 | + CFLAGS="$CFLAGS $KRB5_FLAGS" |
39 | + LIBS="$LIBS $KRB5_LIBS" | 31 | + LIBS="$LIBS $KRB5_LIBS" |
40 | + | ||
41 | + AC_CHECK_FUNCS([krb5_principal_get_realm]) | 32 | + AC_CHECK_FUNCS([krb5_principal_get_realm]) |
42 | +fi | 33 | +], [HAVE_KRB5=0]) |
43 | 34 | ||
44 | AC_SEARCH_LIBS([versionsort],[]) | 35 | AC_SEARCH_LIBS([versionsort],[]) |
45 | if test "$ac_cv_search_versionsort" = "no"; then | 36 | if test "$ac_cv_search_versionsort" = "no"; then |
46 | -- | ||
47 | 2.7.4 | ||
48 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb index 54f0b9991..019b453c2 100644 --- a/meta-networking/recipes-daemons/autofs/autofs_5.1.6.bb +++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | SUMMARY = "Kernel based automounter for linux" | 1 | SUMMARY = "Kernel based automounter for linux" |
2 | SECTION = "utils" | 2 | SECTION = "utils" |
3 | LICENSE = "GPL-2.0" | 3 | LICENSE = "GPL-2.0" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=ee9324a6f564bb2376b63878ac396798" |
5 | 5 | ||
6 | DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl libnsl2" | 6 | DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl libnsl2" |
7 | 7 | ||
@@ -10,7 +10,6 @@ CFLAGS += "-I${STAGING_INCDIR}/tirpc" | |||
10 | inherit autotools-brokensep systemd update-rc.d pkgconfig | 10 | inherit autotools-brokensep systemd update-rc.d pkgconfig |
11 | 11 | ||
12 | SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ | 12 | SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ |
13 | file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \ | ||
14 | file://no-bash.patch \ | 13 | file://no-bash.patch \ |
15 | file://cross.patch \ | 14 | file://cross.patch \ |
16 | file://fix_disable_ldap.patch \ | 15 | file://fix_disable_ldap.patch \ |
@@ -26,11 +25,9 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ | |||
26 | file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \ | 25 | file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \ |
27 | file://0001-Do-not-hardcode-path-for-pkg.m4.patch \ | 26 | file://0001-Do-not-hardcode-path-for-pkg.m4.patch \ |
28 | file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \ | 27 | file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \ |
28 | file://0001-Define-__SWORD_TYPE-if-undefined.patch \ | ||
29 | " | 29 | " |
30 | 30 | SRC_URI[sha256sum] = "a18619e5ad18960fe382354eef33f070e57e4e5711d484b010acde080a003312" | |
31 | |||
32 | SRC_URI[md5sum] = "e6800e0afd6009ecdff148088c564050" | ||
33 | SRC_URI[sha256sum] = "82094cad44f4e5c4f93eff2789cd66b57d7ab3fa646b7722d97608571001e694" | ||
34 | 31 | ||
35 | UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/" | 32 | UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/" |
36 | 33 | ||
@@ -87,10 +84,14 @@ do_install_append () { | |||
87 | } | 84 | } |
88 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" | 85 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" |
89 | 86 | ||
87 | # all the libraries are unversioned, so don't pack it on PN-dev | ||
88 | SOLIBS = ".so" | ||
89 | FILES_SOLIBSDEV = "" | ||
90 | # Some symlinks are created in plugins dir e.g. | ||
91 | # mount_nfs4.so -> mount_nfs.so | ||
90 | INSANE_SKIP_${PN} = "dev-so" | 92 | INSANE_SKIP_${PN} = "dev-so" |
91 | 93 | ||
92 | RPROVIDES_${PN} += "${PN}-systemd" | 94 | RPROVIDES_${PN} += "${PN}-systemd" |
93 | RREPLACES_${PN} += "${PN}-systemd" | 95 | RREPLACES_${PN} += "${PN}-systemd" |
94 | RCONFLICTS_${PN} += "${PN}-systemd" | 96 | RCONFLICTS_${PN} += "${PN}-systemd" |
95 | SYSTEMD_SERVICE_${PN} = "autofs.service" | 97 | SYSTEMD_SERVICE_${PN} = "autofs.service" |
96 | |||