diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:50 +0100 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-05-05 11:41:28 -0400 |
commit | 275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802 (patch) | |
tree | 4fd20a242b848ec8497066801b86706de3defdce /meta-networking/recipes-daemons | |
parent | 7a9c626092c7d3b10206c7ca4ea2827cca9cba4f (diff) | |
download | meta-openembedded-275b6c30fbe4f2e6d8c607e9f2eedd5c230c0802.tar.gz |
meta-networking: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
6 files changed, 23 insertions, 23 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb index 0f4c2478e..3b52ed475 100644 --- a/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb +++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.1.bb | |||
@@ -36,7 +36,7 @@ CFLAGS += "${LDFLAGS}" | |||
36 | 36 | ||
37 | PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd" | 37 | PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd" |
38 | 38 | ||
39 | PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | 39 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" |
40 | 40 | ||
41 | EXTRA_OEMAKE = "DONTSTRIP=1" | 41 | EXTRA_OEMAKE = "DONTSTRIP=1" |
42 | EXTRA_OECONF += "--disable-mount-locking \ | 42 | EXTRA_OECONF += "--disable-mount-locking \ |
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb index 5da3d965b..50468184b 100644 --- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb +++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb | |||
@@ -24,8 +24,8 @@ EXTRA_OECONF += "--with-dblib=berkeley \ | |||
24 | andrew_cv_runpath_switch=none" | 24 | andrew_cv_runpath_switch=none" |
25 | 25 | ||
26 | PACKAGECONFIG ??= "ntlm \ | 26 | PACKAGECONFIG ??= "ntlm \ |
27 | ${@base_contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \ | 27 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'ldap', '', d)} \ |
28 | ${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ | 28 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ |
29 | " | 29 | " |
30 | PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5," | 30 | PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5," |
31 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam," | 31 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam," |
@@ -54,7 +54,7 @@ do_compile_prepend () { | |||
54 | } | 54 | } |
55 | 55 | ||
56 | do_install_append() { | 56 | do_install_append() { |
57 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 57 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
58 | install -d ${D}${systemd_unitdir}/system | 58 | install -d ${D}${systemd_unitdir}/system |
59 | install -m 0644 ${WORKDIR}/saslauthd.service ${D}${systemd_unitdir}/system | 59 | install -m 0644 ${WORKDIR}/saslauthd.service ${D}${systemd_unitdir}/system |
60 | 60 | ||
diff --git a/meta-networking/recipes-daemons/dnrd/dnrd_2.20.3.bb b/meta-networking/recipes-daemons/dnrd/dnrd_2.20.3.bb index 8769e5294..b5851a959 100644 --- a/meta-networking/recipes-daemons/dnrd/dnrd_2.20.3.bb +++ b/meta-networking/recipes-daemons/dnrd/dnrd_2.20.3.bb | |||
@@ -22,7 +22,7 @@ SYSTEMD_SERVICE_${PN} = "dnrd.service" | |||
22 | SYSTEMD_AUTO_ENABLE = "disable" | 22 | SYSTEMD_AUTO_ENABLE = "disable" |
23 | 23 | ||
24 | inherit autotools | 24 | inherit autotools |
25 | inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} | 25 | inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} |
26 | 26 | ||
27 | do_install() { | 27 | do_install() { |
28 | oe_runmake install DESTDIR=${D} INSTALL="install -p" | 28 | oe_runmake install DESTDIR=${D} INSTALL="install -p" |
@@ -34,7 +34,7 @@ do_install() { | |||
34 | install -p -m 0644 ${WORKDIR}/dnrd.conf.sample ${D}${sysconfdir}/dnrd/dnrd.conf | 34 | install -p -m 0644 ${WORKDIR}/dnrd.conf.sample ${D}${sysconfdir}/dnrd/dnrd.conf |
35 | install -p -m 0755 ${WORKDIR}/dnrd.init ${D}${sysconfdir}/init.d/dnrd | 35 | install -p -m 0755 ${WORKDIR}/dnrd.init ${D}${sysconfdir}/init.d/dnrd |
36 | 36 | ||
37 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | 37 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
38 | install -d -m 0755 ${D}${systemd_unitdir}/system | 38 | install -d -m 0755 ${D}${systemd_unitdir}/system |
39 | install -m 644 ${WORKDIR}/dnrd.service ${D}${systemd_unitdir}/system | 39 | install -m 644 ${WORKDIR}/dnrd.service ${D}${systemd_unitdir}/system |
40 | fi | 40 | fi |
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc index 17dbf76ce..228a81564 100644 --- a/meta-networking/recipes-daemons/postfix/postfix.inc +++ b/meta-networking/recipes-daemons/postfix/postfix.inc | |||
@@ -7,8 +7,8 @@ has a definite Sendmail-ish flavor, but the inside is completely different." | |||
7 | HOMEPAGE= "http://www.postfix.org" | 7 | HOMEPAGE= "http://www.postfix.org" |
8 | SECTION = "mail" | 8 | SECTION = "mail" |
9 | DEPENDS = "virtual/db libpcre openssl postfix-native \ | 9 | DEPENDS = "virtual/db libpcre openssl postfix-native \ |
10 | ${@base_contains('DISTRO_FEATURES', 'ldap', 'openldap', '', d)} \ | 10 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', 'openldap', '', d)} \ |
11 | ${@base_contains('DISTRO_FEATURES', 'sasl', 'cyrus-sasl', '', d)} \ | 11 | ${@bb.utils.contains('DISTRO_FEATURES', 'sasl', 'cyrus-sasl', '', d)} \ |
12 | " | 12 | " |
13 | DEPENDS_class-native = "virtual/db-native openssl-native libpcre-native" | 13 | DEPENDS_class-native = "virtual/db-native openssl-native libpcre-native" |
14 | 14 | ||
@@ -52,9 +52,9 @@ export SYSLIBS = "${LDFLAGS}" | |||
52 | 52 | ||
53 | # ldap support | 53 | # ldap support |
54 | export CCARGS-ldap = "\ | 54 | export CCARGS-ldap = "\ |
55 | ${@base_contains('DISTRO_FEATURES', 'ldap', '-DHAS_LDAP', '', d)}" | 55 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', '-DHAS_LDAP', '', d)}" |
56 | export AUXLIBS-ldap = "\ | 56 | export AUXLIBS-ldap = "\ |
57 | ${@base_contains('DISTRO_FEATURES', 'ldap', '-lldap -llber', '', d)}" | 57 | ${@bb.utils.contains('DISTRO_FEATURES', 'ldap', '-lldap -llber', '', d)}" |
58 | 58 | ||
59 | # no native openldap | 59 | # no native openldap |
60 | export CCARGS-ldap_class-native = "" | 60 | export CCARGS-ldap_class-native = "" |
@@ -63,9 +63,9 @@ export AUXLIBS-ldap_class-native = "" | |||
63 | # SASL support -DUSE_LDAP_SASL -DUSE_SASL_AUTH | 63 | # SASL support -DUSE_LDAP_SASL -DUSE_SASL_AUTH |
64 | # current openldap didn't enable SASL | 64 | # current openldap didn't enable SASL |
65 | export CCARGS-sasl = "\ | 65 | export CCARGS-sasl = "\ |
66 | ${@base_contains('DISTRO_FEATURES', 'sasl', '-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I=/usr/include/sasl', '', d)}" | 66 | ${@bb.utils.contains('DISTRO_FEATURES', 'sasl', '-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I=/usr/include/sasl', '', d)}" |
67 | export AUXLIBS-sasl = "\ | 67 | export AUXLIBS-sasl = "\ |
68 | ${@base_contains('DISTRO_FEATURES', 'sasl', '-lsasl2', '', d)}" | 68 | ${@bb.utils.contains('DISTRO_FEATURES', 'sasl', '-lsasl2', '', d)}" |
69 | export CCARGS-sasl_class-native = "" | 69 | export CCARGS-sasl_class-native = "" |
70 | export AUXLIBS-sasl_class-native = "" | 70 | export AUXLIBS-sasl_class-native = "" |
71 | 71 | ||
diff --git a/meta-networking/recipes-daemons/squid/squid_3.5.7.bb b/meta-networking/recipes-daemons/squid/squid_3.5.7.bb index a94fed7e5..c3eabcdb3 100644 --- a/meta-networking/recipes-daemons/squid/squid_3.5.7.bb +++ b/meta-networking/recipes-daemons/squid/squid_3.5.7.bb | |||
@@ -34,15 +34,15 @@ inherit autotools useradd ptest | |||
34 | USERADD_PACKAGES = "${PN}" | 34 | USERADD_PACKAGES = "${PN}" |
35 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid" | 35 | USERADD_PARAM_${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid" |
36 | 36 | ||
37 | PACKAGECONFIG ??= "${@base_contains('TARGET_ARCH', 'powerpc', 'noatomics', '', d)} \ | 37 | PACKAGECONFIG ??= "${@bb.utils.contains('TARGET_ARCH', 'powerpc', 'noatomics', '', d)} \ |
38 | ${@base_contains('TARGET_ARCH', 'mips', 'noatomics', '', d)} \ | 38 | ${@bb.utils.contains('TARGET_ARCH', 'mips', 'noatomics', '', d)} \ |
39 | " | 39 | " |
40 | PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack" | 40 | PACKAGECONFIG[libnetfilter-conntrack] = "--with-netfilter-conntrack=${includedir}, --without-netfilter-conntrack, libnetfilter-conntrack" |
41 | PACKAGECONFIG[noatomics] = "squid_cv_gnu_atomics=no,squid_cv_gnu_atomics=yes,," | 41 | PACKAGECONFIG[noatomics] = "squid_cv_gnu_atomics=no,squid_cv_gnu_atomics=yes,," |
42 | 42 | ||
43 | BASIC_AUTH = "DB SASL LDAP NIS" | 43 | BASIC_AUTH = "DB SASL LDAP NIS" |
44 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 44 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
45 | BASIC_AUTH += "${@base_contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}" | 45 | BASIC_AUTH += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'PAM', '', d)}" |
46 | 46 | ||
47 | EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}'" | 47 | EXTRA_OECONF += "--with-default-user=squid --enable-auth-basic='${BASIC_AUTH}'" |
48 | export BUILDCXXFLAGS="${BUILD_CXXFLAGS}" | 48 | export BUILDCXXFLAGS="${BUILD_CXXFLAGS}" |
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb index 4ee881ddd..6c8ba9164 100644 --- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb +++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb | |||
@@ -29,13 +29,13 @@ SRC_URI[sha256sum] = "9d4d2bf6e6e2884852ba4e69e157a2cecd68c5a7635d66a3a8cf8d898c | |||
29 | 29 | ||
30 | PACKAGECONFIG ??= "tcp-wrappers" | 30 | PACKAGECONFIG ??= "tcp-wrappers" |
31 | PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers" | 31 | PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers" |
32 | SRC_URI +="${@base_contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)}" | 32 | SRC_URI +="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://vsftpd-tcp_wrappers-support.patch', '', d)}" |
33 | 33 | ||
34 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 34 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
35 | RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}" | 35 | RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}" |
36 | PAMLIB = "${@base_contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}" | 36 | PAMLIB = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}" |
37 | NOPAM_SRC ="${@base_contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}" | 37 | NOPAM_SRC ="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}" |
38 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)}" | 38 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '', '${NOPAM_SRC}', d)}" |
39 | 39 | ||
40 | inherit update-rc.d useradd systemd | 40 | inherit update-rc.d useradd systemd |
41 | 41 | ||
@@ -75,7 +75,7 @@ do_install() { | |||
75 | sed -i "s:/lib/security:${base_libdir}/security:" ${D}${sysconfdir}/pam.d/vsftpd | 75 | sed -i "s:/lib/security:${base_libdir}/security:" ${D}${sysconfdir}/pam.d/vsftpd |
76 | sed -i "s:ftpusers:vsftpd.ftpusers:" ${D}${sysconfdir}/pam.d/vsftpd | 76 | sed -i "s:ftpusers:vsftpd.ftpusers:" ${D}${sysconfdir}/pam.d/vsftpd |
77 | fi | 77 | fi |
78 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 78 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
79 | install -d ${D}${sysconfdir}/tmpfiles.d | 79 | install -d ${D}${sysconfdir}/tmpfiles.d |
80 | echo "d /var/run/vsftpd/empty 0755 root root -" \ | 80 | echo "d /var/run/vsftpd/empty 0755 root root -" \ |
81 | > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf | 81 | > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |