diff options
author | Andrej Kozemcak <andrej.kozemcak@siemens.com> | 2022-09-22 15:57:45 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-22 16:45:05 -0700 |
commit | 1dc95cae909bb3f5d05112489eb2374c24ada35b (patch) | |
tree | 3166ab3f4931491c1ae1a5fad077780f95ca3f25 /meta-networking/recipes-daemons | |
parent | 2239a3063cadbdf7f9deb41d2842c06c2ad2bce1 (diff) | |
download | meta-openembedded-1dc95cae909bb3f5d05112489eb2374c24ada35b.tar.gz |
squid: upgrade 4.15 -> 5.7
- drop included patches
- refresh remaining patches
- update to new ptest
Licence change: update year
Signed-off-by: Andrej Kozemcak <andrej.kozemcak@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch | 82 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/0001-splay.cc-fix-bind-is-not-a-member-of-std.patch | 31 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch | 34 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch | 2 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch | 15 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch | 8 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/squid/squid_5.7.bb (renamed from meta-networking/recipes-daemons/squid/squid_4.15.bb) | 21 |
7 files changed, 27 insertions, 166 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch b/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch deleted file mode 100644 index ff51f5344..000000000 --- a/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch +++ /dev/null | |||
@@ -1,82 +0,0 @@ | |||
1 | From 1f8b5f0e1cc27634a7310be4c9674112f919d974 Mon Sep 17 00:00:00 2001 | ||
2 | From: uhliarik <luhliari@redhat.com> | ||
3 | Date: Thu, 18 Feb 2021 01:08:40 +0000 | ||
4 | Subject: [PATCH] Fix build on Fedora Rawhide (#772) | ||
5 | |||
6 | * add SYSTEMD_LIBS to all binaries using client_side.cc, fixing linking | ||
7 | * add `<limits>` to all sources using std::numeric_limits, fixing gcc-11 | ||
8 | builds | ||
9 | --- | ||
10 | Upstream-Status: Backport [https://github.com/kraj/squid/commit/1f8b5f0e1cc27634a7310be4c9674112f919d974] | ||
11 | src/Makefile.am | 4 ++++ | ||
12 | src/ip/QosConfig.cc | 1 + | ||
13 | src/ipc/mem/PageStack.cc | 1 + | ||
14 | src/ssl/helper.cc | 2 ++ | ||
15 | 4 files changed, 8 insertions(+) | ||
16 | |||
17 | --- a/src/Makefile.am | ||
18 | +++ b/src/Makefile.am | ||
19 | @@ -2320,6 +2320,7 @@ tests_test_http_range_LDADD = \ | ||
20 | $(SSLLIB) \ | ||
21 | $(KRB5LIBS) \ | ||
22 | $(LIBCPPUNIT_LIBS) \ | ||
23 | + $(SYSTEMD_LIBS) \ | ||
24 | $(COMPAT_LIB) \ | ||
25 | $(XTRA_LIBS) | ||
26 | tests_test_http_range_LDFLAGS = $(LIBADD_DL) | ||
27 | @@ -2624,6 +2625,7 @@ tests_testHttpRequest_LDADD = \ | ||
28 | $(SSLLIB) \ | ||
29 | $(KRB5LIBS) \ | ||
30 | $(LIBCPPUNIT_LIBS) \ | ||
31 | + $(SYSTEMD_LIBS) \ | ||
32 | $(COMPAT_LIB) \ | ||
33 | $(XTRA_LIBS) | ||
34 | tests_testHttpRequest_LDFLAGS = $(LIBADD_DL) | ||
35 | @@ -3487,6 +3489,7 @@ tests_testURL_LDADD = \ | ||
36 | $(SSLLIB) \ | ||
37 | $(KRB5LIBS) \ | ||
38 | $(LIBCPPUNIT_LIBS) \ | ||
39 | + $(SYSTEMD_LIBS) \ | ||
40 | $(COMPAT_LIB) \ | ||
41 | $(XTRA_LIBS) | ||
42 | tests_testURL_LDFLAGS = $(LIBADD_DL) | ||
43 | @@ -3646,6 +3649,7 @@ nodist_tests_testYesNoNone_SOURCES = \ | ||
44 | tests_testYesNoNone_LDADD= \ | ||
45 | base/libbase.la \ | ||
46 | $(LIBCPPUNIT_LIBS) \ | ||
47 | + $(SYSTEMD_LIBS) \ | ||
48 | $(COMPAT_LIB) \ | ||
49 | $(XTRA_LIBS) | ||
50 | tests_testYesNoNone_LDFLAGS = $(LIBADD_DL) | ||
51 | --- a/src/ip/QosConfig.cc | ||
52 | +++ b/src/ip/QosConfig.cc | ||
53 | @@ -21,6 +21,7 @@ | ||
54 | #include "Parsing.h" | ||
55 | |||
56 | #include <cerrno> | ||
57 | +#include <limits> | ||
58 | |||
59 | CBDATA_CLASS_INIT(acl_tos); | ||
60 | |||
61 | --- a/src/ipc/mem/PageStack.cc | ||
62 | +++ b/src/ipc/mem/PageStack.cc | ||
63 | @@ -14,6 +14,7 @@ | ||
64 | #include "Debug.h" | ||
65 | #include "ipc/mem/Page.h" | ||
66 | #include "ipc/mem/PageStack.h" | ||
67 | +#include <limits> | ||
68 | |||
69 | /// used to mark a stack slot available for storing free page offsets | ||
70 | const Ipc::Mem::PageStack::Value Writable = 0; | ||
71 | --- a/src/ssl/helper.cc | ||
72 | +++ b/src/ssl/helper.cc | ||
73 | @@ -19,6 +19,8 @@ | ||
74 | #include "ssl/helper.h" | ||
75 | #include "wordlist.h" | ||
76 | |||
77 | +#include <limits> | ||
78 | + | ||
79 | Ssl::CertValidationHelper::LruCache *Ssl::CertValidationHelper::HelperCache = nullptr; | ||
80 | |||
81 | #if USE_SSL_CRTD | ||
82 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/0001-splay.cc-fix-bind-is-not-a-member-of-std.patch b/meta-networking/recipes-daemons/squid/files/0001-splay.cc-fix-bind-is-not-a-member-of-std.patch deleted file mode 100644 index fbbad1597..000000000 --- a/meta-networking/recipes-daemons/squid/files/0001-splay.cc-fix-bind-is-not-a-member-of-std.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 1def5b4278d97f197520d23c1dce52f93a1b2f46 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrej Valek <andrej.valek@siemens.com> | ||
3 | Date: Tue, 9 Apr 2019 09:40:30 +0200 | ||
4 | Subject: [PATCH] splay.cc: fix bind is not a member of std | ||
5 | |||
6 | fix | ||
7 | | ../../squid-4.6/test-suite/splay.cc:134:28: error: 'bind' is not a member of 'std' | ||
8 | | auto nextRandom = std::bind (distribution, generator); | ||
9 | | ^~~~ | ||
10 | | ../../squid-4.6/test-suite/splay.cc:134:28: note: 'std::bind' is defined in header '<functional>'; did you forget to '#include <functional>'? | ||
11 | |||
12 | Signed-off-by: Andrej Valek <andrej.valek@siemens.com> | ||
13 | --- | ||
14 | test-suite/splay.cc | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/test-suite/splay.cc b/test-suite/splay.cc | ||
18 | index f71b337..4e21adc 100644 | ||
19 | --- a/test-suite/splay.cc | ||
20 | +++ b/test-suite/splay.cc | ||
21 | @@ -20,6 +20,7 @@ | ||
22 | #include <unistd.h> | ||
23 | #endif | ||
24 | #include <random> | ||
25 | +#include <functional> | ||
26 | |||
27 | class intnode | ||
28 | { | ||
29 | -- | ||
30 | 2.11.0 | ||
31 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch b/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch deleted file mode 100644 index f267875ed..000000000 --- a/meta-networking/recipes-daemons/squid/files/0001-tools.cc-fixed-unused-result-warning.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 86dae8010310d13bd2a2beb006b4085d06ae1556 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 25 Jun 2017 00:59:24 -0700 | ||
4 | Subject: [PATCH] tools.cc: fixed unused-result warning | ||
5 | |||
6 | fix | ||
7 | | ../../squid-3.5.26/src/tools.cc: In function 'void enter_suid()': | ||
8 | | ../../squid-3.5.26/src/tools.cc:616:11: error: ignoring return value of 'int setuid(__uid_t)', declared with attribute warn_unused_result [-Werror=unused-result] | ||
9 | | setuid(0); | ||
10 | | ~~~~~~^~~ | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | |||
14 | --- | ||
15 | src/tools.cc | 5 +++-- | ||
16 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/src/tools.cc b/src/tools.cc | ||
19 | index 5829574..19f0836 100644 | ||
20 | --- a/src/tools.cc | ||
21 | +++ b/src/tools.cc | ||
22 | @@ -581,8 +581,10 @@ enter_suid(void) | ||
23 | debugs (21, 3, "enter_suid: setresuid failed: " << xstrerr(xerrno)); | ||
24 | } | ||
25 | #else | ||
26 | - | ||
27 | - setuid(0); | ||
28 | + if (setuid(0) < 0) { | ||
29 | + const auto xerrno = errno; | ||
30 | + debugs(50, DBG_IMPORTANT, "WARNING: no_suid: setuid(0): " << xstrerr(xerrno)); | ||
31 | + } | ||
32 | #endif | ||
33 | #if HAVE_PRCTL && defined(PR_SET_DUMPABLE) | ||
34 | /* Set Linux DUMPABLE flag */ | ||
diff --git a/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch b/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch index 1516bb014..a429b7b2d 100644 --- a/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch +++ b/meta-networking/recipes-daemons/squid/files/Fix-flawed-dynamic-ldb-link-test-in-configure.patch | |||
@@ -19,7 +19,7 @@ diff --git a/configure.ac b/configure.ac | |||
19 | index d2f7feb..c7ae568 100644 | 19 | index d2f7feb..c7ae568 100644 |
20 | --- a/configure.ac | 20 | --- a/configure.ac |
21 | +++ b/configure.ac | 21 | +++ b/configure.ac |
22 | @@ -3235,6 +3235,16 @@ case "$host" in | 22 | @@ -3268,6 +3268,16 @@ case "$host" in |
23 | ;; | 23 | ;; |
24 | esac | 24 | esac |
25 | 25 | ||
diff --git a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch index dd83b62e6..10853333e 100644 --- a/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch +++ b/meta-networking/recipes-daemons/squid/files/Skip-AC_RUN_IFELSE-tests.patch | |||
@@ -38,10 +38,10 @@ index ad0ba60..4477446 100644 | |||
38 | ]) | 38 | ]) |
39 | ]) dnl SQUID_CHECK_KRB5_HEIMDAL_BROKEN_KRB5_H | 39 | ]) dnl SQUID_CHECK_KRB5_HEIMDAL_BROKEN_KRB5_H |
40 | diff --git a/acinclude/lib-checks.m4 b/acinclude/lib-checks.m4 | 40 | diff --git a/acinclude/lib-checks.m4 b/acinclude/lib-checks.m4 |
41 | index 7624b56..b449c5a 100644 | 41 | index 1e9333527c..2d42787029 100644 |
42 | --- a/acinclude/lib-checks.m4 | 42 | --- a/acinclude/lib-checks.m4 |
43 | +++ b/acinclude/lib-checks.m4 | 43 | +++ b/acinclude/lib-checks.m4 |
44 | @@ -217,7 +217,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_CONST_SSL_METHOD],[ | 44 | @@ -227,7 +227,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_CONST_SSL_METHOD],[ |
45 | [ | 45 | [ |
46 | AC_MSG_RESULT([no]) | 46 | AC_MSG_RESULT([no]) |
47 | ], | 47 | ], |
@@ -52,14 +52,15 @@ index 7624b56..b449c5a 100644 | |||
52 | 52 | ||
53 | SQUID_STATE_ROLLBACK(check_const_SSL_METHOD) | 53 | SQUID_STATE_ROLLBACK(check_const_SSL_METHOD) |
54 | ]) | 54 | ]) |
55 | @@ -377,7 +379,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_TXTDB],[ | 55 | @@ -386,8 +386,9 @@ AC_DEFUN([SQUID_CHECK_OPENSSL_TXTDB],[ |
56 | [ | ||
56 | AC_MSG_RESULT([yes]) | 57 | AC_MSG_RESULT([yes]) |
57 | AC_DEFINE(SQUID_USE_SSLLHASH_HACK, 1) | 58 | AC_DEFINE(SQUID_USE_SSLLHASH_HACK, 1) |
58 | ], | 59 | - ], |
59 | -[]) | 60 | -[]) |
60 | +[ | 61 | + ],[ |
61 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) | 62 | + AC_MSG_RESULT([skipped - can't test in cross-compiled env]) |
62 | +]) | 63 | + ]) |
63 | 64 | ||
64 | SQUID_STATE_ROLLBACK(check_TXTDB) | 65 | SQUID_STATE_ROLLBACK(check_TXTDB) |
65 | ]) | 66 | ]) |
diff --git a/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch index e5267ea2b..ea27285e0 100644 --- a/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch +++ b/meta-networking/recipes-daemons/squid/files/squid-don-t-do-squid-conf-tests-at-build-time.patch | |||
@@ -20,11 +20,11 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | |||
20 | 1 file changed, 7 insertions(+), 8 deletions(-) | 20 | 1 file changed, 7 insertions(+), 8 deletions(-) |
21 | 21 | ||
22 | diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am | 22 | diff --git a/test-suite/Makefile.am b/test-suite/Makefile.am |
23 | index 061a463..350dfb2 100644 | 23 | index 0233c0e..e0021b6 100644 |
24 | --- a/test-suite/Makefile.am | 24 | --- a/test-suite/Makefile.am |
25 | +++ b/test-suite/Makefile.am | 25 | +++ b/test-suite/Makefile.am |
26 | @@ -41,8 +41,7 @@ TESTS += debug \ | 26 | @@ -40,8 +40,7 @@ TESTS += debug \ |
27 | MemPoolTest\ | 27 | splay\ |
28 | mem_node_test\ | 28 | mem_node_test\ |
29 | mem_hdr_test\ | 29 | mem_hdr_test\ |
30 | - $(ESI_TESTS) \ | 30 | - $(ESI_TESTS) \ |
@@ -33,7 +33,7 @@ index 061a463..350dfb2 100644 | |||
33 | 33 | ||
34 | ## Sort by alpha - any build failures are significant. | 34 | ## Sort by alpha - any build failures are significant. |
35 | check_PROGRAMS += debug \ | 35 | check_PROGRAMS += debug \ |
36 | @@ -125,19 +124,19 @@ VirtualDeleteOperator_SOURCES = VirtualDeleteOperator.cc $(DEBUG_SOURCE) | 36 | @@ -159,19 +158,19 @@ VirtualDeleteOperator_SOURCES = \ |
37 | ##$(TARGLIB): $(LIBOBJS) | 37 | ##$(TARGLIB): $(LIBOBJS) |
38 | ## $(AR_R) $(TARGLIB) $(LIBOBJS) | 38 | ## $(AR_R) $(TARGLIB) $(LIBOBJS) |
39 | 39 | ||
diff --git a/meta-networking/recipes-daemons/squid/squid_4.15.bb b/meta-networking/recipes-daemons/squid/squid_5.7.bb index a1122a3cd..a208a2a88 100644 --- a/meta-networking/recipes-daemons/squid/squid_4.15.bb +++ b/meta-networking/recipes-daemons/squid/squid_5.7.bb | |||
@@ -22,17 +22,14 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2 | |||
22 | file://set_sysroot_patch.patch \ | 22 | file://set_sysroot_patch.patch \ |
23 | file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ | 23 | file://squid-don-t-do-squid-conf-tests-at-build-time.patch \ |
24 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ | 24 | file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ |
25 | file://0001-tools.cc-fixed-unused-result-warning.patch \ | ||
26 | file://0001-splay.cc-fix-bind-is-not-a-member-of-std.patch \ | ||
27 | file://0001-Fix-build-on-Fedora-Rawhide-772.patch \ | ||
28 | " | 25 | " |
29 | 26 | ||
30 | SRC_URI:remove:toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch" | 27 | SRC_URI:remove:toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch" |
31 | 28 | ||
32 | SRC_URI[sha256sum] = "71635811e766ce8b155225a9e3c7757cfc7ff93df26b28d82e5e6fc021b9a605" | 29 | SRC_URI[sha256sum] = "4c17e1eb324c4b7aa3c6889eba66eeca7ed98625d44076f7db7b027b2b093bd5" |
33 | 30 | ||
34 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 31 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
35 | file://errors/COPYRIGHT;md5=0e03cd976052c45697ad5d96e7dff8dc \ | 32 | file://errors/COPYRIGHT;md5=0a7deb73d8fb7a9849af7145987829a4 \ |
36 | " | 33 | " |
37 | DEPENDS = "libtool krb5 openldap db cyrus-sasl" | 34 | DEPENDS = "libtool krb5 openldap db cyrus-sasl" |
38 | 35 | ||
@@ -80,12 +77,21 @@ do_install_ptest() { | |||
80 | cp -rf ${B}/${TESTDIR} ${D}${PTEST_PATH} | 77 | cp -rf ${B}/${TESTDIR} ${D}${PTEST_PATH} |
81 | cp -rf ${S}/${TESTDIR} ${D}${PTEST_PATH} | 78 | cp -rf ${S}/${TESTDIR} ${D}${PTEST_PATH} |
82 | 79 | ||
80 | # Needed to generate file squid.conf.default | ||
81 | oe_runmake DESTDIR=${D}${PTEST_PATH} -C src install-data-local | ||
82 | install -d ${D}${sysconfdir}/squid | ||
83 | install -m 0644 ${D}${PTEST_PATH}/${sysconfdir}/squid/squid.conf.default ${D}${sysconfdir}/squid | ||
84 | |||
85 | # Don't need these directories | ||
86 | rm -rf ${D}${PTEST_PATH}/${sysconfdir} | ||
87 | rm -rf ${D}${PTEST_PATH}/usr | ||
88 | rm -rf ${D}${PTEST_PATH}/var | ||
89 | |||
83 | # do NOT need to rebuild Makefile itself | 90 | # do NOT need to rebuild Makefile itself |
84 | sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile | 91 | sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile |
85 | 92 | ||
86 | # Add squid-conf-tests for runtime tests | 93 | # Add squid-conf-tests for runtime tests |
87 | sed -e 's/^\(runtest-TESTS:\)/\1 squid-conf-tests/' \ | 94 | sed -e 's/^\(runtest-TESTS:\)/\1 squid-conf-tests/' \ |
88 | -e "s/\(list=' \$(TESTS)\)/\1 squid-conf-tests/" \ | ||
89 | -i ${D}${PTEST_PATH}/${TESTDIR}/Makefile | 95 | -i ${D}${PTEST_PATH}/${TESTDIR}/Makefile |
90 | 96 | ||
91 | # Ensure the path for command true is correct | 97 | # Ensure the path for command true is correct |
@@ -112,6 +118,7 @@ do_install:append() { | |||
112 | FILES:${PN} += "${libdir} ${datadir}/errors ${datadir}/icons" | 118 | FILES:${PN} += "${libdir} ${datadir}/errors ${datadir}/icons" |
113 | FILES:${PN}-dbg += "/usr/src/debug" | 119 | FILES:${PN}-dbg += "/usr/src/debug" |
114 | FILES:${PN}-doc += "${datadir}/*.txt" | 120 | FILES:${PN}-doc += "${datadir}/*.txt" |
121 | FILES:${PN}-ptest += "${sysconfdir}/squid/squid.conf.default" | ||
115 | 122 | ||
116 | RDEPENDS:${PN} += "perl" | 123 | RDEPENDS:${PN} += "perl" |
117 | RDEPENDS:${PN}-ptest += "make" | 124 | RDEPENDS:${PN}-ptest += "perl make" |