diff options
author | Randy MacLeod <Randy.MacLeod@windriver.com> | 2024-04-09 13:25:27 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-04-09 13:56:26 -0700 |
commit | 9dbf1b42bbbd71f8492117bf5a16137faf5f9fc9 (patch) | |
tree | e1f7c33057d904e84051b93a34b7879f52f14382 /meta-networking/recipes-daemons | |
parent | 64082c18e50b84ab261448950e1a807328ef1ec5 (diff) | |
download | meta-openembedded-9dbf1b42bbbd71f8492117bf5a16137faf5f9fc9.tar.gz |
ncftp: Upgrade to 3.2.7
Switch the SRC_URI from "ftp:" to "https:". Drop the obsolete SRC_URI[md5sum].
Drop ncftp-3.2.5-gcc10.patch since we're using gcc13 and upstream has fixed the build
to work by adding an extern to sh_util/gpshare.c for example.
Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/ncftp/ncftp/ncftp-3.2.5-gcc10.patch | 83 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb (renamed from meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb) | 6 |
2 files changed, 2 insertions, 87 deletions
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-3.2.5-gcc10.patch b/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-3.2.5-gcc10.patch deleted file mode 100644 index 5dee824d7..000000000 --- a/meta-networking/recipes-daemons/ncftp/ncftp/ncftp-3.2.5-gcc10.patch +++ /dev/null | |||
@@ -1,83 +0,0 @@ | |||
1 | Fix build with -fno-common | ||
2 | |||
3 | Patch from https://src.fedoraproject.org/rpms/ncftp/raw/master/f/ncftp-3.2.5-gcc10.patch | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | |||
8 | --- a/ncftp/bookmark.h | ||
9 | +++ b/ncftp/bookmark.h | ||
10 | @@ -29,6 +29,8 @@ typedef struct Bookmark { | ||
11 | int reserved; | ||
12 | } Bookmark; | ||
13 | |||
14 | +extern Bookmark gBm; | ||
15 | + | ||
16 | #define kBookmarkVersion 8 | ||
17 | #define kBookmarkMinVersion 3 | ||
18 | #if (defined(WIN32) || defined(_WINDOWS)) && !defined(__CYGWIN__) | ||
19 | --- a/ncftp/cmds.c | ||
20 | +++ b/ncftp/cmds.c | ||
21 | @@ -98,7 +98,7 @@ extern char gPager[], gHome[], gShell[]; | ||
22 | extern char gOS[]; | ||
23 | extern int gAutoResume; | ||
24 | extern int gAutoSaveChangesToExistingBookmarks; | ||
25 | -extern Bookmark gBm; | ||
26 | +//extern Bookmark gBm; | ||
27 | extern int gLoadedBm, gConfirmClose, gSavePasswords, gScreenColumns; | ||
28 | extern char gLocalCWD[512], gPrevLocalCWD[512]; | ||
29 | extern int gMayCancelJmp; | ||
30 | --- a/ncftp/main.c | ||
31 | +++ b/ncftp/main.c | ||
32 | @@ -38,7 +38,7 @@ extern int gUnprocessedJobs; | ||
33 | char gLocalCWD[512], gPrevLocalCWD[512]; | ||
34 | |||
35 | extern char gRemoteCWD[512], gPrevRemoteCWD[512]; | ||
36 | -extern Bookmark gBm; | ||
37 | +//extern Bookmark gBm; | ||
38 | extern int gLoadedBm; | ||
39 | extern int gFirewallType; | ||
40 | extern char gAutoAscii[]; | ||
41 | --- a/sh_util/gpshare.c | ||
42 | +++ b/sh_util/gpshare.c | ||
43 | @@ -28,7 +28,7 @@ | ||
44 | |||
45 | static int gIsAtty1 = 1, gIsAtty2 = 1; | ||
46 | extern int gLoadedBm, gBookmarkMatchMode; | ||
47 | -Bookmark gBm; | ||
48 | +//Bookmark gBm; | ||
49 | |||
50 | double | ||
51 | FileSize(double size, const char **uStr0, double *uMult0) | ||
52 | --- a/sh_util/ncftpget.c | ||
53 | +++ b/sh_util/ncftpget.c | ||
54 | @@ -40,7 +40,7 @@ extern unsigned int gFirewallPort; | ||
55 | extern char gFirewallExceptionList[256]; | ||
56 | extern int gFwDataPortMode; | ||
57 | extern const char gOS[], gVersion[]; | ||
58 | -extern Bookmark gBm; | ||
59 | +//extern Bookmark gBm; | ||
60 | |||
61 | static void | ||
62 | #if (defined(__GNUC__)) && (__GNUC__ >= 2) | ||
63 | --- a/sh_util/ncftpls.c | ||
64 | +++ b/sh_util/ncftpls.c | ||
65 | @@ -39,7 +39,7 @@ extern unsigned int gFirewallPort; | ||
66 | extern char gFirewallExceptionList[256]; | ||
67 | extern int gFwDataPortMode; | ||
68 | extern const char gOS[], gVersion[]; | ||
69 | -extern Bookmark gBm; | ||
70 | +//extern Bookmark gBm; | ||
71 | |||
72 | static int FTPRemoteRecursiveMList(FTPCIPtr cip, const char *const rdir, /* FTPFileInfoListPtr files, */ FTPLineListPtr lines); | ||
73 | |||
74 | --- a/sh_util/ncftpput.c | ||
75 | +++ b/sh_util/ncftpput.c | ||
76 | @@ -41,7 +41,6 @@ extern unsigned int gFirewallPort; | ||
77 | extern char gFirewallExceptionList[256]; | ||
78 | extern int gFwDataPortMode; | ||
79 | extern const char gOS[], gVersion[]; | ||
80 | -extern Bookmark gBm; | ||
81 | extern int gSendfileInProgress; | ||
82 | |||
83 | static void | ||
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb index e66325c83..15bb00a3a 100644 --- a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb +++ b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb | |||
@@ -5,14 +5,12 @@ LICENSE = "ClArtistic" | |||
5 | LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9c2390809f71465aa7ff76e03dc14d91" | 5 | LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9c2390809f71465aa7ff76e03dc14d91" |
6 | DEPENDS = "ncurses" | 6 | DEPENDS = "ncurses" |
7 | 7 | ||
8 | SRC_URI = "ftp://ftp.ncftp.com/${BPN}/${BP}-src.tar.xz \ | 8 | SRC_URI = "https://www.ncftp.com/public_ftp/ncftp/${BP}-src.tar.xz \ |
9 | file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \ | 9 | file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \ |
10 | file://unistd.patch \ | 10 | file://unistd.patch \ |
11 | file://ncftp-3.2.5-gcc10.patch \ | ||
12 | file://0001-Forward-port-defining-PREFIX_BINDIR-to-use-new-autoc.patch \ | 11 | file://0001-Forward-port-defining-PREFIX_BINDIR-to-use-new-autoc.patch \ |
13 | " | 12 | " |
14 | SRC_URI[md5sum] = "42d0f896d69a4d603ec097546444245f" | 13 | SRC_URI[sha256sum] = "d41c5c4d6614a8eae2ed4e4d7ada6b6d3afcc9fb65a4ed9b8711344bef24f7e8" |
15 | SRC_URI[sha256sum] = "5f200687c05d0807690d9fb770327b226f02dd86155b49e750853fce4e31098d" | ||
16 | 14 | ||
17 | inherit autotools-brokensep pkgconfig | 15 | inherit autotools-brokensep pkgconfig |
18 | 16 | ||