summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-08-16 09:12:17 -0700
committerKhem Raj <raj.khem@gmail.com>2024-08-19 10:19:31 -0700
commit8337af7da4cf96de46eb620f821447ac402734e7 (patch)
tree9081b44031df9838c45353eb4eb30f80d219dd54 /meta-networking/recipes-daemons
parentbe709e18cbe7d38f537302fa14e9b9d29a637835 (diff)
downloadmeta-openembedded-8337af7da4cf96de46eb620f821447ac402734e7.tar.gz
ippool: Fix buildpaths QA error
Pass OE's CFLAGS via CC since the Makefile disregards these flags from environment and has it own notion of it. This ensures that flags to rewrite debug flags are passed down correctly to compiler. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool_1.3.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
index 7947ffe45..90e7814a0 100644
--- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
+++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
@@ -42,7 +42,7 @@ inherit systemd
42DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc" 42DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc"
43RDEPENDS:${PN} = "rpcbind" 43RDEPENDS:${PN} = "rpcbind"
44 44
45EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'" 45EXTRA_OEMAKE = "CC='${CC} ${CFLAGS}' AS='${AS}' LD='${LD} ${LDFLAGS}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
46EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}" 46EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
47# enable self tests 47# enable self tests
48EXTRA_OEMAKE += "IPPOOL_TEST=y" 48EXTRA_OEMAKE += "IPPOOL_TEST=y"
@@ -52,12 +52,7 @@ CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
52SYSTEMD_SERVICE:${PN} = "ippool.service" 52SYSTEMD_SERVICE:${PN} = "ippool.service"
53 53
54do_compile:prepend() { 54do_compile:prepend() {
55 # fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
56 sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
57 sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
58
59 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile 55 sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile
60
61} 56}
62 57
63 58