diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-16 09:12:17 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-19 10:19:31 -0700 |
commit | 8337af7da4cf96de46eb620f821447ac402734e7 (patch) | |
tree | 9081b44031df9838c45353eb4eb30f80d219dd54 /meta-networking/recipes-daemons | |
parent | be709e18cbe7d38f537302fa14e9b9d29a637835 (diff) | |
download | meta-openembedded-8337af7da4cf96de46eb620f821447ac402734e7.tar.gz |
ippool: Fix buildpaths QA error
Pass OE's CFLAGS via CC since the Makefile disregards these flags from
environment and has it own notion of it. This ensures that flags to
rewrite debug flags are passed down correctly to compiler.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/ippool/ippool_1.3.bb | 7 |
1 files changed, 1 insertions, 6 deletions
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb index 7947ffe45..90e7814a0 100644 --- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb +++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb | |||
@@ -42,7 +42,7 @@ inherit systemd | |||
42 | DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc" | 42 | DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc" |
43 | RDEPENDS:${PN} = "rpcbind" | 43 | RDEPENDS:${PN} = "rpcbind" |
44 | 44 | ||
45 | EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'" | 45 | EXTRA_OEMAKE = "CC='${CC} ${CFLAGS}' AS='${AS}' LD='${LD} ${LDFLAGS}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'" |
46 | EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}" | 46 | EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}" |
47 | # enable self tests | 47 | # enable self tests |
48 | EXTRA_OEMAKE += "IPPOOL_TEST=y" | 48 | EXTRA_OEMAKE += "IPPOOL_TEST=y" |
@@ -52,12 +52,7 @@ CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc" | |||
52 | SYSTEMD_SERVICE:${PN} = "ippool.service" | 52 | SYSTEMD_SERVICE:${PN} = "ippool.service" |
53 | 53 | ||
54 | do_compile:prepend() { | 54 | do_compile:prepend() { |
55 | # fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env | ||
56 | sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile | ||
57 | sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile | ||
58 | |||
59 | sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile | 55 | sed -i -e "s:-I/usr/include/pppd:-I=/usr/include/pppd:" ${S}/pppd/Makefile |
60 | |||
61 | } | 56 | } |
62 | 57 | ||
63 | 58 | ||