diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-12-20 15:08:06 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-12-23 13:29:20 -0800 |
commit | 2552c8e916da4fee1195a9af9c109ebd820f4aaf (patch) | |
tree | 8e7f92d2b3451901301119f78695f03343469e98 /meta-networking/recipes-daemons | |
parent | 79ab090e2f5b53ea317ed0038b4f408665f6908c (diff) | |
download | meta-openembedded-2552c8e916da4fee1195a9af9c109ebd820f4aaf.tar.gz |
opensaf: Upgrade to 5.18.09
Degrade certain Werror into warnings to get it building with
gcc >= 8
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch | 12 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/opensaf/opensaf_5.18.09.bb (renamed from meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb) | 7 |
2 files changed, 10 insertions, 9 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch index db6796d05..93c75777f 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch +++ b/meta-networking/recipes-daemons/opensaf/opensaf/0001-Fix-string-overflow-in-snprintf.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From ae7178a78aba2e5766b70191617113487fd7ad0b Mon Sep 17 00:00:00 2001 | 1 | From 88661a60629894353512c53ed32f2b901f64149c Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 16 Apr 2018 18:29:17 -0700 | 3 | Date: Mon, 16 Apr 2018 18:29:17 -0700 |
4 | Subject: [PATCH] Fix string overflow in snprintf | 4 | Subject: [PATCH] Fix string overflow in snprintf |
@@ -53,7 +53,7 @@ index 81e521e..d53cc48 100644 | |||
53 | TRACE_ENTER(); | 53 | TRACE_ENTER(); |
54 | 54 | ||
55 | diff --git a/src/smf/smfd/SmfUpgradeCampaign.cc b/src/smf/smfd/SmfUpgradeCampaign.cc | 55 | diff --git a/src/smf/smfd/SmfUpgradeCampaign.cc b/src/smf/smfd/SmfUpgradeCampaign.cc |
56 | index 45cdce8..6761bcf 100644 | 56 | index c30ea14..098f17a 100644 |
57 | --- a/src/smf/smfd/SmfUpgradeCampaign.cc | 57 | --- a/src/smf/smfd/SmfUpgradeCampaign.cc |
58 | +++ b/src/smf/smfd/SmfUpgradeCampaign.cc | 58 | +++ b/src/smf/smfd/SmfUpgradeCampaign.cc |
59 | @@ -447,7 +447,7 @@ SaAisErrorT SmfUpgradeCampaign::tooManyRestarts(bool *o_result) { | 59 | @@ -447,7 +447,7 @@ SaAisErrorT SmfUpgradeCampaign::tooManyRestarts(bool *o_result) { |
@@ -66,11 +66,11 @@ index 45cdce8..6761bcf 100644 | |||
66 | /* Read the SmfCampRestartInfo object smfCampRestartCnt attr */ | 66 | /* Read the SmfCampRestartInfo object smfCampRestartCnt attr */ |
67 | std::string obj = "smfRestartInfo=info," + | 67 | std::string obj = "smfRestartInfo=info," + |
68 | @@ -473,7 +473,7 @@ SaAisErrorT SmfUpgradeCampaign::tooManyRestarts(bool *o_result) { | 68 | @@ -473,7 +473,7 @@ SaAisErrorT SmfUpgradeCampaign::tooManyRestarts(bool *o_result) { |
69 | attrsmfCampRestartCnt.setName("smfCampRestartCnt"); | 69 | attrsmfCampRestartCnt.SetAttributeName("smfCampRestartCnt"); |
70 | attrsmfCampRestartCnt.setType("SA_IMM_ATTR_SAUINT32T"); | 70 | attrsmfCampRestartCnt.SetAttributeType("SA_IMM_ATTR_SAUINT32T"); |
71 | char buf[5]; | 71 | char buf[5]; |
72 | - snprintf(buf, 4, "%d", curCnt); | 72 | - snprintf(buf, 4, "%d", curCnt); |
73 | + snprintf(buf, 4, "%hd", curCnt); | 73 | + snprintf(buf, 4, "%hd", curCnt); |
74 | attrsmfCampRestartCnt.addValue(buf); | 74 | attrsmfCampRestartCnt.AddAttributeValue(buf); |
75 | imoCampRestartInfo.addValue(attrsmfCampRestartCnt); | 75 | imoCampRestartInfo.AddValue(attrsmfCampRestartCnt); |
76 | 76 | ||
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.18.09.bb index c534c6206..f1aedc4de 100644 --- a/meta-networking/recipes-daemons/opensaf/opensaf_5.18.04.bb +++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.18.09.bb | |||
@@ -29,8 +29,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \ | |||
29 | file://0001-Fix-string-overflow-in-snprintf.patch \ | 29 | file://0001-Fix-string-overflow-in-snprintf.patch \ |
30 | file://0008-check-for-size-before-using-strncpy.patch \ | 30 | file://0008-check-for-size-before-using-strncpy.patch \ |
31 | " | 31 | " |
32 | SRC_URI[md5sum] = "21836e43b13ad33bed9bd0ed391e5a6e" | 32 | SRC_URI[md5sum] = "45044fde0b35eac057a5fa05c27b8040" |
33 | SRC_URI[sha256sum] = "e55dc2645487fb22938e8386b99eef6eb7aff43a246ce3e92488daf6ee46247a" | 33 | SRC_URI[sha256sum] = "230a0ea628ba278170a913746c39b2c8cd529d7dc25326b2e17b5c095cf94025" |
34 | 34 | ||
35 | inherit autotools useradd systemd pkgconfig | 35 | inherit autotools useradd systemd pkgconfig |
36 | 36 | ||
@@ -48,7 +48,8 @@ PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi" | |||
48 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" | 48 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" |
49 | 49 | ||
50 | PKGLIBDIR="${libdir}" | 50 | PKGLIBDIR="${libdir}" |
51 | 51 | CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation" | |
52 | CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation=" | ||
52 | LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" | 53 | LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" |
53 | 54 | ||
54 | do_install_append() { | 55 | do_install_append() { |