diff options
author | Chong Lu <Chong.Lu@windriver.com> | 2014-10-30 10:26:40 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2014-11-04 16:02:44 -0500 |
commit | 22119569b940a9294f37bdb36a84082faa281c1a (patch) | |
tree | 2abf2e9dd8c01962b88f82315abb677b8f444f99 /meta-networking/recipes-daemons | |
parent | c1958c2171ae679a8dc2d4a45ca3ce08ef716c1e (diff) | |
download | meta-openembedded-22119569b940a9294f37bdb36a84082faa281c1a.tar.gz |
squid: change ksh reference in krb ldap helper to sh
This solves the following warning:
squid-3.4.7: squid requires /bin/bash, /usr/bin/perl, but no providers in its
RDEPENDS [file-rdeps]
Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
3 files changed, 41 insertions, 30 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/Change-ksh-reference-in-krb-ldap-helper-to-bash.patch b/meta-networking/recipes-daemons/squid/files/Change-ksh-reference-in-krb-ldap-helper-to-bash.patch deleted file mode 100644 index 6591d5c6f..000000000 --- a/meta-networking/recipes-daemons/squid/files/Change-ksh-reference-in-krb-ldap-helper-to-bash.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 37da4010f41d936c2c727fc32adab832bdde9bec Mon Sep 17 00:00:00 2001 | ||
2 | Message-Id: <37da4010f41d936c2c727fc32adab832bdde9bec.1382481765.git.Jim.Somerville@windriver.com> | ||
3 | From: Jim Somerville <Jim.Somerville@windriver.com> | ||
4 | Date: Tue, 22 Oct 2013 18:39:39 -0400 | ||
5 | Subject: [PATCH 1/1] Change ksh reference in krb ldap helper to bash | ||
6 | |||
7 | Very simple cert_tool script with no ksh specifics. | ||
8 | Change it to use bash so a package dependency doesn't | ||
9 | get created to ksh. | ||
10 | |||
11 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> | ||
12 | --- | ||
13 | helpers/external_acl/kerberos_ldap_group/cert_tool | 3 ++- | ||
14 | 1 files changed, 2 insertions(+), 1 deletions(-) | ||
15 | |||
16 | diff --git a/helpers/external_acl/kerberos_ldap_group/cert_tool b/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
17 | index 9f14959..b61be5d 100644 | ||
18 | --- a/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
19 | +++ b/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
20 | @@ -1,4 +1,5 @@ | ||
21 | -#!/bin/ksh | ||
22 | +#!/bin/bash | ||
23 | +# The above was originally ksh | ||
24 | # | ||
25 | # ----------------------------------------------------------------------------- | ||
26 | # | ||
27 | -- | ||
28 | 1.7.4.1 | ||
29 | |||
diff --git a/meta-networking/recipes-daemons/squid/files/squid-change-ksh-reference-in-krb-ldap-helper-to-sh.patch b/meta-networking/recipes-daemons/squid/files/squid-change-ksh-reference-in-krb-ldap-helper-to-sh.patch new file mode 100644 index 000000000..8e03860b3 --- /dev/null +++ b/meta-networking/recipes-daemons/squid/files/squid-change-ksh-reference-in-krb-ldap-helper-to-sh.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | squid: change ksh reference in krb ldap helper to sh | ||
2 | |||
3 | Very simple cert_tool script with no ksh specifics. | ||
4 | Change it to use sh so a package dependency doesn't | ||
5 | get created to ksh. | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Signed-off-by: Jim Somerville <Jim.Somerville@windriver.com> | ||
10 | Signed-off-by: Chong Lu <Chong.Lu@windriver.com> | ||
11 | --- | ||
12 | helpers/external_acl/kerberos_ldap_group/cert_tool | 6 +++--- | ||
13 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
14 | |||
15 | diff --git a/helpers/external_acl/kerberos_ldap_group/cert_tool b/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
16 | index 9f14959..8c4ea11 100644 | ||
17 | --- a/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
18 | +++ b/helpers/external_acl/kerberos_ldap_group/cert_tool | ||
19 | @@ -1,4 +1,4 @@ | ||
20 | -#!/bin/ksh | ||
21 | +#!/bin/sh | ||
22 | # | ||
23 | # ----------------------------------------------------------------------------- | ||
24 | # | ||
25 | @@ -64,9 +64,9 @@ QUIT | ||
26 | # Create database for Sun ldap and pem file for Openldap | ||
27 | # | ||
28 | rm ${server}_[0-9]*.pem 2>/dev/null | ||
29 | -let i=0 | ||
30 | +i=0 | ||
31 | ls ${server}_[0-9]*.cert | while read file; do | ||
32 | - let i=i+1 | ||
33 | + i=`expr $i + 1` | ||
34 | cat $file >> ${server}_$i.pem | ||
35 | CA=`openssl x509 -noout -text -in ${server}_$i.pem | grep -i "CA:.*true"` | ||
36 | if [ -n "$CA" ]; then | ||
37 | -- | ||
38 | 1.9.1 | ||
39 | |||
diff --git a/meta-networking/recipes-daemons/squid/squid_3.4.7.bb b/meta-networking/recipes-daemons/squid/squid_3.4.7.bb index cd10bd042..c5f616dd4 100644 --- a/meta-networking/recipes-daemons/squid/squid_3.4.7.bb +++ b/meta-networking/recipes-daemons/squid/squid_3.4.7.bb | |||
@@ -16,7 +16,7 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${MIN_VER}/${BPN}-${P | |||
16 | file://Set-up-for-cross-compilation.patch \ | 16 | file://Set-up-for-cross-compilation.patch \ |
17 | file://Skip-AC_RUN_IFELSE-tests.patch \ | 17 | file://Skip-AC_RUN_IFELSE-tests.patch \ |
18 | file://Fix-flawed-dynamic-ldb-link-test-in-configure.patch \ | 18 | file://Fix-flawed-dynamic-ldb-link-test-in-configure.patch \ |
19 | file://Change-ksh-reference-in-krb-ldap-helper-to-bash.patch \ | 19 | file://squid-change-ksh-reference-in-krb-ldap-helper-to-sh.patch \ |
20 | file://squid-use-serial-tests-config-needed-by-ptest.patch \ | 20 | file://squid-use-serial-tests-config-needed-by-ptest.patch \ |
21 | file://run-ptest \ | 21 | file://run-ptest \ |
22 | file://volatiles.03_squid \ | 22 | file://volatiles.03_squid \ |
@@ -63,4 +63,5 @@ FILES_${PN} += "${libdir} ${datadir}/errors ${datadir}/icons" | |||
63 | FILES_${PN}-dbg += "/usr/src/debug" | 63 | FILES_${PN}-dbg += "/usr/src/debug" |
64 | FILES_${PN}-doc += "${datadir}/*.txt" | 64 | FILES_${PN}-doc += "${datadir}/*.txt" |
65 | 65 | ||
66 | RDEPENDS_${PN} += "perl" | ||
66 | RDEPENDS_${PN}-ptest += "make" | 67 | RDEPENDS_${PN}-ptest += "make" |