summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/vsftpd
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-09-28 15:54:04 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-04 00:28:31 +0200
commitfd7973168ab1c8f696cc5e8bcddfeac224cfc775 (patch)
treedbd96fb742333ec9ceece85e7e4cac7cb7701860 /meta-networking/recipes-daemons/vsftpd
parent66182220e8b1133af83f58e40d9d3fa3d358299a (diff)
downloadmeta-openembedded-fd7973168ab1c8f696cc5e8bcddfeac224cfc775.tar.gz
vsftpd: fix pkg_postinst
Fix pkg_postinst to not exit if "$D" is not empty. Otherwise, postinsts from update-rc.d.bbclass would not run and the symlinks under /etc/rc?.d/ would not be created. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/vsftpd')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
index a1c4ff4ad..07c73c5f7 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.2.bb
@@ -88,12 +88,11 @@ USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp
88GROUPADD_PARAM_${PN} = "-r ftp" 88GROUPADD_PARAM_${PN} = "-r ftp"
89 89
90pkg_postinst_${PN}() { 90pkg_postinst_${PN}() {
91 if [ -n "$D" ]; then 91 if [ -z "$D" ]; then
92 exit 0
93 fi
94 if type systemd-tmpfiles >/dev/null; then 92 if type systemd-tmpfiles >/dev/null; then
95 systemd-tmpfiles --create 93 systemd-tmpfiles --create
96 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then 94 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
97 ${sysconfdir}/init.d/populate-volatile.sh update 95 ${sysconfdir}/init.d/populate-volatile.sh update
98 fi 96 fi
97 fi
99} 98}