diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-07-27 11:53:44 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-30 19:15:24 -0700 |
commit | ca22e1996dae65fc50e92d23bdcefe2607da7105 (patch) | |
tree | b3298cedfa3716978fe62c6493f7c742e6b1789c /meta-networking/recipes-daemons/postfix | |
parent | af907bf362e9358e924619423196b14b103f5e62 (diff) | |
download | meta-openembedded-ca22e1996dae65fc50e92d23bdcefe2607da7105.tar.gz |
postfix: Fix build failures with glibc 2.30
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/postfix')
3 files changed, 51 insertions, 15 deletions
diff --git a/meta-networking/recipes-daemons/postfix/files/0001-Fixed-build-failure-with-glibc-2.30-due-to-dropped-R.patch b/meta-networking/recipes-daemons/postfix/files/0001-Fixed-build-failure-with-glibc-2.30-due-to-dropped-R.patch new file mode 100644 index 000000000..22adaff72 --- /dev/null +++ b/meta-networking/recipes-daemons/postfix/files/0001-Fixed-build-failure-with-glibc-2.30-due-to-dropped-R.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 8b3792830f4930fee7fbb00c854d9766f2b74dca Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 27 Jul 2019 11:35:38 -0700 | ||
4 | Subject: [PATCH] Fixed build failure with glibc 2.30 due to dropped | ||
5 | RES_INSECURE1/2 macros | ||
6 | |||
7 | see [1] | ||
8 | |||
9 | [1] https://sourceware.org/git/?p=glibc.git;a=commit;h=333221862ecbebde60dd16e7ca17d26444e62f50 | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/dns/dns_str_resflags.c | 6 ++++++ | ||
15 | 1 file changed, 6 insertions(+) | ||
16 | |||
17 | diff --git a/src/dns/dns_str_resflags.c b/src/dns/dns_str_resflags.c | ||
18 | index 5f2cce5..df32345 100644 | ||
19 | --- a/src/dns/dns_str_resflags.c | ||
20 | +++ b/src/dns/dns_str_resflags.c | ||
21 | @@ -60,10 +60,16 @@ static const LONG_NAME_MASK resflag_table[] = { | ||
22 | "RES_DEFNAMES", RES_DEFNAMES, | ||
23 | "RES_STAYOPEN", RES_STAYOPEN, | ||
24 | "RES_DNSRCH", RES_DNSRCH, | ||
25 | +#ifdef RES_INSECURE1 | ||
26 | "RES_INSECURE1", RES_INSECURE1, | ||
27 | +#endif | ||
28 | +#ifdef RES_INSECURE2 | ||
29 | "RES_INSECURE2", RES_INSECURE2, | ||
30 | +#endif | ||
31 | "RES_NOALIASES", RES_NOALIASES, | ||
32 | +#ifdef RES_USE_INET6 | ||
33 | "RES_USE_INET6", RES_USE_INET6, | ||
34 | +#endif | ||
35 | #ifdef RES_ROTATE | ||
36 | "RES_ROTATE", RES_ROTATE, | ||
37 | #endif | ||
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc index 94379412f..778100533 100644 --- a/meta-networking/recipes-daemons/postfix/postfix.inc +++ b/meta-networking/recipes-daemons/postfix/postfix.inc | |||
@@ -14,17 +14,6 @@ DEPENDS = "db icu libpcre libnsl2 openssl postfix-native \ | |||
14 | LICENSE = "IPL-1.0 | EPL-2.0" | 14 | LICENSE = "IPL-1.0 | EPL-2.0" |
15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b181651ad99a7dc4cc8c4ce2f491ed1a" | 15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b181651ad99a7dc4cc8c4ce2f491ed1a" |
16 | 16 | ||
17 | SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \ | ||
18 | file://makedefs.patch \ | ||
19 | file://install.patch \ | ||
20 | file://main.cf \ | ||
21 | file://postfix \ | ||
22 | file://internal_recipient \ | ||
23 | file://postfix.service \ | ||
24 | file://aliasesdb \ | ||
25 | file://check_hostname.sh \ | ||
26 | " | ||
27 | |||
28 | S = "${WORKDIR}/postfix-${PV}" | 17 | S = "${WORKDIR}/postfix-${PV}" |
29 | 18 | ||
30 | CLEANBROKEN = "1" | 19 | CLEANBROKEN = "1" |
diff --git a/meta-networking/recipes-daemons/postfix/postfix_3.4.5.bb b/meta-networking/recipes-daemons/postfix/postfix_3.4.5.bb index 3ce805553..189baea5c 100644 --- a/meta-networking/recipes-daemons/postfix/postfix_3.4.5.bb +++ b/meta-networking/recipes-daemons/postfix/postfix_3.4.5.bb | |||
@@ -1,9 +1,19 @@ | |||
1 | require postfix.inc | 1 | require postfix.inc |
2 | 2 | ||
3 | SRC_URI += "file://0001-makedefs-Use-native-compiler-to-build-makedefs.test.patch \ | 3 | SRC_URI += "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \ |
4 | file://postfix-install.patch \ | 4 | file://makedefs.patch \ |
5 | file://icu-config.patch \ | 5 | file://install.patch \ |
6 | file://0001-makedefs-add-lnsl-and-lresolv-to-SYSLIBS-by-default.patch \ | 6 | file://main.cf \ |
7 | file://postfix \ | ||
8 | file://internal_recipient \ | ||
9 | file://postfix.service \ | ||
10 | file://aliasesdb \ | ||
11 | file://check_hostname.sh \ | ||
12 | file://0001-makedefs-Use-native-compiler-to-build-makedefs.test.patch \ | ||
13 | file://postfix-install.patch \ | ||
14 | file://icu-config.patch \ | ||
15 | file://0001-makedefs-add-lnsl-and-lresolv-to-SYSLIBS-by-default.patch \ | ||
16 | file://0001-Fixed-build-failure-with-glibc-2.30-due-to-dropped-R.patch \ | ||
7 | " | 17 | " |
8 | SRC_URI[md5sum] = "093109941095390562166de766d4720d" | 18 | SRC_URI[md5sum] = "093109941095390562166de766d4720d" |
9 | SRC_URI[sha256sum] = "8b2ba54f9d2a049582a0ed3ee2dbe96ba57e278feea9cb4f80e1a61844e6319f" | 19 | SRC_URI[sha256sum] = "8b2ba54f9d2a049582a0ed3ee2dbe96ba57e278feea9cb4f80e1a61844e6319f" |