summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/cyrus-sasl
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2013-10-30 14:45:54 -0400
committerJoe MacDonald <joe@deserted.net>2013-10-31 10:55:55 -0400
commit82d1ec9d612a0d1300efa912dd01e20068016705 (patch)
tree07e9a11baadce1508cf85fa06ace576b73308008 /meta-networking/recipes-daemons/cyrus-sasl
parent27ba970b9eabd254aea24848420c4d3b8674761f (diff)
downloadmeta-openembedded-82d1ec9d612a0d1300efa912dd01e20068016705.tar.gz
cyrus-sasl: ensure size_t is defined for use by sasl.h
While making use of the cyrus-sasl library an external application will most likely include sasl.h which will cause compilation failures if steps haven't been taken to define size_t. This should not be the responsibility of the application building against the sasl library but rather handled already in sasl.h. Here we ensure sasl.h has the proper includes to have size_t defined before it is used. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-daemons/cyrus-sasl')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch31
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch
new file mode 100644
index 000000000..ecbab845d
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch
@@ -0,0 +1,31 @@
1From 92d72789c811b0d55f624a8bac5ccc4412f5996e Mon Sep 17 00:00:00 2001
2From: Ken Murchison <murch@andrew.cmu.edu>
3Date: Thu, 20 Dec 2012 18:14:50 -0500
4Subject: [PATCH] sasl.h: #include <stddef.h> for size_t on NetBSD
5
6This patch was imported from git://git.cyrusimap.org/cyrus-sasl
7commit 67a188693796a14e3a76ac603104807fbbfddfc4
8
9Upstream-Status: Backport
10
11Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
12---
13 include/sasl.h | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/include/sasl.h b/include/sasl.h
17index fef4d51..8b8a63f 100755
18--- a/include/sasl.h
19+++ b/include/sasl.h
20@@ -121,6 +121,8 @@
21 #ifndef SASL_H
22 #define SASL_H 1
23
24+#include <stddef.h> /* For size_t */
25+
26 /* Keep in sync with win32/common.mak */
27 #define SASL_VERSION_MAJOR 2
28 #define SASL_VERSION_MINOR 1
29--
301.8.3.2
31
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
index f05ab8510..2abaee2e3 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -9,6 +9,7 @@ SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
9 file://Fix-hardcoded-libdir.patch \ 9 file://Fix-hardcoded-libdir.patch \
10 file://debian_patches_0009_sasldb_al.diff \ 10 file://debian_patches_0009_sasldb_al.diff \
11 file://debian_patches_0014_avoid_pic_overwrite.diff \ 11 file://debian_patches_0014_avoid_pic_overwrite.diff \
12 file://sasl.h-include-stddef.h-for-size_t-on-NetBSD.patch \
12 " 13 "
13 14
14inherit autotools pkgconfig useradd 15inherit autotools pkgconfig useradd