summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/autofs
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2013-03-13 22:23:39 +0100
committerJoe MacDonald <joe.macdonald@windriver.com>2013-03-18 15:13:52 -0400
commit9641d4dff422b235ecd46947716361206b9b1e37 (patch)
tree895eae8d447b9f4257c6a7c9d29801d1bdafafba /meta-networking/recipes-daemons/autofs
parent68a37289727ed5fab880f606154946d7be749a93 (diff)
downloadmeta-openembedded-9641d4dff422b235ecd46947716361206b9b1e37.tar.gz
autofs: fix compile with uclibc
* Backport patch to make yp optional, which uclibc doesn't provide. * Create patch to include linux/nfs.h instead of nfs/nfs.h. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-daemons/autofs')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch32
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-make-yellow-pages-support-optional.patch145
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb4
3 files changed, 180 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch
new file mode 100644
index 000000000..3a878980a
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch
@@ -0,0 +1,32 @@
1Upstream-Status: Pending
2
3From 44bdce8c6ed9b30c1643e5981172a4f9025f013c Mon Sep 17 00:00:00 2001
4From: Andreas Oberritter <obi@opendreambox.org>
5Date: Wed, 13 Mar 2013 16:17:08 +0100
6Subject: [PATCH] autofs-5.0.7: include linux/nfs.h directly in rpc_subs.h
7
8Fixes compile error with uclibc. Glibc's nfs/nfs.h contains
9nothing but "#include linux/nfs.h". rpc_subs.h already includes
10other linux/nfs*.h files directly.
11
12Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
13---
14 include/rpc_subs.h | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/include/rpc_subs.h b/include/rpc_subs.h
18index b6d59f9..a2d9648 100644
19--- a/include/rpc_subs.h
20+++ b/include/rpc_subs.h
21@@ -18,7 +18,7 @@
22
23 #include <rpc/rpc.h>
24 #include <rpc/pmap_prot.h>
25-#include <nfs/nfs.h>
26+#include <linux/nfs.h>
27 #include <linux/nfs2.h>
28 #include <linux/nfs3.h>
29
30--
311.7.10.4
32
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-make-yellow-pages-support-optional.patch b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-make-yellow-pages-support-optional.patch
new file mode 100644
index 000000000..9504d8e7f
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.0.7/autofs-5.0.7-make-yellow-pages-support-optional.patch
@@ -0,0 +1,145 @@
1Upstream-Status: Backport
2
3autofs-5.0.7 - make yellow pages support optional
4
5From: Chris Packham <chris.packham@alliedtelesis.co.nz>
6
7If rpcsvc/ypclnt.h is not available don't compile in Yellow Pages
8support.
9---
10
11 Makefile.conf.in | 3 +++
12 configure | 16 ++++++++++++++++
13 configure.in | 9 +++++++++
14 include/config.h.in | 3 +++
15 lib/rpc_subs.c | 1 -
16 modules/Makefile | 9 +++++++--
17 7 files changed, 39 insertions(+), 3 deletions(-)
18
19
20diff --git a/Makefile.conf.in b/Makefile.conf.in
21index 802318b..3766d45 100644
22--- a/Makefile.conf.in
23+++ b/Makefile.conf.in
24@@ -43,6 +43,9 @@ NISPLUS = @HAVE_NISPLUS@
25 # SMBFS support: yes (1) no (0)
26 SMBFS = @HAVE_SMBMOUNT@
27
28+# YellowPages support: yes (1) no (0)
29+YPCLNT = @HAVE_YPCLNT@
30+
31 # Support for calling e2fsck when mounting ext2 filesystems
32 EXT2FS = @HAVE_E2FSCK@
33
34diff --git a/configure b/configure
35index 3722a46..cf6428c 100755
36--- a/configure
37+++ b/configure
38@@ -614,6 +614,7 @@ XML_FLAGS
39 LIBLDAP
40 HAVE_LDAP
41 LDAP_FLAGS
42+HAVE_YPCLNT
43 HAVE_NISPLUS
44 EGREP
45 GREP
46@@ -4575,6 +4576,21 @@ fi
47
48
49
50+# YellowPages support?
51+HAVE_YPCLNT=0
52+ac_fn_c_check_header_mongrel "$LINENO" "rpcsvc/ypclnt.h" "ac_cv_header_rpcsvc_ypclnt_h" "$ac_includes_default"
53+if test "x$ac_cv_header_rpcsvc_ypclnt_h" = xyes; then :
54+ HAVE_YPCLNT=1
55+fi
56+
57+
58+
59+if test "$HAVE_YPCLNT" = "1"; then
60+
61+$as_echo "#define HAVE_YPCLNT 1" >>confdefs.h
62+
63+fi
64+
65 #
66 # OpenLDAP support? Expect that this may have a special directory...
67 #
68diff --git a/configure.in b/configure.in
69index 90bda62..363c376 100644
70--- a/configure.in
71+++ b/configure.in
72@@ -213,6 +213,15 @@ HAVE_NISPLUS=0
73 AC_CHECK_HEADER(rpcsvc/nis.h, HAVE_NISPLUS=1)
74 AC_SUBST(HAVE_NISPLUS)
75
76+# YellowPages support?
77+HAVE_YPCLNT=0
78+AC_CHECK_HEADER([rpcsvc/ypclnt.h], HAVE_YPCLNT=1)
79+AC_SUBST(HAVE_YPCLNT)
80+if test "$HAVE_YPCLNT" = "1"; then
81+ AC_DEFINE(HAVE_YPCLNT, 1,
82+ [Define if using YellowPages])
83+fi
84+
85 #
86 # OpenLDAP support? Expect that this may have a special directory...
87 #
88diff --git a/include/config.h.in b/include/config.h.in
89index 9bdf98a..7f1c5b5 100644
90--- a/include/config.h.in
91+++ b/include/config.h.in
92@@ -72,6 +72,9 @@
93 /* Define to 1 if you have the <unistd.h> header file. */
94 #undef HAVE_UNISTD_H
95
96+/* Define if using YellowPages */
97+#undef HAVE_YPCLNT
98+
99 /* Use libxml2 tsd usage workaround */
100 #undef LIBXML2_WORKAROUND
101
102diff --git a/lib/rpc_subs.c b/lib/rpc_subs.c
103index ad1d557..718caf9 100644
104--- a/lib/rpc_subs.c
105+++ b/lib/rpc_subs.c
106@@ -27,7 +27,6 @@
107 #include <net/if.h>
108 #include <netinet/in.h>
109 #include <arpa/inet.h>
110-#include <rpcsvc/ypclnt.h>
111 #include <errno.h>
112 #include <sys/ioctl.h>
113 #include <ctype.h>
114diff --git a/modules/Makefile b/modules/Makefile
115index 939da7c..c5deb24 100644
116--- a/modules/Makefile
117+++ b/modules/Makefile
118@@ -5,13 +5,13 @@
119 -include ../Makefile.conf
120 include ../Makefile.rules
121
122-SRCS := lookup_yp.c lookup_file.c lookup_program.c lookup_userhome.c \
123+SRCS := lookup_file.c lookup_program.c lookup_userhome.c \
124 lookup_multi.c lookup_hosts.c lookup_dir.c \
125 parse_sun.c \
126 mount_generic.c mount_nfs.c mount_afs.c mount_autofs.c \
127 mount_changer.c mount_bind.c
128
129-MODS := lookup_yp.so lookup_file.so lookup_program.so lookup_userhome.so \
130+MODS := lookup_file.so lookup_program.so lookup_userhome.so \
131 lookup_multi.so lookup_hosts.so lookup_dir.so \
132 parse_sun.so \
133 mount_generic.so mount_nfs.so mount_afs.so mount_autofs.so \
134@@ -37,6 +37,11 @@ ifeq ($(NISPLUS), 1)
135 MODS += lookup_nisplus.so
136 endif
137
138+ifeq ($(YPCLNT), 1)
139+ SRCS += lookup_yp.c
140+ MODS += lookup_yp.so
141+endif
142+
143 ifeq ($(LDAP), 1)
144 SRCS += lookup_ldap.c
145 MODS += lookup_ldap.so
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index 215d29382..44985b2eb 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -3,7 +3,7 @@ SECTION = "base"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6PR = "r1" 6PR = "r2"
7 7
8DEPENDS += "libtirpc flex-native bison-native" 8DEPENDS += "libtirpc flex-native bison-native"
9 9
@@ -27,6 +27,8 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
27 file://autofs-5.0.6-fix-recursive-mount-deadlock.patch \ 27 file://autofs-5.0.6-fix-recursive-mount-deadlock.patch \
28 file://autofs-5.0.6-increase-file-map-read-buffer-size.patch \ 28 file://autofs-5.0.6-increase-file-map-read-buffer-size.patch \
29 file://autofs-5.0.7-handle-new-location-of-systemd.patch \ 29 file://autofs-5.0.7-handle-new-location-of-systemd.patch \
30 file://autofs-5.0.7-make-yellow-pages-support-optional.patch \
31 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
30 file://Makefile.rules-cross.patch \ 32 file://Makefile.rules-cross.patch \
31 file://no-bash.patch \ 33 file://no-bash.patch \
32 file://cross.patch \ 34 file://cross.patch \