diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-30 00:18:57 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-04-25 15:55:36 -0400 |
commit | 9e69cd9c18af17f1b7e478f46f225ca863f03062 (patch) | |
tree | 47ea6901f74125a25cf588cb4b8a5992a94f0726 /meta-networking/recipes-connectivity | |
parent | 46cd79e49ecc8a13b93971fa3625d854e9e2ff0a (diff) | |
download | meta-openembedded-9e69cd9c18af17f1b7e478f46f225ca863f03062.tar.gz |
daq: Fix build with musl
unistd.h is not in sys/ on all platforms
use standard location in /usr/include to look for it
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r-- | meta-networking/recipes-connectivity/daq/daq_2.0.6.bb | 4 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/daq/files/0001-correct-the-location-of-unistd.h.patch | 29 |
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/daq/daq_2.0.6.bb b/meta-networking/recipes-connectivity/daq/daq_2.0.6.bb index 952d7a42d..47cb163e6 100644 --- a/meta-networking/recipes-connectivity/daq/daq_2.0.6.bb +++ b/meta-networking/recipes-connectivity/daq/daq_2.0.6.bb | |||
@@ -9,7 +9,9 @@ PARALLEL_MAKE = "" | |||
9 | DEPENDS = "libpcap libpcre libdnet" | 9 | DEPENDS = "libpcap libpcre libdnet" |
10 | 10 | ||
11 | SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \ | 11 | SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \ |
12 | file://disable-run-test-program-while-cross-compiling.patch " | 12 | file://disable-run-test-program-while-cross-compiling.patch \ |
13 | file://0001-correct-the-location-of-unistd.h.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | # these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking | 16 | # these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking |
15 | # this error from test-dependencies script: | 17 | # this error from test-dependencies script: |
diff --git a/meta-networking/recipes-connectivity/daq/files/0001-correct-the-location-of-unistd.h.patch b/meta-networking/recipes-connectivity/daq/files/0001-correct-the-location-of-unistd.h.patch new file mode 100644 index 000000000..4798a77f5 --- /dev/null +++ b/meta-networking/recipes-connectivity/daq/files/0001-correct-the-location-of-unistd.h.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 10e7d4e4bfcb70344d18f0d4ce36068475747f25 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 29 Mar 2017 15:59:43 -0700 | ||
4 | Subject: [PATCH] correct the location of unistd.h | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | os-daq-modules/daq_ipfw.c | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/os-daq-modules/daq_ipfw.c b/os-daq-modules/daq_ipfw.c | ||
12 | index 016beb0..c2a4175 100644 | ||
13 | --- a/os-daq-modules/daq_ipfw.c | ||
14 | +++ b/os-daq-modules/daq_ipfw.c | ||
15 | @@ -23,10 +23,10 @@ | ||
16 | #include <stdlib.h> | ||
17 | #include <string.h> | ||
18 | #include <stdio.h> | ||
19 | +#include <unistd.h> | ||
20 | |||
21 | #include <sys/types.h> | ||
22 | #include <sys/time.h> | ||
23 | -#include <sys/unistd.h> | ||
24 | |||
25 | #include <netinet/in.h> | ||
26 | #include <sys/socket.h> | ||
27 | -- | ||
28 | 2.12.1 | ||
29 | |||