diff options
author | Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br> | 2015-01-29 18:22:19 -0200 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-02-23 13:21:07 -0500 |
commit | 7fc8172e3d36c8ed48c62a27740ea4b59e88afee (patch) | |
tree | 3d2b92a9c55e131b8c2260052919e5b0ca63e879 /meta-networking/recipes-connectivity | |
parent | 13670f904b0807d3da9faf2034921ec264359b60 (diff) | |
download | meta-openembedded-7fc8172e3d36c8ed48c62a27740ea4b59e88afee.tar.gz |
crda: upgrade to 3.13
CRDA has been relicensed under the copyleft-next license.
Regulatory bins license remains ISC.
There is an new internal library called libreg.so which was
placed in the same directory of the regulatory bin. The call
to make was adjusted accordingly.
Remove version 1.1.3.
Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
6 files changed, 200 insertions, 38 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch b/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch new file mode 100644 index 000000000..36464004d --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From: "John W. Linville" <linville@tuxdriver.com> | ||
2 | Date: Fri, 14 Feb 2014 13:58:44 -0500 | ||
3 | Subject: [PATCH] crda: Add DESTDIR support in install-libreg* rules in Makefile | ||
4 | Origin: https://git.kernel.org/?p=linux/kernel/git/mcgrof/crda.git/commit?id=2cabb2588da56735369131b709f191453c080be0 | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | |||
8 | Signed-off-by: John W. Linville <linville@tuxdriver.com> | ||
9 | Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com> | ||
10 | --- | ||
11 | Makefile | 8 ++++---- | ||
12 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile b/Makefile | ||
15 | index 0b2f0d7..1f25509 100644 | ||
16 | --- a/Makefile | ||
17 | +++ b/Makefile | ||
18 | @@ -120,13 +120,13 @@ $(LIBREG): regdb.h reglib.h reglib.c | ||
19 | |||
20 | install-libreg-headers: | ||
21 | $(NQ) ' INSTALL libreg-headers' | ||
22 | - $(Q)mkdir -p $(INCLUDE_DIR) | ||
23 | - $(Q)cp *.h $(INCLUDE_DIR)/ | ||
24 | + $(Q)mkdir -p $(DESTDIR)/$(INCLUDE_DIR) | ||
25 | + $(Q)cp *.h $(DESTDIR)/$(INCLUDE_DIR)/ | ||
26 | |||
27 | install-libreg: | ||
28 | $(NQ) ' INSTALL libreg' | ||
29 | - $(Q)mkdir -p $(LIBDIR) | ||
30 | - $(Q)cp $(LIBREG) $(LIBDIR)/ | ||
31 | + $(Q)mkdir -p $(DESTDIR)/$(LIBDIR) | ||
32 | + $(Q)cp $(LIBREG) $(DESTDIR)/$(LIBDIR)/ | ||
33 | $(Q)ldconfig | ||
34 | |||
35 | %.o: %.c regdb.h $(LIBREG) | ||
diff --git a/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Fix-the-linking-order-to-avoid-compilation-erro.patch b/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Fix-the-linking-order-to-avoid-compilation-erro.patch new file mode 100644 index 000000000..68b4b13e9 --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda-3.13/crda-Fix-the-linking-order-to-avoid-compilation-erro.patch | |||
@@ -0,0 +1,51 @@ | |||
1 | From: Krishna Chaitanya <chaitanya.mgit@gmail.com> | ||
2 | Date: Mon, 16 Dec 2013 21:57:39 +0530 | ||
3 | Subject: [PATCH] crda: Fix the linking order to avoid compilation error | ||
4 | Origin: https://git.kernel.org/?p=linux/kernel/git/mcgrof/crda.git/commit?id=fefefdb2c52c8fbedbb339b4badb8226cad7e7e0 | ||
5 | |||
6 | While linking the crda.o and libreg.so, first put crda.o | ||
7 | and then -lreg. This fixed the below error: | ||
8 | |||
9 | GEN keys-gcrypt.c | ||
10 | Trusted pubkeys: pubkeys/linville.key.pub.pem | ||
11 | CC libreg.so | ||
12 | CC crda.o | ||
13 | LD crda | ||
14 | crda.o: In function `main': | ||
15 | crda/crda.c:196: undefined reference to `reglib_get_rd_alpha2' | ||
16 | collect2: ld returned 1 exit status | ||
17 | make: *** [crda] Error 1 | ||
18 | |||
19 | Note: This still doesn't fix the below error (will send another mail) | ||
20 | |||
21 | CHK /usr/lib/crda/regulatory.bin | ||
22 | Database signature verification failed. | ||
23 | Invalid or empty regulatory file, note: a binary regulatory file should be used. | ||
24 | make: *** [verify] Error 234 | ||
25 | |||
26 | Upstream-Status: Backport | ||
27 | |||
28 | Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com> | ||
29 | Signed-off-by: Chaitanya T K <chaitanya.mgit@gmail.com> | ||
30 | --- | ||
31 | Makefile | 5 +++-- | ||
32 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
33 | |||
34 | diff --git a/Makefile b/Makefile | ||
35 | index 4a351c6..0b2f0d7 100644 | ||
36 | --- a/Makefile | ||
37 | +++ b/Makefile | ||
38 | @@ -28,10 +28,11 @@ RUNTIME_PUBKEY_DIR?=/etc/wireless-regdb/pubkeys | ||
39 | CFLAGS += -O2 -fpic | ||
40 | CFLAGS += -std=gnu99 -Wall -Werror -pedantic | ||
41 | CFLAGS += -Wall -g | ||
42 | -LDLIBS += -lm | ||
43 | LDLIBREG += -lreg | ||
44 | +LDLIBS += $(LDLIBREG) | ||
45 | +LDLIBS += -lm | ||
46 | LIBREG += libreg.so | ||
47 | -LDFLAGS += -L ./ $(LDLIBREG) | ||
48 | +LDFLAGS += -L ./ | ||
49 | |||
50 | all: all_noverify verify | ||
51 | |||
diff --git a/meta-networking/recipes-connectivity/crda/crda-3.13/do-not-run-ldconfig-if-destdir-is-set.patch b/meta-networking/recipes-connectivity/crda/crda-3.13/do-not-run-ldconfig-if-destdir-is-set.patch new file mode 100644 index 000000000..3ef35ee54 --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda-3.13/do-not-run-ldconfig-if-destdir-is-set.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | From: Ben Hutchings <ben@decadent.org.uk> | ||
2 | Date: Sat, 23 Aug 2014 12:27:34 -0700 | ||
3 | Subject: crda: Do not run ldconfig if DESTDIR is set | ||
4 | |||
5 | Upstream-Status: Backport [http://www.spinics.net/lists/linux-wireless/msg126028.html] | ||
6 | |||
7 | Signed-off-by: Ben Hutchings <ben@decadent.org.uk> | ||
8 | Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> | ||
9 | |||
10 | --- a/Makefile | ||
11 | +++ b/Makefile | ||
12 | @@ -132,7 +132,9 @@ install-libreg: | ||
13 | $(NQ) ' INSTALL libreg' | ||
14 | $(Q)mkdir -p $(DESTDIR)/$(LIBDIR) | ||
15 | $(Q)cp $(LIBREG) $(DESTDIR)/$(LIBDIR)/ | ||
16 | +ifndef DESTDIR | ||
17 | $(Q)ldconfig | ||
18 | +endif | ||
19 | |||
20 | %.o: %.c regdb.h $(LIBREG) | ||
21 | $(NQ) ' CC ' $@ | ||
diff --git a/meta-networking/recipes-connectivity/crda/crda-3.13/fix-linking-of-libraries-used-by-reglib.patch b/meta-networking/recipes-connectivity/crda/crda-3.13/fix-linking-of-libraries-used-by-reglib.patch new file mode 100644 index 000000000..aceb56df7 --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda-3.13/fix-linking-of-libraries-used-by-reglib.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | From: Ben Hutchings <ben@decadent.org.uk> | ||
2 | Date: Sat, 23 Aug 2014 12:26:37 -0700 | ||
3 | Subject: Fix linking of libraries used by libreg | ||
4 | |||
5 | The math and crypto libraries are called by and need to be linked to | ||
6 | libreg.so, not to the executables. | ||
7 | |||
8 | Upstream-Status: Backport [http://www.spinics.net/lists/linux-wireless/msg126027.html] | ||
9 | |||
10 | Signed-off-by: Ben Hutchings <ben@decadent.org.uk> | ||
11 | Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> | ||
12 | |||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -30,7 +30,7 @@ CFLAGS += -std=gnu99 -Wall -Werror -peda | ||
16 | CFLAGS += -Wall -g | ||
17 | LDLIBREG += -lreg | ||
18 | LDLIBS += $(LDLIBREG) | ||
19 | -LDLIBS += -lm | ||
20 | +LIBREGLDLIBS += -lm | ||
21 | LIBREG += libreg.so | ||
22 | LDFLAGS += -L ./ | ||
23 | |||
24 | @@ -40,7 +40,7 @@ all_noverify: $(LIBREG) crda intersect r | ||
25 | |||
26 | ifeq ($(USE_OPENSSL),1) | ||
27 | CFLAGS += -DUSE_OPENSSL -DPUBKEY_DIR=\"$(RUNTIME_PUBKEY_DIR)\" `pkg-config --cflags openssl` | ||
28 | -LDLIBS += `pkg-config --libs openssl` | ||
29 | +LIBREGLDLIBS += `pkg-config --libs openssl` | ||
30 | |||
31 | ifeq ($(RUNTIME_PUBKEY_ONLY),1) | ||
32 | CFLAGS += -DRUNTIME_PUBKEY_ONLY | ||
33 | @@ -51,7 +51,7 @@ endif | ||
34 | |||
35 | else | ||
36 | CFLAGS += -DUSE_GCRYPT | ||
37 | -LDLIBS += -lgcrypt | ||
38 | +LIBREGLDLIBS += -lgcrypt | ||
39 | |||
40 | $(LIBREG): keys-gcrypt.c | ||
41 | |||
42 | @@ -121,7 +121,7 @@ keys-%.c: utils/key2pub.py $(wildcard $( | ||
43 | |||
44 | $(LIBREG): regdb.h reglib.h reglib.c | ||
45 | $(NQ) ' CC ' $@ | ||
46 | - $(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^ | ||
47 | + $(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^ $(LIBREGLDLIBS) | ||
48 | |||
49 | install-libreg-headers: | ||
50 | $(NQ) ' INSTALL libreg-headers' | ||
diff --git a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb b/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb deleted file mode 100644 index 0bb899860..000000000 --- a/meta-networking/recipes-connectivity/crda/crda_1.1.3.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | SUMMARY = "Wireless Central Regulatory Domain Agent" | ||
2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" | ||
3 | |||
4 | LICENSE = "ISC" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c" | ||
6 | |||
7 | |||
8 | DEPENDS = "python-m2crypto-native python-native libgcrypt libnl" | ||
9 | |||
10 | SRC_URI = "http://wireless.kernel.org/download/crda/${BP}.tar.bz2;name=crda \ | ||
11 | http://wireless.kernel.org/download/wireless-regdb/regulatory.bins/2013.01.11-regulatory.bin;name=bin \ | ||
12 | " | ||
13 | SRC_URI[crda.md5sum] = "29579185e06a75675507527243d28e5c" | ||
14 | SRC_URI[crda.sha256sum] = "aa8a7fe92f0765986c421a5b6768a185375ac210393df0605ee132f6754825f0" | ||
15 | SRC_URI[bin.md5sum] = "e0c8a5ca63fb8bf803213f9a0c90b50b" | ||
16 | SRC_URI[bin.sha256sum] = "b1ee0b20c123c612dfdb6851ab42c01666f66fb583e0e590942f19bb54cf84be" | ||
17 | |||
18 | inherit python-dir pythonnative | ||
19 | # Recursive make problem | ||
20 | EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D}" | ||
21 | |||
22 | do_compile() { | ||
23 | oe_runmake all_noverify | ||
24 | } | ||
25 | |||
26 | do_install() { | ||
27 | oe_runmake SBINDIR=${sbindir}/ install | ||
28 | |||
29 | install -d ${D}${libdir}/crda/ | ||
30 | |||
31 | install -m 0644 ${WORKDIR}/2013.01.11-regulatory.bin ${D}${libdir}/crda/regulatory.bin | ||
32 | } | ||
33 | |||
34 | |||
35 | RDEPENDS_${PN} = "udev" | ||
36 | FILES_${PN} += "${libdir}crda/regulatory.bin \ | ||
37 | ${base_libdir}/udev/rules.d/85-regulatory.rules \ | ||
38 | " | ||
diff --git a/meta-networking/recipes-connectivity/crda/crda_3.13.bb b/meta-networking/recipes-connectivity/crda/crda_3.13.bb new file mode 100644 index 000000000..2ccced42e --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda_3.13.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | SUMMARY = "Wireless Central Regulatory Domain Agent" | ||
2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" | ||
3 | |||
4 | LICENSE = "copyleft-next-0.3.0 & ISC" | ||
5 | LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe \ | ||
6 | file://${WORKDIR}/wireless-regdb-2014.11.18/LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c" | ||
7 | |||
8 | DEPENDS = "python-m2crypto-native python-native" | ||
9 | |||
10 | SRC_URI = "https://www.kernel.org/pub/software/network/crda/${BP}.tar.xz;name=crda \ | ||
11 | https://www.kernel.org/pub/software/network/wireless-regdb/wireless-regdb-2014.11.18.tar.xz;name=bin \ | ||
12 | file://crda-Fix-the-linking-order-to-avoid-compilation-erro.patch \ | ||
13 | file://crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch \ | ||
14 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ | ||
15 | file://fix-linking-of-libraries-used-by-reglib.patch \ | ||
16 | " | ||
17 | SRC_URI[crda.md5sum] = "66b1b0417c1ad19f0009a5c0c0c1aebc" | ||
18 | SRC_URI[crda.sha256sum] = "2f85da7ab0170b140d6ed62596c8f268d4a7dedecf84cac7182ada979742ff59" | ||
19 | |||
20 | SRC_URI[bin.md5sum] = "d750c402c5510add7380edcb1d9b75b2" | ||
21 | SRC_URI[bin.sha256sum] = "eab6b50f30748a8b0065ba38cf3df05aac161a5861ae0a6c3cfd01d38a71c9dd" | ||
22 | |||
23 | inherit python-dir pythonnative | ||
24 | # Recursive make problem | ||
25 | EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg'" | ||
26 | |||
27 | do_compile() { | ||
28 | oe_runmake all_noverify | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | oe_runmake SBINDIR=${sbindir}/ install | ||
33 | |||
34 | install -d ${D}${libdir}/crda/ | ||
35 | |||
36 | install -m 0644 ${WORKDIR}/wireless-regdb-2014.11.18/regulatory.bin ${D}${libdir}/crda/regulatory.bin | ||
37 | } | ||
38 | |||
39 | |||
40 | RDEPENDS_${PN} = "udev libgcrypt libnl" | ||
41 | FILES_${PN} += "${libdir}crda/regulatory.bin \ | ||
42 | ${base_libdir}/udev/rules.d/85-regulatory.rules \ | ||
43 | " | ||