diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2018-09-03 11:32:15 +1200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-09-04 11:55:21 -0700 |
commit | 9c0243b69180741ef722fd03d4291c3f31fad9e2 (patch) | |
tree | c482ff1b1f73d5da979a4d29ebad843ae308f3bd /meta-networking/recipes-connectivity | |
parent | 35952eda3f73ad2937b1ee3243b1e189d6def1f6 (diff) | |
download | meta-openembedded-9c0243b69180741ef722fd03d4291c3f31fad9e2.tar.gz |
mosquitto: upgrade to 1.5.1
This includes one security fix and numerous other bugfixes. MQTT version
3.1.1 is now the default protocol.
See the following for details:
https://mosquitto.org/blog/2018/08/version-151-released/
https://mosquitto.org/blog/2018/05/version-1-5-released/
Changes to the recipe:
* Drop explicit installation of the libmosquitto.a static library
because this no longer gets built by default, and the normal
"make install" which we are running will install it anyway if it were
to be enabled.
* Drop our service file since there is one supplied in the source tree
* Enable systemd notify support when systemd is being used
* Update comments in the init script
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init | 4 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service | 15 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb (renamed from meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb) | 11 |
3 files changed, 6 insertions, 24 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init index d2a27b273..6a0c12760 100644 --- a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init +++ b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.init | |||
@@ -8,9 +8,9 @@ | |||
8 | # Required-Stop: $remote_fs $syslog | 8 | # Required-Stop: $remote_fs $syslog |
9 | # Default-Start: 2 3 4 5 | 9 | # Default-Start: 2 3 4 5 |
10 | # Default-Stop: 0 1 6 | 10 | # Default-Stop: 0 1 6 |
11 | # Short-Description: mosquitto MQTT v3.1 message broker | 11 | # Short-Description: mosquitto MQTT message broker |
12 | # Description: | 12 | # Description: |
13 | # This is a message broker that supports version 3.1 of the MQ Telemetry | 13 | # This is a message broker that supports version 3.1/3.1.1 of the MQ Telemetry |
14 | # Transport (MQTT) protocol. | 14 | # Transport (MQTT) protocol. |
15 | # | 15 | # |
16 | # MQTT provides a method of carrying out messaging using a publish/subscribe | 16 | # MQTT provides a method of carrying out messaging using a publish/subscribe |
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service b/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service deleted file mode 100644 index 25f68fae0..000000000 --- a/meta-networking/recipes-connectivity/mosquitto/files/mosquitto.service +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Mosquitto - lightweight server implementation of the MQTT and MQTT-SN protocols | ||
3 | ConditionPathExists=/etc/mosquitto/mosquitto.conf | ||
4 | After=network.target | ||
5 | |||
6 | [Service] | ||
7 | Type=simple | ||
8 | ExecStartPre=/bin/rm -f /var/run/mosquitto.pid | ||
9 | ExecStart=/usr/sbin/mosquitto -c /etc/mosquitto/mosquitto.conf | ||
10 | ExecReload=/bin/kill -HUP $MAINPID | ||
11 | PIDFile=/var/run/mosquitto.pid | ||
12 | Restart=on-failure | ||
13 | |||
14 | [Install] | ||
15 | WantedBy=multi-user.target | ||
diff --git a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb index f451687a6..fa51f4e76 100644 --- a/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.4.15.bb +++ b/meta-networking/recipes-connectivity/mosquitto/mosquitto_1.5.1.bb | |||
@@ -12,12 +12,11 @@ DEPENDS = "uthash" | |||
12 | 12 | ||
13 | SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ | 13 | SRC_URI = "http://mosquitto.org/files/source/mosquitto-${PV}.tar.gz \ |
14 | file://0002-uthash-remove-in-tree-version.patch \ | 14 | file://0002-uthash-remove-in-tree-version.patch \ |
15 | file://mosquitto.service \ | ||
16 | file://mosquitto.init \ | 15 | file://mosquitto.init \ |
17 | " | 16 | " |
18 | 17 | ||
19 | SRC_URI[md5sum] = "546cb1ce35cc3f7d23e6d2f1f9a962e7" | 18 | SRC_URI[md5sum] = "f98c99998a36a234f3a9d9b402b991db" |
20 | SRC_URI[sha256sum] = "7d3b3e245a3b4ec94b05678c8199c806359737949f4cfe0bf936184f6ca89a83" | 19 | SRC_URI[sha256sum] = "8557bc7ae34dfaf32a0fb56d2491b7a7f731269c88337227233013502df4d5b0" |
21 | 20 | ||
22 | inherit systemd update-rc.d useradd | 21 | inherit systemd update-rc.d useradd |
23 | 22 | ||
@@ -34,6 +33,7 @@ EXTRA_OEMAKE = " \ | |||
34 | ${@bb.utils.contains('PACKAGECONFIG', 'dns-srv', 'WITH_SRV=yes', 'WITH_SRV=no', d)} \ | 33 | ${@bb.utils.contains('PACKAGECONFIG', 'dns-srv', 'WITH_SRV=yes', 'WITH_SRV=no', d)} \ |
35 | ${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \ | 34 | ${@bb.utils.contains('PACKAGECONFIG', 'ssl', 'WITH_TLS=yes WITH_TLS_PSK=yes', 'WITH_TLS=no WITH_TLS_PSK=no', d)} \ |
36 | ${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \ | 35 | ${@bb.utils.contains('PACKAGECONFIG', 'uuid', 'WITH_UUID=yes', 'WITH_UUID=no', d)} \ |
36 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'WITH_SYSTEMD=yes', 'WITH_SYSTEMD=no', d)} \ | ||
37 | STRIP=/bin/true \ | 37 | STRIP=/bin/true \ |
38 | WITH_DOCS=no \ | 38 | WITH_DOCS=no \ |
39 | " | 39 | " |
@@ -43,11 +43,8 @@ export LIB_SUFFIX = "${@d.getVar('baselib', True).replace('lib', '')}" | |||
43 | do_install() { | 43 | do_install() { |
44 | oe_runmake 'DESTDIR=${D}' install | 44 | oe_runmake 'DESTDIR=${D}' install |
45 | 45 | ||
46 | install -d ${D}${libdir} | ||
47 | install -m 0644 lib/libmosquitto.a ${D}${libdir}/ | ||
48 | |||
49 | install -d ${D}${systemd_unitdir}/system/ | 46 | install -d ${D}${systemd_unitdir}/system/ |
50 | install -m 0644 ${WORKDIR}/mosquitto.service ${D}${systemd_unitdir}/system/ | 47 | install -m 0644 ${S}/service/systemd/mosquitto.service.notify ${D}${systemd_unitdir}/system/mosquitto.service |
51 | 48 | ||
52 | install -d ${D}${sysconfdir}/mosquitto | 49 | install -d ${D}${sysconfdir}/mosquitto |
53 | install -m 0644 ${D}${sysconfdir}/mosquitto/mosquitto.conf.example \ | 50 | install -m 0644 ${D}${sysconfdir}/mosquitto/mosquitto.conf.example \ |