summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-11-30 13:04:04 +0100
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-17 10:57:42 -0500
commit380f0cef364c1a3749b574ee29f44cca004088b0 (patch)
treee775df9921c037911a8abe4505c6c19c7c178c56 /meta-networking/recipes-connectivity
parentcb9e340867bc12b440a9ac25363b412168ad8f13 (diff)
downloadmeta-openembedded-380f0cef364c1a3749b574ee29f44cca004088b0.tar.gz
samba: simplify LSB handling
Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index 804a4d2dd..c2436af4e 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -38,8 +38,8 @@ DEPENDS_append_libc-musl = " libtirpc"
38CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc" 38CFLAGS_append_libc-musl = " -I${STAGING_INCDIR}/tirpc"
39LDFLAGS_append_libc-musl = " -ltirpc" 39LDFLAGS_append_libc-musl = " -ltirpc"
40 40
41SYSVINITTYPE_linuxstdbase = "lsb" 41LSB = ""
42SYSVINITTYPE = "sysv" 42LSB_linuxstdbase = "lsb"
43 43
44INITSCRIPT_NAME = "samba" 44INITSCRIPT_NAME = "samba"
45INITSCRIPT_PARAMS = "start 20 3 5 . stop 20 0 1 6 ." 45INITSCRIPT_PARAMS = "start 20 3 5 . stop 20 0 1 6 ."
@@ -48,19 +48,16 @@ SYSTEMD_PACKAGES = "${PN}-base winbind"
48SYSTEMD_SERVICE_${PN}-base = "nmb.service smb.service" 48SYSTEMD_SERVICE_${PN}-base = "nmb.service smb.service"
49SYSTEMD_SERVICE_winbind = "winbind.service" 49SYSTEMD_SERVICE_winbind = "winbind.service"
50 50
51PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${SYSVINITTYPE}', '', d)} \ 51PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
52 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
53 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'zeroconf', '', d)} \ 52 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'zeroconf', '', d)} \
54 acl cups ldap \ 53 acl cups ldap \
55" 54"
56 55
57RDEPENDS_${PN}-base += "${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'lsb', '', d)}" 56RDEPENDS_${PN}-base += "${LSB}"
58RDEPENDS_${PN}-ctdb-tests += "bash util-linux-getopt" 57RDEPENDS_${PN}-ctdb-tests += "bash util-linux-getopt"
59 58
60PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl" 59PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl"
61PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin" 60PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
62PACKAGECONFIG[lsb] = ",,lsb"
63PACKAGECONFIG[sysv] = ",,sysvinit"
64PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups" 61PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups"
65PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap" 62PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
66PACKAGECONFIG[sasl] = ",,cyrus-sasl" 63PACKAGECONFIG[sasl] = ",,cyrus-sasl"
@@ -121,7 +118,7 @@ do_install_append() {
121 install -m644 packaging/systemd/samba.conf.tmp ${D}${sysconfdir}/tmpfiles.d/samba.conf 118 install -m644 packaging/systemd/samba.conf.tmp ${D}${sysconfdir}/tmpfiles.d/samba.conf
122 echo "d ${localstatedir}/log/samba 0755 root root -" \ 119 echo "d ${localstatedir}/log/samba 0755 root root -" \
123 >> ${D}${sysconfdir}/tmpfiles.d/samba.conf 120 >> ${D}${sysconfdir}/tmpfiles.d/samba.conf
124 if ${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'true', 'false', d)}; then 121 if [ "${LSB}" = "lsb" ]; then
125 install -d ${D}${sysconfdir}/init.d 122 install -d ${D}${sysconfdir}/init.d
126 install -m 0755 packaging/LSB/samba.sh ${D}${sysconfdir}/init.d/samba 123 install -m 0755 packaging/LSB/samba.sh ${D}${sysconfdir}/init.d/samba
127 else 124 else