summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-11 10:53:05 +0800
committerKhem Raj <raj.khem@gmail.com>2018-10-10 20:48:18 -0700
commit9f47fcd33739c92dc86003182ac32b2535db7f32 (patch)
tree5e87257a82388a6c948d939eb0e3a3cf91cea25f /meta-networking/recipes-connectivity
parentf72160a3dc1ee7e8c0edfb19cfdb4b6a7fa3ab2b (diff)
downloadmeta-openembedded-9f47fcd33739c92dc86003182ac32b2535db7f32.tar.gz
freeradius: fix radiusd.service startup failed problem
during radiusd start up, it will check several CVEs of libssl, if allow_vulnerable_openssl set to no and one of the CVEs is matched, radiusd will not startup. in tls.c, two CVEs's version number is wrong, and after upgrade openssl to 1.1.1, one CVE matched, so startup failed. correct the version numner to make radiusd startup successfully. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/freeradius/files/0001-freeradius-correct-version-number-of-libssl-defect.patch44
-rw-r--r--meta-networking/recipes-connectivity/freeradius/freeradius_3.0.17.bb1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/freeradius/files/0001-freeradius-correct-version-number-of-libssl-defect.patch b/meta-networking/recipes-connectivity/freeradius/files/0001-freeradius-correct-version-number-of-libssl-defect.patch
new file mode 100644
index 000000000..9e1f5b2ef
--- /dev/null
+++ b/meta-networking/recipes-connectivity/freeradius/files/0001-freeradius-correct-version-number-of-libssl-defect.patch
@@ -0,0 +1,44 @@
1From fecf974b63f72eeb12d3b43522e948ca2bc704d4 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Thu, 11 Oct 2018 09:45:52 +0800
4Subject: [PATCH] freeradius: correct version number of libssl defect
5
6Upstream-Status: Backport [https://github.com/FreeRADIUS/freeradius-server
7 /commit/ad039347beca4ded297813a1da6eabb61fcf2ddd]
8
9upstream have refactored this part code into
10src/lib/tls/base.c, and problem also have fixed
11by commit ad039347beca
12
13Signed-off-by: Changqing Li <changqing.li@windriver.com>
14---
15 src/main/tls.c | 8 ++++----
16 1 file changed, 4 insertions(+), 4 deletions(-)
17
18diff --git a/src/main/tls.c b/src/main/tls.c
19index acbfe79..d9c91f1 100644
20--- a/src/main/tls.c
21+++ b/src/main/tls.c
22@@ -72,15 +72,15 @@ typedef struct libssl_defect {
23 static libssl_defect_t libssl_defects[] =
24 {
25 {
26- .low = 0x01010101f, /* 1.1.0a */
27- .high = 0x01010101f, /* 1.1.0a */
28+ .low = 0x01010001f, /* 1.1.0a */
29+ .high = 0x01010001f, /* 1.1.0a */
30 .id = "CVE-2016-6309",
31 .name = "OCSP status request extension",
32 .comment = "For more information see https://www.openssl.org/news/secadv/20160926.txt"
33 },
34 {
35- .low = 0x01010100f, /* 1.1.0 */
36- .high = 0x01010100f, /* 1.1.0 */
37+ .low = 0x010100000f, /* 1.1.0 */
38+ .high = 0x01010000f, /* 1.1.0 */
39 .id = "CVE-2016-6304",
40 .name = "OCSP status request extension",
41 .comment = "For more information see https://www.openssl.org/news/secadv/20160922.txt"
42--
432.7.4
44
diff --git a/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.17.bb b/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.17.bb
index 1b45e780a..c17d56dea 100644
--- a/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.17.bb
+++ b/meta-networking/recipes-connectivity/freeradius/freeradius_3.0.17.bb
@@ -29,6 +29,7 @@ SRC_URI = "ftp://ftp.freeradius.org/pub/freeradius/freeradius-server-${PV}.tar.b
29 file://0001-rlm_mschap-Use-includedir-instead-of-hardcoding-usr-.patch \ 29 file://0001-rlm_mschap-Use-includedir-instead-of-hardcoding-usr-.patch \
30 file://radiusd.service \ 30 file://radiusd.service \
31 file://radiusd-volatiles.conf \ 31 file://radiusd-volatiles.conf \
32 file://0001-freeradius-correct-version-number-of-libssl-defect.patch \
32" 33"
33SRC_URI[md5sum] = "1f4ad38f32101a7d50d818afa6f17339" 34SRC_URI[md5sum] = "1f4ad38f32101a7d50d818afa6f17339"
34SRC_URI[sha256sum] = "3f03404b6e4a4f410e1f15ea2ababfec7f8a7ae8a49836d8a0c137436d913b96" 35SRC_URI[sha256sum] = "3f03404b6e4a4f410e1f15ea2ababfec7f8a7ae8a49836d8a0c137436d913b96"