summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-09-17 12:04:42 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2016-10-20 10:25:49 -0400
commita95726df4bb1c898da7e4d4dbf9e2846914061e4 (patch)
tree699cb947435fb868862a6c357712a5418652ebbd /meta-networking/recipes-connectivity
parent3fdfdd8ff4f2cb8c70dd08d5c0cf363384259563 (diff)
downloadmeta-openembedded-a95726df4bb1c898da7e4d4dbf9e2846914061e4.tar.gz
samba: replace pam packageconfig by hard dependency
samba links against libpam even if pam is not in packageconfig and libpam was built before. This patch avoid this floating dependency - other solution could not be found. For those who want packageconfig back, see discussion iat [1] for further inspiration. [1] http://lists.openembedded.org/pipermail/openembedded-devel/2016-September/109143.html Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index 3686faaee..e9694d4e9 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -28,7 +28,7 @@ inherit systemd waf-samba cpan-base perlnative update-rc.d
28# remove default added RDEPENDS on perl 28# remove default added RDEPENDS on perl
29RDEPENDS_${PN}_remove = "perl" 29RDEPENDS_${PN}_remove = "perl"
30 30
31DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb krb5 libbsd libaio" 31DEPENDS += "readline virtual/libiconv zlib popt libtalloc libtdb libtevent libldb krb5 libbsd libaio libpam"
32 32
33SYSVINITTYPE_linuxstdbase = "lsb" 33SYSVINITTYPE_linuxstdbase = "lsb"
34SYSVINITTYPE = "sysv" 34SYSVINITTYPE = "sysv"
@@ -36,8 +36,7 @@ SYSVINITTYPE = "sysv"
36INITSCRIPT_NAME = "samba.sh" 36INITSCRIPT_NAME = "samba.sh"
37INITSCRIPT_PARAMS = "start 20 3 5 . stop 20 0 1 6 ." 37INITSCRIPT_PARAMS = "start 20 3 5 . stop 20 0 1 6 ."
38 38
39PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 39PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${SYSVINITTYPE}', '', d)} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${SYSVINITTYPE}', '', d)} \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ 40 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
42 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'zeroconf', '', d)} \ 41 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'zeroconf', '', d)} \
43 acl cups ldap \ 42 acl cups ldap \
@@ -48,7 +47,6 @@ RDEPENDS_${PN}-ctdb-tests += "bash"
48 47
49PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl" 48PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl"
50PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin" 49PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
51PACKAGECONFIG[pam] = "--with-pam --with-pammodulesdir=${base_libdir}/security,--without-pam,libpam"
52PACKAGECONFIG[lsb] = ",,lsb" 50PACKAGECONFIG[lsb] = ",,lsb"
53PACKAGECONFIG[sysv] = ",,sysvinit" 51PACKAGECONFIG[sysv] = ",,sysvinit"
54PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups" 52PACKAGECONFIG[cups] = "--enable-cups,--disable-cups,cups"
@@ -85,6 +83,7 @@ EXTRA_OECONF += "--enable-fhs \
85 --with-cluster-support \ 83 --with-cluster-support \
86 --with-profiling-data \ 84 --with-profiling-data \
87 --with-libiconv=${STAGING_DIR_HOST}${prefix} \ 85 --with-libiconv=${STAGING_DIR_HOST}${prefix} \
86 --with-pam --with-pammodulesdir=${base_libdir}/security \
88 " 87 "
89DISABLE_STATIC = "" 88DISABLE_STATIC = ""
90 89