summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-08-14 10:30:09 +0200
committerKhem Raj <raj.khem@gmail.com>2024-09-01 15:54:30 -0700
commit84d6e138cb558cea9155e5a392e2ff7647e2e688 (patch)
tree816a1e846cecedb61817337825a37c59fcd7edd8 /meta-networking/recipes-connectivity
parentc8f4a786402063d160fa16284c16c8fca8165a5a (diff)
downloadmeta-openembedded-84d6e138cb558cea9155e5a392e2ff7647e2e688.tar.gz
cleanup after polkit fix
This commit removes the need to fix polkit permissions: https://git.openembedded.org/meta-openembedded/commit/?h=master-next&id=d5e90541f8e35916abc930b2da6de037b23d51a1 That allows to do some cleanup Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
index 42e20cc9e..e7f0987e0 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4 4
5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" 5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native"
6 6
7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache useradd features_check python3targetconfig 7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache features_check python3targetconfig
8 8
9REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" 9REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
10 10
@@ -60,12 +60,3 @@ do_install:append() {
60 ${D}${bindir}/blueman-services \ 60 ${D}${bindir}/blueman-services \
61 ${D}${bindir}/blueman-tray 61 ${D}${bindir}/blueman-tray
62} 62}
63
64USERADD_PACKAGES = "${PN}"
65USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
66
67do_install:append() {
68 # Fix up permissions on polkit rules.d to work with rpm4 constraints
69 chmod 700 ${D}/${datadir}/polkit-1/rules.d
70 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
71}