diff options
author | Wenzong Fan <wenzong.fan@windriver.com> | 2015-12-15 02:43:59 -0500 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-01-05 12:43:32 -0500 |
commit | 71cebad9798894a9aac19577c1a1a6a08046390b (patch) | |
tree | 66e269d0d9101003667d8b4f4567fe3c63730097 /meta-networking/recipes-connectivity | |
parent | 053248455f81262900922ce556452e61cf105ab4 (diff) | |
download | meta-openembedded-71cebad9798894a9aac19577c1a1a6a08046390b.tar.gz |
samba: add PACKAGECONFIG for valgrind
* Add configure options '--without-valgrind'
* Disable valgrind by default since it doesn't build for all targets
This fixes build errors:
../source3/include/includes.h:156:31: fatal error: \
valgrind/memcheck.h: No such file or directory
compilation terminated.
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba-4.1.12/21-add-config-option-without-valgrind.patch | 63 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.1.12.bb | 2 |
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.1.12/21-add-config-option-without-valgrind.patch b/meta-networking/recipes-connectivity/samba/samba-4.1.12/21-add-config-option-without-valgrind.patch new file mode 100644 index 000000000..025ac2775 --- /dev/null +++ b/meta-networking/recipes-connectivity/samba/samba-4.1.12/21-add-config-option-without-valgrind.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From 9a2d6315ff206b2a47100dfd85afe3af56576995 Mon Sep 17 00:00:00 2001 | ||
2 | From: Wenzong Fan <wenzong.fan@windriver.com> | ||
3 | Date: Thu, 10 Dec 2015 04:20:51 -0500 | ||
4 | Subject: [PATCH] Add config option without-valgrind | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | ||
9 | --- | ||
10 | lib/replace/wscript | 4 +++- | ||
11 | source3/wscript | 5 ++++- | ||
12 | wscript | 4 ++++ | ||
13 | 3 files changed, 11 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/lib/replace/wscript b/lib/replace/wscript | ||
16 | index f0040b1..aca73af 100644 | ||
17 | --- a/lib/replace/wscript | ||
18 | +++ b/lib/replace/wscript | ||
19 | @@ -101,7 +101,9 @@ struct foo bar = { .y = 'X', .x = 1 }; | ||
20 | |||
21 | conf.CHECK_CODE('', headers='rpc/rpc.h rpcsvc/yp_prot.h', define='HAVE_RPCSVC_YP_PROT_H') | ||
22 | |||
23 | - conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') | ||
24 | + if not Options.options.disable_valgrind: | ||
25 | + conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') | ||
26 | + | ||
27 | conf.CHECK_HEADERS('nss_common.h nsswitch.h ns_api.h') | ||
28 | conf.CHECK_HEADERS('sys/extattr.h sys/ea.h sys/proplist.h sys/cdefs.h') | ||
29 | conf.CHECK_HEADERS('utmp.h utmpx.h lastlog.h malloc.h') | ||
30 | diff --git a/source3/wscript b/source3/wscript | ||
31 | index bac3dd5..a5c51ea 100644 | ||
32 | --- a/source3/wscript | ||
33 | +++ b/source3/wscript | ||
34 | @@ -1016,7 +1016,10 @@ syscall(SYS_setgroups32, 0, NULL); | ||
35 | Logs.warn("--with-dnsupdate=yes but gssapi support not sufficient") | ||
36 | else: | ||
37 | conf.DEFINE('WITH_DNS_UPDATES', 1) | ||
38 | - conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') | ||
39 | + | ||
40 | + if not Options.options.disable_valgrind: | ||
41 | + conf.CHECK_HEADERS('valgrind.h valgrind/valgrind.h valgrind/memcheck.h') | ||
42 | + | ||
43 | if Options.options.developer: | ||
44 | if conf.CONFIG_SET('HAVE_VALGRIND_H') or conf.CONFIG_SET('HAVE_VALGRIND_VALGRIND_H'): | ||
45 | conf.DEFINE('VALGRIND', '1') | ||
46 | diff --git a/wscript b/wscript | ||
47 | index 7679c0f..681ac17 100644 | ||
48 | --- a/wscript | ||
49 | +++ b/wscript | ||
50 | @@ -72,6 +72,10 @@ def set_options(opt): | ||
51 | help=("Disable systemd integration"), | ||
52 | action='store_false', dest='enable_systemd') | ||
53 | |||
54 | + opt.add_option('--without-valgrind', | ||
55 | + help=("Disable use of the valgrind headers"), | ||
56 | + action="store_true", dest='disable_valgrind', default=False) | ||
57 | + | ||
58 | gr = opt.option_group('developer options') | ||
59 | |||
60 | opt.tool_options('python') # options for disabling pyc or pyo compilation | ||
61 | -- | ||
62 | 1.9.1 | ||
63 | |||
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb index 75cf5d228..9ca017848 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb | |||
@@ -33,6 +33,7 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \ | |||
33 | file://18-avoid-get-config-by-native-ncurses.patch \ | 33 | file://18-avoid-get-config-by-native-ncurses.patch \ |
34 | file://19-systemd-daemon-is-contained-by-libsystemd.patch \ | 34 | file://19-systemd-daemon-is-contained-by-libsystemd.patch \ |
35 | file://20-do-not-import-target-module-while-cross-compile.patch \ | 35 | file://20-do-not-import-target-module-while-cross-compile.patch \ |
36 | file://21-add-config-option-without-valgrind.patch \ | ||
36 | " | 37 | " |
37 | 38 | ||
38 | SRC_URI[md5sum] = "232016d7581a1ba11e991ec2674553c4" | 39 | SRC_URI[md5sum] = "232016d7581a1ba11e991ec2674553c4" |
@@ -65,6 +66,7 @@ PACKAGECONFIG[sasl] = ",,cyrus-sasl" | |||
65 | PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" | 66 | PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" |
66 | PACKAGECONFIG[dmapi] = "--with-dmapi,--without-dmapi,dmapi" | 67 | PACKAGECONFIG[dmapi] = "--with-dmapi,--without-dmapi,dmapi" |
67 | PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi" | 68 | PACKAGECONFIG[zeroconf] = "--enable-avahi,--disable-avahi,avahi" |
69 | PACKAGECONFIG[valgrind] = ",--without-valgrind,valgrind," | ||
68 | 70 | ||
69 | SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'sasl', '', 'file://21-avoid-sasl-unless-wanted.patch', d)}" | 71 | SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'sasl', '', 'file://21-avoid-sasl-unless-wanted.patch', d)}" |
70 | 72 | ||