summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-15 13:45:14 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-16 21:26:12 -0400
commit35326fa74dee53ffa4bd454e5fc95fdcbf0d5da6 (patch)
tree891a2c80bf0ea3ee4bb7dac92b3997f177bc4c0d /meta-networking/recipes-connectivity
parent6555c34fd3a392d72983d3d2ae6464e32fe44fa0 (diff)
downloadmeta-openembedded-35326fa74dee53ffa4bd454e5fc95fdcbf0d5da6.tar.gz
samba: upgrade to 4.4.5
* This is a security release in order to address the following defect: - CVE-2016-2119 (Client side SMB2/3 required signing can be downgraded) * Detail release note: - https://www.samba.org/samba/history/samba-4.4.5.html * Removed part of the 10-use-only-libsystemd.patch which has been fixed in new version. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch81
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/00-fix-typos-in-man-pages.patch (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/00-fix-typos-in-man-pages.patch)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/0006-avoid-using-colon-in-the-checking-msg.patch (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/0006-avoid-using-colon-in-the-checking-msg.patch)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/10-use-only-libsystemd.patch30
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/16-do-not-check-xsltproc-manpages.patch (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/16-do-not-check-xsltproc-manpages.patch)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/20-do-not-import-target-module-while-cross-compile.patch (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/20-do-not-import-target-module-while-cross-compile.patch)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/21-add-config-option-without-valgrind.patch (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/21-add-config-option-without-valgrind.patch)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.5/volatiles.03_samba (renamed from meta-networking/recipes-connectivity/samba/samba-4.4.2/volatiles.03_samba)0
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb (renamed from meta-networking/recipes-connectivity/samba/samba_4.4.2.bb)4
9 files changed, 32 insertions, 83 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch
deleted file mode 100644
index 81621ff2a..000000000
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch
+++ /dev/null
@@ -1,81 +0,0 @@
1diff -ur samba-4.4.2/lib/util/become_daemon.c samba-4.4.2/lib/util/become_daemon.c
2--- samba-4.4.2/lib/util/become_daemon.c 2016-05-08 18:33:24.000000000 +0200
3+++ samba-4.4.2/lib/util/become_daemon.c 2016-05-08 18:26:50.275177918 +0200
4@@ -24,7 +24,7 @@
5 #include "includes.h"
6 #include "system/filesys.h"
7 #include "system/locale.h"
8-#if HAVE_LIBSYSTEMD_DAEMON
9+#if HAVE_LIBSYSTEMD
10 #include <systemd/sd-daemon.h>
11 #endif
12 #include "lib/util/close_low_fd.h"
13@@ -69,9 +69,9 @@
14 if (do_fork) {
15 newpid = fork();
16 if (newpid) {
17-#if HAVE_LIBSYSTEMD_DAEMON
18+#if HAVE_LIBSYSTEMD
19 sd_notifyf(0, "READY=0\nSTATUS=Starting process...\nMAINPID=%lu", (unsigned long) newpid);
20-#endif /* HAVE_LIBSYSTEMD_DAEMON */
21+#endif /* HAVE_LIBSYSTEMD */
22 _exit(0);
23 }
24 }
25@@ -98,7 +98,7 @@
26
27 _PUBLIC_ void exit_daemon(const char *msg, int error)
28 {
29-#ifdef HAVE_LIBSYSTEMD_DAEMON
30+#ifdef HAVE_LIBSYSTEMD
31 if (msg == NULL) {
32 msg = strerror(error);
33 }
34@@ -117,7 +117,7 @@
35 if (name == NULL) {
36 name = "Samba";
37 }
38-#ifdef HAVE_LIBSYSTEMD_DAEMON
39+#ifdef HAVE_LIBSYSTEMD
40 sd_notifyf(0, "READY=1\nSTATUS=%s: ready to serve connections...", name);
41 #endif
42 DEBUG(0, ("STATUS=daemon '%s' finished starting up and ready to serve "
43@@ -129,7 +129,7 @@
44 if (name == NULL) {
45 name = "Samba";
46 }
47-#ifdef HAVE_LIBSYSTEMD_DAEMON
48+#ifdef HAVE_LIBSYSTEMD
49 sd_notifyf(0, "\nSTATUS=%s: %s", name, msg);
50 #endif
51 DEBUG(0, ("STATUS=daemon '%s' : %s", name, msg));
52diff -ur samba-4.4.2/lib/util/debug.c samba-4.4.2/lib/util/debug.c
53--- samba-4.4.2/lib/util/debug.c 2016-05-08 18:33:24.000000000 +0200
54+++ samba-4.4.2/lib/util/debug.c 2016-05-08 18:27:09.341481492 +0200
55@@ -102,7 +102,7 @@
56 .fd = 2 /* stderr by default */
57 };
58
59-#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD_JOURNAL)
60+#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD)
61 static int debug_level_to_priority(int level)
62 {
63 /*
64@@ -179,7 +179,7 @@
65 }
66 #endif /* WITH_SYSLOG */
67
68-#ifdef HAVE_LIBSYSTEMD_JOURNAL
69+#ifdef HAVE_LIBSYSTEMD
70 #include <systemd/sd-journal.h>
71 static void debug_systemd_log(int msg_level,
72 const char *msg, const char *msg_no_nl)
73@@ -251,7 +251,7 @@
74 },
75 #endif
76
77-#ifdef HAVE_LIBSYSTEMD_JOURNAL
78+#ifdef HAVE_LIBSYSTEMD
79 {
80 .name = "systemd",
81 .log = debug_systemd_log,
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/00-fix-typos-in-man-pages.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/00-fix-typos-in-man-pages.patch
index c94bc3185..c94bc3185 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/00-fix-typos-in-man-pages.patch
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/00-fix-typos-in-man-pages.patch
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/0006-avoid-using-colon-in-the-checking-msg.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/0006-avoid-using-colon-in-the-checking-msg.patch
index cdf7a38c1..cdf7a38c1 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/0006-avoid-using-colon-in-the-checking-msg.patch
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/0006-avoid-using-colon-in-the-checking-msg.patch
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.5/10-use-only-libsystemd.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/10-use-only-libsystemd.patch
new file mode 100644
index 000000000..0ddc9410c
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/10-use-only-libsystemd.patch
@@ -0,0 +1,30 @@
1diff -ur samba-4.4.2/lib/util/debug.c samba-4.4.2/lib/util/debug.c
2--- samba-4.4.2/lib/util/debug.c 2016-05-08 18:33:24.000000000 +0200
3+++ samba-4.4.2/lib/util/debug.c 2016-05-08 18:27:09.341481492 +0200
4@@ -102,7 +102,7 @@
5 .fd = 2 /* stderr by default */
6 };
7
8-#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD_JOURNAL)
9+#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD)
10 static int debug_level_to_priority(int level)
11 {
12 /*
13@@ -179,7 +179,7 @@
14 }
15 #endif /* WITH_SYSLOG */
16
17-#ifdef HAVE_LIBSYSTEMD_JOURNAL
18+#ifdef HAVE_LIBSYSTEMD
19 #include <systemd/sd-journal.h>
20 static void debug_systemd_log(int msg_level,
21 const char *msg, const char *msg_no_nl)
22@@ -251,7 +251,7 @@
23 },
24 #endif
25
26-#ifdef HAVE_LIBSYSTEMD_JOURNAL
27+#ifdef HAVE_LIBSYSTEMD
28 {
29 .name = "systemd",
30 .log = debug_systemd_log,
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/16-do-not-check-xsltproc-manpages.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/16-do-not-check-xsltproc-manpages.patch
index c37cfcde4..c37cfcde4 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/16-do-not-check-xsltproc-manpages.patch
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/16-do-not-check-xsltproc-manpages.patch
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/20-do-not-import-target-module-while-cross-compile.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/20-do-not-import-target-module-while-cross-compile.patch
index e112b3b40..e112b3b40 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/20-do-not-import-target-module-while-cross-compile.patch
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/20-do-not-import-target-module-while-cross-compile.patch
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/21-add-config-option-without-valgrind.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.5/21-add-config-option-without-valgrind.patch
index 025ac2775..025ac2775 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/21-add-config-option-without-valgrind.patch
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/21-add-config-option-without-valgrind.patch
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/volatiles.03_samba b/meta-networking/recipes-connectivity/samba/samba-4.4.5/volatiles.03_samba
index 4bdfa7d2c..4bdfa7d2c 100644
--- a/meta-networking/recipes-connectivity/samba/samba-4.4.2/volatiles.03_samba
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.5/volatiles.03_samba
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index c51569657..e35d527f8 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -21,8 +21,8 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
21 file://volatiles.03_samba \ 21 file://volatiles.03_samba \
22 " 22 "
23 23
24SRC_URI[md5sum] = "03a65a3adf08ceb1636ad59d234d7f9d" 24SRC_URI[md5sum] = "6950c5e9f7bdeb8a610c2ca957a15be4"
25SRC_URI[sha256sum] = "eaecd41a85ebb9507b8db9856ada2a949376e9d53cf75664b5493658f6e5926a" 25SRC_URI[sha256sum] = "b876ef2e63f66265490e80a122e66ef2d7616112b839df68f56ac2e1ce17a7bd"
26 26
27inherit systemd waf-samba cpan-base perlnative update-rc.d 27inherit systemd waf-samba cpan-base perlnative update-rc.d
28# remove default added RDEPENDS on perl 28# remove default added RDEPENDS on perl