diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-11-12 07:06:43 +0000 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-12-14 09:20:10 -0500 |
commit | cf51ee759339dba2364aa570665d725f11d0b8a7 (patch) | |
tree | 68e66eac38947cd89a7120f10ee99463f2df786f /meta-networking/recipes-connectivity | |
parent | b8d98187b93115f7604ae649675211b97a359d76 (diff) | |
download | meta-openembedded-cf51ee759339dba2364aa570665d725f11d0b8a7.tar.gz |
ez-ipupdate: Add recipe
A client for automaticly updating your dynamic hostname parameters
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
4 files changed, 79 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/ez-ipupdate/ez-ipupdate_3.0.11b7.bb b/meta-networking/recipes-connectivity/ez-ipupdate/ez-ipupdate_3.0.11b7.bb new file mode 100644 index 000000000..cb5375c1f --- /dev/null +++ b/meta-networking/recipes-connectivity/ez-ipupdate/ez-ipupdate_3.0.11b7.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "daemon that sends updates when your IP changes" | ||
2 | HOMEPAGE = "http://sourceforge.net/projects/ez-ipupdate/" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=7783169b4be06b54e86730eb01bc3a31" | ||
6 | |||
7 | SRC_URI = "http://sourceforge.net/projects/ez-ipupdate/files/${BPN}/${PV}/${BPN}-${PV}.tar.gz \ | ||
8 | file://Makefile.am.patch \ | ||
9 | file://cache_file.c.patch \ | ||
10 | file://conf_file.c.patch \ | ||
11 | " | ||
12 | SRC_URI[md5sum] = "525be4550b4461fdf105aed8e753b020" | ||
13 | SRC_URI[sha256sum] = "a15ec0dc0b78ec7578360987c68e43a67bc8d3591cbf528a323588830ae22c20" | ||
14 | |||
15 | inherit autotools pkgconfig | ||
diff --git a/meta-networking/recipes-connectivity/ez-ipupdate/files/Makefile.am.patch b/meta-networking/recipes-connectivity/ez-ipupdate/files/Makefile.am.patch new file mode 100644 index 000000000..d80ed3e29 --- /dev/null +++ b/meta-networking/recipes-connectivity/ez-ipupdate/files/Makefile.am.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Remove EXTRASRC and EXTRAOBJ from obj list | ||
2 | |||
3 | --- ez-ipupdate-3.0.11b7/Makefile.am.orig 2014-07-02 13:47:50.758034983 -0600 | ||
4 | +++ ez-ipupdate-3.0.11b7/Makefile.am 2014-07-02 13:48:38.406034650 -0600 | ||
5 | @@ -1,7 +1,7 @@ | ||
6 | |||
7 | bin_PROGRAMS = ez-ipupdate | ||
8 | -ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h @EXTRASRC@ | ||
9 | -ez_ipupdate_LDADD = @EXTRAOBJ@ | ||
10 | +ez_ipupdate_SOURCES = ez-ipupdate.c conf_file.c conf_file.h md5.c md5.h cache_file.c cache_file.h error.h pid_file.c pid_file.h dprintf.h | ||
11 | +ez_ipupdate_LDADD = | ||
12 | |||
13 | EXTRA_DIST = getpass.c ez-ipupdate.lsm example.conf example-pgpow.conf example-dhs.conf example-dyndns.conf example-ods.conf example-tzo.conf example-gnudip.conf example-easydns.conf example-justlinux.conf example-dyns.conf CHANGELOG mkbinary example-heipv6tb.conf | ||
14 | |||
diff --git a/meta-networking/recipes-connectivity/ez-ipupdate/files/cache_file.c.patch b/meta-networking/recipes-connectivity/ez-ipupdate/files/cache_file.c.patch new file mode 100644 index 000000000..de5eb3a6d --- /dev/null +++ b/meta-networking/recipes-connectivity/ez-ipupdate/files/cache_file.c.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | Dont assume errno type | ||
2 | |||
3 | --- ez-ipupdate-3.0.11b7/cache_file.c.orig 2014-07-02 14:01:07.126029412 -0600 | ||
4 | +++ ez-ipupdate-3.0.11b7/cache_file.c 2014-07-02 14:08:27.422026332 -0600 | ||
5 | @@ -43,11 +43,11 @@ | ||
6 | #include <cache_file.h> | ||
7 | |||
8 | #if HAVE_STRERROR | ||
9 | -extern int errno; | ||
10 | +# include <errno.h> | ||
11 | # define error_string strerror(errno) | ||
12 | #elif HAVE_SYS_ERRLIST | ||
13 | extern const char *const sys_errlist[]; | ||
14 | -extern int errno; | ||
15 | +# include <errno.h> | ||
16 | # define error_string (sys_errlist[errno]) | ||
17 | #else | ||
18 | # define error_string "error message not found" | ||
19 | @@ -63,11 +63,11 @@ | ||
20 | # define dprintf(x) | ||
21 | #endif | ||
22 | #if HAVE_STRERROR | ||
23 | -extern int errno; | ||
24 | +# include <errno.h> | ||
25 | # define error_string strerror(errno) | ||
26 | #elif HAVE_SYS_ERRLIST | ||
27 | extern const char *const sys_errlist[]; | ||
28 | -extern int errno; | ||
29 | +# include <errno.h> | ||
30 | # define error_string (sys_errlist[errno]) | ||
31 | #else | ||
32 | # define error_string "error message not found" | ||
diff --git a/meta-networking/recipes-connectivity/ez-ipupdate/files/conf_file.c.patch b/meta-networking/recipes-connectivity/ez-ipupdate/files/conf_file.c.patch new file mode 100644 index 000000000..02218a39e --- /dev/null +++ b/meta-networking/recipes-connectivity/ez-ipupdate/files/conf_file.c.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | Dont assume errno type | ||
2 | |||
3 | --- ez-ipupdate-3.0.11b7/conf_file.c.orig 2014-07-02 14:01:19.174029328 -0600 | ||
4 | +++ ez-ipupdate-3.0.11b7/conf_file.c 2014-07-02 14:08:42.982026223 -0600 | ||
5 | @@ -38,11 +38,11 @@ | ||
6 | #include <conf_file.h> | ||
7 | |||
8 | #if HAVE_STRERROR | ||
9 | -extern int errno; | ||
10 | +# include <errno.h> | ||
11 | # define error_string strerror(errno) | ||
12 | #elif HAVE_SYS_ERRLIST | ||
13 | extern const char *const sys_errlist[]; | ||
14 | -extern int errno; | ||
15 | +# include <errno.h> | ||
16 | # define error_string (sys_errlist[errno]) | ||
17 | #else | ||
18 | # define error_string "error message not found" | ||