summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-03-06 21:29:36 +0200
committerKhem Raj <raj.khem@gmail.com>2019-03-07 09:33:45 -0800
commitf52c6edcc56d27f76ae74aeb81b2eb920b465240 (patch)
treeb22c9e0a22757530723d80f0fb8de00795b15c25 /meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb
parenta74489f70be9fda3bf7fa36a9c6b35009e85a19e (diff)
downloadmeta-openembedded-f52c6edcc56d27f76ae74aeb81b2eb920b465240.tar.gz
wireless-regdb: Upgrade 2018.10.24 -> 2019.03.01
Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb')
-rw-r--r--meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb
new file mode 100644
index 000000000..7b7de5849
--- /dev/null
+++ b/meta-networking/recipes-connectivity/wireless-regdb/wireless-regdb_2019.03.01.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Wireless Central Regulatory Domain Database"
2HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
3SECTION = "net"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
6
7SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
8SRC_URI[md5sum] = "b5eb2d0cc23f5e495a59405e34ce437f"
9SRC_URI[sha256sum] = "3a4e6f7006599bc5764f86e1e86422710da13ad80e0242147b61c6855ebc915f"
10
11inherit bin_package allarch
12
13do_install() {
14 install -d -m0755 ${D}${nonarch_libdir}/crda
15 install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
16 install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
17 install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
18
19 install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
20 install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
21}
22
23# Install static regulatory DB in /lib/firmware for kernel to load.
24# This requires Linux kernel >= v4.15.
25# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass in kernel's recipe.
26PACKAGES =+ "${PN}-static"
27RCONFLICTS_${PN} = "${PN}-static"
28
29FILES_${PN}-static = " \
30 ${nonarch_base_libdir}/firmware/regulatory.db \
31 ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
32"
33
34# Native users might want to use the source of regulatory DB.
35# This is for example used by Linux kernel <= v4.14 and kernel_wireless_regdb.bbclass.
36do_install_append_class-native() {
37 install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
38}
39
40RSUGGESTS_${PN} = "crda"
41
42BBCLASSEXTEND = "native"