diff options
author | Hannu Lounento <hannu.lounento@vaisala.com> | 2018-05-17 04:27:22 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-05-23 15:32:05 -0700 |
commit | cb7b35a4f9f93ecddbb245e32982d3674cef334d (patch) | |
tree | 3ba94273b8bebb6220a233fb7a95def2a5cf7b72 /meta-networking/recipes-connectivity/vlan | |
parent | d1cfe7a70cddd4026552e615f8027160abb7bf0b (diff) | |
download | meta-openembedded-cb7b35a4f9f93ecddbb245e32982d3674cef334d.tar.gz |
vlan: use update-alternatives for vconfig
Busybox also provides the command 'vconfig' when CONFIG_VCONFIG is
enabled.
Busybox has a priority of 50.
Prior to the patch running
bitbake core-image-minimal
produced the warnings
WARNING: core-image-minimal-1.0-r0 do_rootfs: busybox.postinst returned 1, marking as unpacked only, configuration required on target.
WARNING: core-image-minimal-1.0-r0 do_rootfs: Intentionally failing postinstall scriptlets of ['busybox'] to defer them to first boot is deprecated. Please place them into pkg_postinst_ontarget_${PN} ().
If deferring to first boot wasn't the intent, then scriptlet failure may mean an issue in the recipe, or a regression elsewhere.
Details of the failure are in /path/to/poky/build/tmp-glibc/work/qemux86-oe-linux/core-image-minimal/1.0-r0/temp/log.do_rootfs.
WARNING: core-image-minimal-1.0-r0 do_rootfs: [log_check] core-image-minimal: found 1 warning message in the logfile:
[log_check] WARNING: Intentionally failing postinstall scriptlets of ['busybox'] to defer them to first boot is deprecated. Please place them into pkg_postinst_ontarget_${PN} ().
where log.do_rootfs contained
update-alternatives: Error: not linking /path/to/poky/build/tmp-glibc/work/qemux86-oe-linux/core-image-minimal/1.0-r0/rootfs/sbin/vconfig to /bin/busybox.nosuid since /path/to/poky/build/tmp-glibc/work/qemux86-oe-linux/core-image-minimal/1.0-r0/rootfs/sbin/vconfig exists and is not a link
when a workspace layer created by devtool contained
$ cat workspace/appends/busybox_%.bbappend
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append = " file://vconfig.cfg"
and
$ cat workspace/appends/busybox/vconfig.cfg
CONFIG_VCONFIG=y
and local.conf contained
$ tail -n2 conf/local.conf
IMAGE_INSTALL_append = " busybox"
IMAGE_INSTALL_append = " vlan"
Signed-off-by: Hannu Lounento <hannu.lounento@vaisala.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/vlan')
-rw-r--r-- | meta-networking/recipes-connectivity/vlan/vlan_1.9.bb | 6 |
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb index bd55efce2..7eea5d135 100644 --- a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb +++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb | |||
@@ -14,6 +14,8 @@ SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb486884 | |||
14 | 14 | ||
15 | S = "${WORKDIR}/${BPN}" | 15 | S = "${WORKDIR}/${BPN}" |
16 | 16 | ||
17 | inherit update-alternatives | ||
18 | |||
17 | EXTRA_OEMAKE = "-e MAKEFLAGS=" | 19 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
18 | 20 | ||
19 | # comment out MakeInclude in Makefile which sets build environment | 21 | # comment out MakeInclude in Makefile which sets build environment |
@@ -30,3 +32,7 @@ do_install () { | |||
30 | install -d ${D}/${base_sbindir} | 32 | install -d ${D}/${base_sbindir} |
31 | install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/ | 33 | install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/ |
32 | } | 34 | } |
35 | |||
36 | ALTERNATIVE_PRIORITY = "100" | ||
37 | ALTERNATIVE_${PN} = "vconfig" | ||
38 | ALTERNATIVE_LINK_NAME[vconfig] = "${base_sbindir}/vconfig" | ||