diff options
author | Zhiquan Li <zhiquan.li@windriver.com> | 2015-10-23 18:07:35 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-11-11 10:47:20 +0100 |
commit | f08b9e8e7d9740f8353d70aa9c2a0989951bed1d (patch) | |
tree | f256771c2b0870adc71020ca8e37f80a1c575536 /meta-networking/recipes-connectivity/snort | |
parent | 4a680e64f4570d38ffdfca51b67e6347ac91a361 (diff) | |
download | meta-openembedded-f08b9e8e7d9740f8353d70aa9c2a0989951bed1d.tar.gz |
snort: fix m4 causes out of memory during configure
There is an incorrect m4_define() in configure.in which will result in an
infinite recursion, and it doesn't make sense, since snort 2.9.7 it has been
commented out. We follow this solution to fix it.
Signed-off-by: Zhiquan Li <zhiquan.li@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/snort')
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch | 21 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb | 16 |
2 files changed, 24 insertions, 13 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch b/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch new file mode 100644 index 000000000..225061153 --- /dev/null +++ b/meta-networking/recipes-connectivity/snort/snort/m4-oom-during-configure.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | Upstream-Status: Backport | ||
2 | |||
3 | There is an incorrect m4_define() in configure.in which will result in an | ||
4 | infinite recursion, and it doesn't make sense, since snort 2.9.7 it has been | ||
5 | commented out. We follow this solution to fix it. | ||
6 | |||
7 | Signed-off-by: Zhiquan Li <zhiquan.li@windriver.com> | ||
8 | |||
9 | --- a/configure.in 2015-10-22 13:58:50.743367251 +0800 | ||
10 | +++ b/configure.in 2015-10-22 13:59:13.855366117 +0800 | ||
11 | @@ -1100,8 +1100,8 @@ | ||
12 | # Define PKG_CHECK_MODULES if it doesnt already exist. | ||
13 | #file_ This prevents './configure' from erroring on machines that dont have | ||
14 | # 'pkgconfig' installed. | ||
15 | -m4_ifdef([PKG_CHECK_MODULES],[], [m4_define([PKG_CHECK_MODULES], | ||
16 | - [echo "PKG_CHECK_MODULES not defined"])]) | ||
17 | +#m4_ifdef([PKG_CHECK_MODULES],[], [m4_define([PKG_CHECK_MODULES], | ||
18 | +# [echo "PKG_CHECK_MODULES not defined"])]) | ||
19 | |||
20 | if test "x$enable_rzb_saac" = "xyes"; then | ||
21 | AC_CHECK_PROG(PKG_CONFIG,pkg-config,yes) | ||
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb index 66653c6c3..65dc524a8 100644 --- a/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb +++ b/meta-networking/recipes-connectivity/snort/snort_2.9.6.0.bb | |||
@@ -6,19 +6,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=78fa8ef966b48fbf9095e13cc92377c5" | |||
6 | 6 | ||
7 | DEPENDS = "libpcap libpcre daq libdnet util-linux" | 7 | DEPENDS = "libpcap libpcre daq libdnet util-linux" |
8 | 8 | ||
9 | # Blacklist: | ||
10 | # | ||
11 | # http://errors.yoctoproject.org/Errors/Details/8936/ | ||
12 | # | ||
13 | # snort failure is again very nasty, because it's m4 which eats all | ||
14 | # available memory and swap before it's killed by OOM killer. | ||
15 | # | ||
16 | # Luckily it always picked m4 | ||
17 | # | ||
18 | # [Wed Feb 18 19:00:51 2015] Out of memory: Kill process 28522 (m4) score 961 or sacrifice child | ||
19 | # [Wed Feb 18 19:10:51 2015] Out of memory: Kill process 45228 (m4) score 958 or sacrifice child | ||
20 | # ... | ||
21 | PNBLACKLIST[snort] ?= "BROKEN: autotools processing causes OOM condition on configure" | ||
22 | 9 | ||
23 | SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \ | 10 | SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \ |
24 | file://snort.init \ | 11 | file://snort.init \ |
@@ -26,6 +13,7 @@ SRC_URI = " ${GENTOO_MIRROR}/${BP}.tar.gz;name=tarball \ | |||
26 | file://disable-dap-address-space-id.patch \ | 13 | file://disable-dap-address-space-id.patch \ |
27 | file://0001-libpcap-search-sysroot-for-headers.patch \ | 14 | file://0001-libpcap-search-sysroot-for-headers.patch \ |
28 | file://not-hardcoded-libdir.patch \ | 15 | file://not-hardcoded-libdir.patch \ |
16 | file://m4-oom-during-configure.patch \ | ||
29 | " | 17 | " |
30 | 18 | ||
31 | SRC_URI[tarball.md5sum] = "18111f6de3989ca89add36077a7c2659" | 19 | SRC_URI[tarball.md5sum] = "18111f6de3989ca89add36077a7c2659" |
@@ -45,6 +33,8 @@ EXTRA_OECONF = " \ | |||
45 | --disable-static-daq \ | 33 | --disable-static-daq \ |
46 | --with-dnet-includes=${STAGING_INCDIR} \ | 34 | --with-dnet-includes=${STAGING_INCDIR} \ |
47 | --with-dnet-libraries=${STAGING_LIBDIR} \ | 35 | --with-dnet-libraries=${STAGING_LIBDIR} \ |
36 | --with-libpcre-includes=${STAGING_INCDIR} \ | ||
37 | --with-libpcre-libraries=${STAGING_INCDIR} \ | ||
48 | " | 38 | " |
49 | 39 | ||
50 | # if you want to disable it, you need to patch configure.in first | 40 | # if you want to disable it, you need to patch configure.in first |