summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/snort
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-06-28 15:49:57 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit8cab57e4aaba417f6884584979a76096834c1a43 (patch)
tree775b829d55d7504dc306377b65b1477bede59dad /meta-networking/recipes-connectivity/snort
parent4c983dc8374c275a29118c63a17af95b34c607cc (diff)
downloadmeta-openembedded-8cab57e4aaba417f6884584979a76096834c1a43.tar.gz
snort: fix compile-host-path QA issue
The Fedora 28+ does not have inbuilt SunRPC support in glibc and is separately availble in tirpc package. So it enables tirpc checking for fedora in configure. Drop this piece of code since we had specify '-ltirpc' in LDFLAGS explicitly. Otherwise it will cause a compile-host-path QA issue if the host is Fedora 28+: cc1: warning: include location "/usr/include/tirpc" is unsafe for cross-compilation [-Wpoison-system-directories] Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/snort')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort/configure.in-disable-tirpc-checking-for-fedora.patch60
-rw-r--r--meta-networking/recipes-connectivity/snort/snort_2.9.13.bb1
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/configure.in-disable-tirpc-checking-for-fedora.patch b/meta-networking/recipes-connectivity/snort/snort/configure.in-disable-tirpc-checking-for-fedora.patch
new file mode 100644
index 000000000..87fd05bfd
--- /dev/null
+++ b/meta-networking/recipes-connectivity/snort/snort/configure.in-disable-tirpc-checking-for-fedora.patch
@@ -0,0 +1,60 @@
1From 65463a7c5cb2514b1523a81911810effffb75a79 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Fri, 28 Jun 2019 15:05:31 +0800
4Subject: [PATCH] configure.in: disable tirpc checking for fedora
5
6The Fedora 28+ does not have inbuilt SunRPC support in glibc and is
7separately availble in tirpc package. So it enables tirpc checking for
8fedora in configure.
9
10Drop this piece of code since we had specify '-ltirpc' in LDFLAGS
11explicitly. Otherwise it will cause a compile-host-path QA issue if the
12host is Fedora 28+:
13cc1: warning: include location "/usr/include/tirpc" is unsafe for
14cross-compilation [-Wpoison-system-directories]
15
16Upstream-Status: Inappropriate [embedded specific]
17
18Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
19---
20 configure.in | 24 ------------------------
21 1 file changed, 24 deletions(-)
22
23diff --git a/configure.in b/configure.in
24index 8662cdd..0ff7e27 100644
25--- a/configure.in
26+++ b/configure.in
27@@ -895,30 +895,6 @@ if test "x$enable_dlclose" = "xno"; then
28 AC_DEFINE([DISABLE_DLCLOSE_FOR_VALGRIND_TESTING],[1],[Don't close opened shared objects for valgrind leak testing of dynamic libraries])
29 fi
30
31-##################################################
32-# Fedora 28+ does not have inbuilt SunRPC support#
33-# in glibc and is separately availble in tirpc #
34-# package. Make sure we've got the library and #
35-# link it #
36-##################################################
37-
38-if test -f /etc/fedora-release ; then
39- DISTRO_VERSION=$(awk '{ print $3 }' /etc/fedora-release)
40- if test $DISTRO_VERSION -ge 28 ; then
41- TIRPC=""
42- AC_CHECK_LIB(tirpc,bindresvport,, TIRPC="no")
43- echo "$TIRPC"
44- if test "x$TIRPC" = "xno"; then
45- echo
46- echo " ERROR! tirpc not found, get it by running "
47- echo " yum install libtirpc-devel "
48- exit
49- fi
50- LIBS="${LIBS} -ltirpc"
51- extra_incl="-I/usr/include/tirpc"
52- fi
53-fi
54-
55 Z_LIB=""
56 AC_CHECK_HEADERS(zlib.h,, Z_LIB="no")
57 if test "x$Z_LIB" = "xno"; then
58--
592.7.4
60
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb
index 1b10dbde1..c7e47e11a 100644
--- a/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb
+++ b/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb
@@ -11,6 +11,7 @@ SRC_URI = "https://www.snort.org/downloads/archive/snort/${BP}.tar.gz \
11 file://0001-libpcap-search-sysroot-for-headers.patch \ 11 file://0001-libpcap-search-sysroot-for-headers.patch \
12 file://fix-host-contamination-when-enable-static-daq.patch \ 12 file://fix-host-contamination-when-enable-static-daq.patch \
13 file://disable-run-test-program-while-cross-compiling.patch \ 13 file://disable-run-test-program-while-cross-compiling.patch \
14 file://configure.in-disable-tirpc-checking-for-fedora.patch \
14" 15"
15 16
16SRC_URI[md5sum] = "b61ae846af022018b05511076baad60c" 17SRC_URI[md5sum] = "b61ae846af022018b05511076baad60c"