summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/sethdlc
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2014-11-25 02:11:07 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2014-11-30 15:45:47 -0500
commitb3caf13a8ebdfb2254eca0bdb6ebcb3b71309c79 (patch)
tree1f8f54ad85902aa8e7c6a757b31ccf07705c8494 /meta-networking/recipes-connectivity/sethdlc
parentbf464bee5a1a0d52fb065d25d27aacc8abe033ea (diff)
downloadmeta-openembedded-b3caf13a8ebdfb2254eca0bdb6ebcb3b71309c79.tar.gz
sethdlc: fix host contamination
* Clean INCLUDES to fix the host contamination errors: In file included from /usr/src/linux/include/linux/posix_types.h:47:0, from /usr/src/linux/include/linux/types.h:17, from /usr/src/linux/include/linux/if.h:22, from sethdlc.c:23: /usr/src/linux/include/asm-generic/posix_types.h:91:3: \ error: conflicting types for '__kernel_fsid_t' } __kernel_fsid_t; ^ .../tmp/sysroots/qemumips/usr/include/asm/posix_types.h:26:3: \ note: previous declaration of '__kernel_fsid_t' was here } __kernel_fsid_t; ^ * Correct LIC_FILES_CHKSUM to checkout license infos from sethdl.c instead of Makefile. Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/sethdlc')
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch42
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/sethdlc.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch b/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch
new file mode 100644
index 000000000..f25a02cd8
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch
@@ -0,0 +1,42 @@
1From 9a9137c3df5309ac359737d6ebd67fb4ff5f3cf2 Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Mon, 24 Nov 2014 22:05:18 -0500
4Subject: [PATCH] sethdlc: fix host contamination
5
6Clean INCLUDES to fix the host contamination errors:
7
8 In file included from /usr/src/linux/include/linux/posix_types.h:47:0,
9 from /usr/src/linux/include/linux/types.h:17,
10 from /usr/src/linux/include/linux/if.h:22,
11 from sethdlc.c:23:
12 /usr/src/linux/include/asm-generic/posix_types.h:91:3: \
13 error: conflicting types for '__kernel_fsid_t'
14 } __kernel_fsid_t;
15 ^
16 .../tmp/sysroots/qemumips/usr/include/asm/posix_types.h:26:3: \
17 note: previous declaration of '__kernel_fsid_t' was here
18 } __kernel_fsid_t;
19 ^
20
21Upstream-Status: Pending
22
23Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
24---
25 Makefile | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/Makefile b/Makefile
29index 0492f2b..97dec22 100644
30--- a/Makefile
31+++ b/Makefile
32@@ -1,6 +1,6 @@
33 CC = gcc
34 CFLAGS = -O2 -Wall -W -Wno-long-long -pipe
35-INCLUDES = -I/usr/src/linux/include -I/usr/src/linux-2.6/include
36+INCLUDES =
37
38 all: sethdlc
39
40--
411.7.9.5
42
diff --git a/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
index cf7482755..5e8d9d9bf 100644
--- a/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
+++ b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
@@ -1,10 +1,11 @@
1DESCRIPTION = "set Linux HDLC packet radio modem driver port information" 1DESCRIPTION = "set Linux HDLC packet radio modem driver port information"
2HOMEPAGE = "https://www.kernel.org/pub/linux/utils/net/hdlc" 2HOMEPAGE = "https://www.kernel.org/pub/linux/utils/net/hdlc"
3LICENSE = "GPLv2 & GPLv2+ " 3LICENSE = "GPLv2 & GPLv2+ "
4LIC_FILES_CHKSUM = "file://Makefile;md5=19aada31930b2be84bf7138420d77263" 4LIC_FILES_CHKSUM = "file://sethdlc.c;endline=10;md5=90f936879e9f8b755a138aeb348782eb"
5 5
6 6
7SRC_URI = "https://www.kernel.org/pub/linux/utils/net/hdlc/${BPN}-1.18.tar.gz \ 7SRC_URI = "https://www.kernel.org/pub/linux/utils/net/hdlc/${BPN}-1.18.tar.gz \
8 file://sethdlc-fix-host-contamination.patch \
8" 9"
9SRC_URI[md5sum] = "9016878156a5eadb06c0bae71cc5c9ab" 10SRC_URI[md5sum] = "9016878156a5eadb06c0bae71cc5c9ab"
10SRC_URI[sha256sum] = "21b1e2e1cb0e288b0ec8fcfd9fed449914e0f8e6fc273706bd5b3d4f6ab6b04e" 11SRC_URI[sha256sum] = "21b1e2e1cb0e288b0ec8fcfd9fed449914e0f8e6fc273706bd5b3d4f6ab6b04e"