summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/sethdlc/sethdlc.bb')
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/sethdlc.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
new file mode 100644
index 000000000..5e8d9d9bf
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "set Linux HDLC packet radio modem driver port information"
2HOMEPAGE = "https://www.kernel.org/pub/linux/utils/net/hdlc"
3LICENSE = "GPLv2 & GPLv2+ "
4LIC_FILES_CHKSUM = "file://sethdlc.c;endline=10;md5=90f936879e9f8b755a138aeb348782eb"
5
6
7SRC_URI = "https://www.kernel.org/pub/linux/utils/net/hdlc/${BPN}-1.18.tar.gz \
8 file://sethdlc-fix-host-contamination.patch \
9"
10SRC_URI[md5sum] = "9016878156a5eadb06c0bae71cc5c9ab"
11SRC_URI[sha256sum] = "21b1e2e1cb0e288b0ec8fcfd9fed449914e0f8e6fc273706bd5b3d4f6ab6b04e"
12
13
14S = "${WORKDIR}/${BPN}-1.18"
15
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17DEPENDS = "virtual/kernel"
18
19EXTRA_OEMAKE="CROSS_COMPILE=${TARGET_PREFIX} CC='${CC} ${LDFLAGS}' \
20 KERNEL_DIR=${STAGING_KERNEL_DIR} "
21
22do_compile_prepend () {
23 oe_runmake clean
24}
25
26
27do_install() {
28 install -d ${D}/${bindir}
29 install sethdlc ${D}/${bindir}/
30}
31
32FILES_${PN} += "${bindir}/sethdlc"