diff options
author | André Draszik <andre.draszik@jci.com> | 2019-01-13 10:55:11 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-01-13 10:28:01 -0800 |
commit | 24af1f974cc95c50dfa56ad15b113279c3993c5d (patch) | |
tree | 40a09c3734718cf88b34e4c3b991ae11360fdee8 /meta-networking/recipes-connectivity/samba | |
parent | 88f2b979caf24fad736b8e378cf9daa142ae0567 (diff) | |
download | meta-openembedded-24af1f974cc95c50dfa56ad15b113279c3993c5d.tar.gz |
meta-networking: remove True option to getVar calls (again)
A couple have still been missed in the past despite multiple
attempts at doing so (or simply have re-appeared?).
Search & replace made using the following command:
sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \
-i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \
| cut -d':' -f1 \
| sort -u)
Signed-off-by: André Draszik <andre.draszik@jci.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/samba')
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.8.4.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb index f1aaeb83d..e86ed96a5 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.8.4.bb | |||
@@ -193,15 +193,15 @@ PACKAGES =+ "${PN}-python ${PN}-pidl \ | |||
193 | 193 | ||
194 | python samba_populate_packages() { | 194 | python samba_populate_packages() { |
195 | def module_hook(file, pkg, pattern, format, basename): | 195 | def module_hook(file, pkg, pattern, format, basename): |
196 | pn = d.getVar('PN', True) | 196 | pn = d.getVar('PN') |
197 | d.appendVar('RRECOMMENDS_%s-base' % pn, ' %s' % pkg) | 197 | d.appendVar('RRECOMMENDS_%s-base' % pn, ' %s' % pkg) |
198 | 198 | ||
199 | mlprefix = d.getVar('MLPREFIX', True) or '' | 199 | mlprefix = d.getVar('MLPREFIX') or '' |
200 | pam_libdir = d.expand('${base_libdir}/security') | 200 | pam_libdir = d.expand('${base_libdir}/security') |
201 | pam_pkgname = mlprefix + 'pam-plugin%s' | 201 | pam_pkgname = mlprefix + 'pam-plugin%s' |
202 | do_split_packages(d, pam_libdir, '^pam_(.*)\.so$', pam_pkgname, 'PAM plugin for %s', extra_depends='', prepend=True) | 202 | do_split_packages(d, pam_libdir, '^pam_(.*)\.so$', pam_pkgname, 'PAM plugin for %s', extra_depends='', prepend=True) |
203 | 203 | ||
204 | libdir = d.getVar('libdir', True) | 204 | libdir = d.getVar('libdir') |
205 | do_split_packages(d, libdir, '^lib(.*)\.so\..*$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True, allow_links=True) | 205 | do_split_packages(d, libdir, '^lib(.*)\.so\..*$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True, allow_links=True) |
206 | pkglibdir = '%s/samba' % libdir | 206 | pkglibdir = '%s/samba' % libdir |
207 | do_split_packages(d, pkglibdir, '^lib(.*)\.so$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True) | 207 | do_split_packages(d, pkglibdir, '^lib(.*)\.so$', 'lib%s', 'Samba %s library', extra_depends='${PN}-common', prepend=True) |