diff options
author | Yi Zhao <yi.zhao@windriver.com> | 2021-11-25 10:44:49 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-11-25 10:14:18 -0800 |
commit | d3eb0a9e848cf5085c1579ec2277f546866f7f87 (patch) | |
tree | 62e5363a80ba29f9282c5791a35e3ced2b000fdc /meta-networking/recipes-connectivity/samba | |
parent | e02caef1cccaef0fe060a04699cd1adf28c5ff83 (diff) | |
download | meta-openembedded-d3eb0a9e848cf5085c1579ec2277f546866f7f87.tar.gz |
samba: add pyldb to rdepends for samba-python3
Fixes:
$ python3
>>> import samba
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib64/python3.10/site-packages/samba/__init__.py", line 28, in <module>
import ldb
ModuleNotFoundError: No module named 'ldb'
>>>
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/samba')
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.14.10.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb b/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb index af0795458..0a5dbe9c9 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.14.10.bb | |||
@@ -245,7 +245,7 @@ PACKAGESPLITFUNCS:prepend = "samba_populate_packages " | |||
245 | PACKAGES_DYNAMIC = "samba-auth-.* samba-pdb-.*" | 245 | PACKAGES_DYNAMIC = "samba-auth-.* samba-pdb-.*" |
246 | 246 | ||
247 | RDEPENDS:${PN} += "${PN}-base ${PN}-python3 ${PN}-dsdb-modules python3" | 247 | RDEPENDS:${PN} += "${PN}-base ${PN}-python3 ${PN}-dsdb-modules python3" |
248 | RDEPENDS:${PN}-python3 += "pytalloc python3-tdb" | 248 | RDEPENDS:${PN}-python3 += "pytalloc python3-tdb pyldb" |
249 | 249 | ||
250 | FILES:${PN}-base = "${sbindir}/nmbd \ | 250 | FILES:${PN}-base = "${sbindir}/nmbd \ |
251 | ${sbindir}/smbd \ | 251 | ${sbindir}/smbd \ |