summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/lftp
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2015-08-17 20:40:22 +0530
committerJoe MacDonald <joe_macdonald@mentor.com>2015-09-11 10:39:09 -0400
commit7e1de2f5c36b84d09afc3f38d76857c336b17a3c (patch)
tree46b4ddd9969a2acf5abdac4f25a9ccaa5650bbb5 /meta-networking/recipes-connectivity/lftp
parent4b532090206695db8902222dd60f7e1948d5aac8 (diff)
downloadmeta-openembedded-7e1de2f5c36b84d09afc3f38d76857c336b17a3c.tar.gz
lftp: add new recipe
LFTP is a sophisticated file transfer program with command line interface. It supports FTP, HTTP, FISH, SFTP, HTTPS and FTPS protocols. Every operation in lftp is reliable, that is any non-fatal error is handled and the operation is retried automatically. So if downloading breaks, it will be restarted from the point automatically. Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/lftp')
-rw-r--r--meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb b/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb
new file mode 100644
index 000000000..e6796a699
--- /dev/null
+++ b/meta-networking/recipes-connectivity/lftp/lftp_4.6.3a.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "LFTP is a sophisticated file transfer program with \
2 command line interface. It supports FTP, HTTP, \
3 FISH, SFTP, HTTPS and FTPS protocols"
4HOMEPAGE = "http://lftp.yar.ru/"
5SECTION = "console/network"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8DEPENDS = "readline"
9
10SRC_URI = "http://fossies.org/linux/misc/lftp-${PV}.tar.gz \
11 "
12SRC_URI[md5sum] = "2777dd514d21fe1da764bedd1d0ab36c"
13SRC_URI[sha256sum] = "a8b53e5ca2c1acbecd181c87f21a8673ca9038dc9f2be6ab8c23790bd91fd446"
14
15inherit autotools gettext pkgconfig
16
17EXTRA_OECONF += "--with-modules"
18
19PACKAGECONFIG ??= "libidn openssl zlib gnutls"
20PACKAGECONFIG[libidn] = "--with-libidn, --without-libidn, libidn"
21PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
22PACKAGECONFIG[zlib] = "--with-zlib, --without-zlib, zlib"
23PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls"
24
25FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug"
26RDEPENDS_${PN} = "perl bash readline"