diff options
author | Krzysztof Kozlowski <krzk@kernel.org> | 2018-07-05 20:58:12 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-05 17:51:16 -0700 |
commit | 8603b7643b9025bf88dd55165ec808c4cea144e3 (patch) | |
tree | f18a49be2731f0073fc4412a4cd1ee3132f910fd /meta-networking/classes | |
parent | 20e3c3e2e435526c3666cf0bf6a1d06266337174 (diff) | |
download | meta-openembedded-8603b7643b9025bf88dd55165ec808c4cea144e3.tar.gz |
kernel_wireless_regdb: Add class for embedding regulatory data into older kernel
Linux kernels before v4.15, allowed to be compiled with static
regulatory database if it was put under net/wireless/db.txt.
Add kernel_wireless_regdb class which allows in such cases to embed the
wireless regulatory database directly in the Linux kernel during build
process.
Usage:
1. The class should be inherited by kernel recipe (e.g. in
linux-yocto_%.bbappend).
2. For Linux kernels up to v4.14, build kernel with CONFIG_EXPERT and
CONFIG_CFG80211_INTERNAL_REGDB.
Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/classes')
-rw-r--r-- | meta-networking/classes/kernel_wireless_regdb.bbclass | 20 |
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/classes/kernel_wireless_regdb.bbclass b/meta-networking/classes/kernel_wireless_regdb.bbclass new file mode 100644 index 000000000..1238172bd --- /dev/null +++ b/meta-networking/classes/kernel_wireless_regdb.bbclass | |||
@@ -0,0 +1,20 @@ | |||
1 | # Linux kernels before v4.15, allowed to be compiled with static | ||
2 | # regulatory database if it was put under net/wireless/db.txt. | ||
3 | # | ||
4 | # This class copies the regulatory plaintext database to kernel sources before | ||
5 | # compiling. | ||
6 | # | ||
7 | # Usage: | ||
8 | # 1. The class should be inherited by kernel recipe (e.g. in | ||
9 | # linux-yocto_%.bbappend). | ||
10 | # 2. For Linux kernels up to v4.14, build kernel with CONFIG_EXPERT and | ||
11 | # CONFIG_CFG80211_INTERNAL_REGDB. | ||
12 | |||
13 | DEPENDS += "wireless-regdb-native" | ||
14 | |||
15 | SRCTREECOVEREDTASKS += "do_kernel_add_regdb" | ||
16 | do_kernel_add_regdb() { | ||
17 | cp ${STAGING_LIBDIR_NATIVE}/crda/db.txt ${S}/net/wireless/db.txt | ||
18 | } | ||
19 | do_kernel_add_regdb[dirs] = "${S}" | ||
20 | addtask kernel_add_regdb before do_build after do_configure | ||