summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-05-08 23:55:03 +0300
committerKhem Raj <raj.khem@gmail.com>2019-05-09 20:34:33 -0700
commit77e6635a56dfd3f737382305f3416f393bc0e77a (patch)
tree892ede6a4cd36402ff254c11f85452fe1a14c8e1 /meta-multimedia
parentd9b5e720a149f846fc251a4fbf4018a857559f2e (diff)
downloadmeta-openembedded-77e6635a56dfd3f737382305f3416f393bc0e77a.tar.gz
Remove liboil
It was replaced by orc 10 years ago and no users are left in meta-openembedded. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb2
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch41
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-math_vfp_asm.S-Convert-fldmia-fstmia-instructions-to.patch257
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch19
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix_riscv_unaligned_access.patch15
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/liboil_fix_for_x32.patch222
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil-0.3.17/no-tests.patch24
-rw-r--r--meta-multimedia/recipes-support/liboil/liboil_0.3.17.bb29
8 files changed, 1 insertions, 608 deletions
diff --git a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
index b048ac667..365618d95 100644
--- a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
+++ b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
@@ -48,5 +48,5 @@ RDEPENDS_packagegroup-meta-multimedia-mkv = "\
48 " 48 "
49 49
50RDEPENDS_packagegroup-meta-multimedia-support = "\ 50RDEPENDS_packagegroup-meta-multimedia-support = "\
51 liboil libmediaart libmediaart-2.0 gst-instruments libsrtp crossguid \ 51 libmediaart libmediaart-2.0 gst-instruments libsrtp crossguid \
52 " 52 "
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch
deleted file mode 100644
index aff1cb184..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-Fix-enable-vfp-flag.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1Upstream-Status: Inappropriate [configuration]
2
3From 1921498bcc06408e8b051a3a9e9ce4182998f748 Mon Sep 17 00:00:00 2001
4From: David Schleef <ds@schleef.org>
5Date: Fri, 8 Apr 2011 10:05:49 -0700
6Subject: [PATCH 10/10] Fix --enable-vfp flag
7
8Patch from Christophe Lyon, fixes #36084.
9---
10 configure.ac | 4 ++--
11 liboil/arm/Makefile.am | 1 +
12 2 files changed, 3 insertions(+), 2 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 98c81fb..407d88c 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -188,8 +188,8 @@ fi
19 AC_ARG_ENABLE(vfp,
20 AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
21 enable_vfp=$enableval,enable_vfp=yes)
22-if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
23- AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
24+if test "x$enable_vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
25+ AS_COMPILER_FLAG(["-mfpu=vfp"],
26 [VFP_CFLAGS="$VFP_CFLAGS -mfpu=vfp"],
27 true)
28 #AS_COMPILER_FLAG(["-Wa,-mfloat-abi=softfp"],
29diff --git a/liboil/arm/Makefile.am b/liboil/arm/Makefile.am
30index ead08ed..cd8d9fa 100644
31--- a/liboil/arm/Makefile.am
32+++ b/liboil/arm/Makefile.am
33@@ -6,4 +6,5 @@ libarm_la_SOURCES = \
34 math_vfp_asm.S
35
36 libarm_la_CFLAGS = $(LIBOIL_CFLAGS) $(VFP_CFLAGS)
37+libarm_la_CCASFLAGS = $(LIBOIL_CFLAGS) $(VFP_CFLAGS)
38
39--
401.7.6
41
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-math_vfp_asm.S-Convert-fldmia-fstmia-instructions-to.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-math_vfp_asm.S-Convert-fldmia-fstmia-instructions-to.patch
deleted file mode 100644
index 05903807e..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/0001-math_vfp_asm.S-Convert-fldmia-fstmia-instructions-to.patch
+++ /dev/null
@@ -1,257 +0,0 @@
1From 02a138f0b247fb08b799f32c49b35912b2921321 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 12 Feb 2019 11:38:46 -0800
4Subject: [PATCH] math_vfp_asm.S: Convert fldmia/fstmia instructions to UAL
5 syntax for clang
6
7This is flagged with clang internal assembler, since it does not allow
8non UAL syntax
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 liboil/arm/math_vfp_asm.S | 94 +++++++++++++++++++--------------------
15 1 file changed, 47 insertions(+), 47 deletions(-)
16
17diff --git a/liboil/arm/math_vfp_asm.S b/liboil/arm/math_vfp_asm.S
18index ae5c803..3dd14d9 100644
19--- a/liboil/arm/math_vfp_asm.S
20+++ b/liboil/arm/math_vfp_asm.S
21@@ -25,7 +25,7 @@
22 */
23
24 #if defined(__VFP_FP__) && !defined(__SOFTFP__)
25-/*
26+/*
27 ** compile with -mcpu=arm1136j-s -mfpu=vfp -mfloat-abi=softfp
28 **
29 ** void vfp_add_f32 (float *d, const float *s1, const float *s2, int n);
30@@ -48,10 +48,10 @@
31 ands ip, r3, #7; /* ip = n % 8 */ \
32 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
33 vfp_ ## fname ## _loop1: \
34- fldmias r1!, {s0}; \
35- fldmias r2!, {s1}; \
36+ vldmia.f32 r1!, {s0}; \
37+ vldmia.f32 r2!, {s1}; \
38 ## finst ##s s2, s0, s1; \
39- fstmias r0!, {s2}; \
40+ vstmia.f32 r0!, {s2}; \
41 subs ip, ip, #1; \
42 bne vfp_ ## fname ## _loop1; \
43 vfp_ ## fname ## _unroll: /* unroll by 8 */ \
44@@ -62,15 +62,15 @@
45 orr fp, lr, fp, lsl #16; /* set vector lenght to 8 */ \
46 fmxr fpscr, fp; \
47 vfp_ ## fname ## _loop2: \
48- fldmias r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
49- fldmias r2!, {s16, s17, s18, s19, s20, s21, s22, s23}; \
50+ vldmia.f32 r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
51+ vldmia.f32 r2!, {s16, s17, s18, s19, s20, s21, s22, s23}; \
52 ## finst ##s s24, s8, s16; \
53- fstmias r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
54+ vstmia.f32 r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
55 subs ip, ip, #1; \
56 bne vfp_ ## fname ## _loop2; \
57 fmxr fpscr, lr; /* restore original fpscr */ \
58 vfp_ ## fname ## _end: \
59- ldmia sp!, {fp, pc}; /* recovering from stack and return */
60+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
61
62 #define UNROLL_F64_TEMPLATE(fname,finst) \
63 .global vfp_ ## fname ## ; \
64@@ -79,10 +79,10 @@
65 ands ip, r3, #3; /* ip = n % 3 */ \
66 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
67 vfp_ ## fname ## _loop1: \
68- fldmiad r1!, {d0}; \
69- fldmiad r2!, {d1}; \
70+ vldmia.f64 r1!, {d0}; \
71+ vldmia.f64 r2!, {d1}; \
72 ## finst ##d d2, d0, d1; \
73- fstmiad r0!, {d2}; \
74+ vstmia.f64 r0!, {d2}; \
75 subs ip, ip, #1; \
76 bne vfp_ ## fname ## _loop1; \
77 vfp_ ## fname ## _unroll: /* unroll by 4 */ \
78@@ -93,15 +93,15 @@
79 orr fp, lr, fp, lsl #16; /* set vector lenght to 8 */ \
80 fmxr fpscr, fp; \
81 vfp_ ## fname ## _loop2: \
82- fldmiad r1!, {d4, d5, d6, d7}; \
83- fldmiad r2!, {d8, d9, d10, d11}; \
84+ vldmia.f64 r1!, {d4, d5, d6, d7}; \
85+ vldmia.f64 r2!, {d8, d9, d10, d11}; \
86 ## finst ##d d12, d4, d8; \
87- fstmiad r0!, {d12, d13, d14, d15}; \
88+ vstmia.f64 r0!, {d12, d13, d14, d15}; \
89 subs ip, ip, #1; \
90 bne vfp_ ## fname ## _loop2; \
91 fmxr fpscr, lr; /* restore original fpscr */ \
92 vfp_ ## fname ## _end: \
93- ldmia sp!, {fp, pc}; /* recovering from stack and return */
94+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
95
96 .align 2
97 UNROLL_F32_TEMPLATE(add_f32,fadd);
98@@ -119,7 +119,7 @@ UNROLL_F64_TEMPLATE(subtract_f64,fsub);
99 #undef UNROLL_F32_TEMPLATE
100 #undef UNROLL_F64_TEMPLATE
101
102-/*
103+/*
104 **
105 ** void vfp_scalaradd_f32_ns (float *d, const float *s1, const float *s2_1, int n);
106 ** void vfp_scalaradd_f64_ns (double *d, const double *s1, const double *s2_1, int n);
107@@ -133,13 +133,13 @@ UNROLL_F64_TEMPLATE(subtract_f64,fsub);
108 .global vfp_ ## fname ## ; \
109 vfp_ ## fname ## : \
110 stmdb sp!, {fp, lr}; /* save registers to stack */ \
111- fldmias r2, {s1}; /* load scalar value */ \
112+ vldmia.f32 r2, {s1}; /* load scalar value */ \
113 ands ip, r3, #7; /* ip = n % 8 */ \
114 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
115 vfp_ ## fname ## _loop1: \
116- fldmias r1!, {s0}; \
117+ vldmia.f32 r1!, {s0}; \
118 ## finst ##s s2, s0, s1; \
119- fstmias r0!, {s2}; \
120+ vstmia.f32 r0!, {s2}; \
121 subs ip, ip, #1; \
122 bne vfp_ ## fname ## _loop1; \
123 vfp_ ## fname ## _unroll: /* unroll by 8 */ \
124@@ -150,26 +150,26 @@ UNROLL_F64_TEMPLATE(subtract_f64,fsub);
125 orr fp, lr, fp, lsl #16; /* set vector lenght to 8 */ \
126 fmxr fpscr, fp; \
127 vfp_ ## fname ## _loop2: \
128- fldmias r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
129+ vldmia.f32 r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
130 ## finst ##s s24, s8, s1; \
131- fstmias r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
132+ vstmia.f32 r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
133 subs ip, ip, #1; \
134 bne vfp_ ## fname ## _loop2; \
135 fmxr fpscr, lr; /* restore original fpscr */ \
136 vfp_ ## fname ## _end: \
137- ldmia sp!, {fp, pc}; /* recovering from stack and return */
138+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
139
140 #define UNROLL_F64_TEMPLATE(fname,finst) \
141 .global vfp_ ## fname ## ; \
142 vfp_ ## fname ## : \
143 stmdb sp!, {fp, lr}; /* save registers to stack */ \
144- fldmiad r2, {d1}; /* load scalar value */ \
145+ vldmia.f64 r2, {d1}; /* load scalar value */ \
146 ands ip, r3, #3; /* ip = n % 3 */ \
147 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
148 vfp_ ## fname ## _loop1: \
149- fldmiad r1!, {d0}; \
150+ vldmia.f64 r1!, {d0}; \
151 ## finst ##d d2, d0, d1; \
152- fstmiad r0!, {d2}; \
153+ vstmia.f64 r0!, {d2}; \
154 subs ip, ip, #1; \
155 bne vfp_ ## fname ## _loop1; \
156 vfp_ ## fname ## _unroll: /* unroll by 4 */ \
157@@ -180,14 +180,14 @@ UNROLL_F64_TEMPLATE(subtract_f64,fsub);
158 orr fp, lr, fp, lsl #16; /* set vector lenght to 4 */ \
159 fmxr fpscr, fp; \
160 vfp_ ## fname ## _loop2: \
161- fldmiad r1!, {d4, d5, d6, d7}; \
162+ vldmia.f64 r1!, {d4, d5, d6, d7}; \
163 ## finst ##d d12, d4, d1; \
164- fstmiad r0!, {d12, d13, d14, d15}; \
165+ vstmia.f64 r0!, {d12, d13, d14, d15}; \
166 subs ip, ip, #1; \
167 bne vfp_ ## fname ## _loop2; \
168 fmxr fpscr, lr; /* restore original fpscr */ \
169 vfp_ ## fname ## _end: \
170- ldmia sp!, {fp, pc}; /* recovering from stack and return */
171+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
172
173 UNROLL_F32_TEMPLATE(scalaradd_f32_ns,fadd);
174 UNROLL_F64_TEMPLATE(scalaradd_f64_ns,fadd);
175@@ -198,7 +198,7 @@ UNROLL_F64_TEMPLATE(scalarmultiply_f64_ns,fmul);
176 #undef UNROLL_F32_TEMPLATE
177 #undef UNROLL_F64_TEMPLATE
178
179-/*
180+/*
181 **
182 ** void vfp_abs_f32_f32_ns(float *d, const float *s, int n);
183 ** void vfp_abs_f64_f64_ns(double *d, const double *s, int n);
184@@ -215,9 +215,9 @@ UNROLL_F64_TEMPLATE(scalarmultiply_f64_ns,fmul);
185 ands ip, r2, #7; /* ip = n % 8 */ \
186 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
187 vfp_ ## fname ## _loop1: \
188- fldmias r1!, {s0}; \
189- ## finst ##s s2, s0; \
190- fstmias r0!, {s2}; \
191+ vldmia.f32 r1!, {s0}; \
192+ ## finst ##.f32 s2, s0; \
193+ vstmia.f32 r0!, {s2}; \
194 subs ip, ip, #1; \
195 bne vfp_ ## fname ## _loop1; \
196 vfp_ ## fname ## _unroll: /* unroll by 8 */ \
197@@ -228,14 +228,14 @@ UNROLL_F64_TEMPLATE(scalarmultiply_f64_ns,fmul);
198 orr fp, lr, fp, lsl #16; /* set vector lenght to 8 */ \
199 fmxr fpscr, fp; \
200 vfp_ ## fname ## _loop2: \
201- fldmias r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
202- ## finst ##s s24, s8; \
203- fstmias r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
204+ vldmia.f32 r1!, {s8, s9, s10, s11, s12, s13, s14, s15}; \
205+ ## finst ##.f32 s24, s8; \
206+ vstmia.f32 r0!, {s24, s25, s26, s27, s28, s29, s30, s31}; \
207 subs ip, ip, #1; \
208 bne vfp_ ## fname ## _loop2; \
209 fmxr fpscr, lr; /* restore original fpscr */ \
210 vfp_ ## fname ## _end: \
211- ldmia sp!, {fp, pc}; /* recovering from stack and return */
212+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
213
214 #define UNROLL_F64_TEMPLATE(fname,finst) \
215 .global vfp_ ## fname ## ; \
216@@ -244,9 +244,9 @@ UNROLL_F64_TEMPLATE(scalarmultiply_f64_ns,fmul);
217 ands ip, r2, #3; /* ip = n % 3 */ \
218 beq vfp_ ## fname ## _unroll; /* if ip == 0 goto prep_loop2 */ \
219 vfp_ ## fname ## _loop1: \
220- fldmiad r1!, {d0}; \
221- ## finst ##d d2, d0; \
222- fstmiad r0!, {d2}; \
223+ vldmia.f64 r1!, {d0}; \
224+ ## finst ##.f64 d2, d0; \
225+ vstmia.f64 r0!, {d2}; \
226 subs ip, ip, #1; \
227 bne vfp_ ## fname ## _loop1; \
228 vfp_ ## fname ## _unroll: /* unroll by 4 */ \
229@@ -257,20 +257,20 @@ UNROLL_F64_TEMPLATE(scalarmultiply_f64_ns,fmul);
230 orr fp, lr, fp, lsl #16; /* set vector lenght to 4 */ \
231 fmxr fpscr, fp; \
232 vfp_ ## fname ## _loop2: \
233- fldmiad r1!, {d4, d5, d6, d7}; \
234- ## finst ##d d12, d4; \
235- fstmiad r0!, {d12, d13, d14, d15}; \
236+ vldmia.f64 r1!, {d4, d5, d6, d7}; \
237+ ## finst ##.f64 d12, d4; \
238+ vstmia.f64 r0!, {d12, d13, d14, d15}; \
239 subs ip, ip, #1; \
240 bne vfp_ ## fname ## _loop2; \
241 fmxr fpscr, lr; /* restore original fpscr */ \
242 vfp_ ## fname ## _end: \
243- ldmia sp!, {fp, pc}; /* recovering from stack and return */
244+ ldmia sp!, {fp, pc}; /* recovering from stack and return */
245
246-UNROLL_F32_TEMPLATE(abs_f32_f32_ns,fabs);
247-UNROLL_F64_TEMPLATE(abs_f64_f64_ns,fabs);
248+UNROLL_F32_TEMPLATE(abs_f32_f32_ns,vabs);
249+UNROLL_F64_TEMPLATE(abs_f64_f64_ns,vabs);
250
251-UNROLL_F32_TEMPLATE(negative_f32,fneg);
252-UNROLL_F64_TEMPLATE(negative_f64,fneg);
253+UNROLL_F32_TEMPLATE(negative_f32,vneg);
254+UNROLL_F64_TEMPLATE(negative_f64,vneg);
255
256 #undef UNROLL_F32_TEMPLATE
257 #undef UNROLL_F64_TEMPLATE
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch
deleted file mode 100644
index c8e3c1f72..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix-unaligned-whitelist.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1Upstream: https://bugs.freedesktop.org/show_bug.cgi?id=31358
2
3configure: fix whitelisting of x86_64 unaligned memory access
4
5Fix typo in whitelist so cross-compile works for x86_64.
6
7Upstream-Status: Inappropriate [configuration]
8
9--- liboil-0.3.17/m4/as-unaligned-access.m4.orig 2009-02-26 14:40:08.000000000 -0500
10+++ liboil-0.3.17/m4/as-unaligned-access.m4 2010-11-03 12:19:55.000000000 -0400
11@@ -9,7 +9,7 @@
12 _AS_ECHO_N([(blacklisted) ])
13 as_cv_unaligned_access=no
14 ;;
15- i?86*|x86_64|amd64|powerpc*|m68k*|cris*)
16+ i?86*|x86_64*|amd64*|powerpc*|m68k*|cris*)
17 _AS_ECHO_N([(whitelisted) ])
18 as_cv_unaligned_access=yes
19 ;;
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix_riscv_unaligned_access.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix_riscv_unaligned_access.patch
deleted file mode 100644
index 448bde73f..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/fix_riscv_unaligned_access.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1RISC-V supports unaligned accesses, therefore enable it
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/m4/as-unaligned-access.m4
6+++ b/m4/as-unaligned-access.m4
7@@ -5,7 +5,7 @@ AC_DEFUN([AS_UNALIGNED_ACCESS], [
8 AC_MSG_CHECKING([if unaligned memory access works correctly])
9 if test x"$as_cv_unaligned_access" = x ; then
10 case $host in
11- alpha*|arm*|hp*|mips*|sh*|sparc*|ia64*)
12+ alpha*|arm*|hp*|mips*|riscv*|sh*|sparc*|ia64*)
13 _AS_ECHO_N([(blacklisted) ])
14 as_cv_unaligned_access=no
15 ;;
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/liboil_fix_for_x32.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/liboil_fix_for_x32.patch
deleted file mode 100644
index 473380e9f..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/liboil_fix_for_x32.patch
+++ /dev/null
@@ -1,222 +0,0 @@
1Upstream-Status: Pending
2
3Make the assembly syntax compatible with x32 gcc. Othewise x32 gcc throws errors.
4
5Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
62011/12/01
7
8
9Index: liboil-0.3.17/liboil/amd64/wavelet.c
10===================================================================
11--- liboil-0.3.17.orig/liboil/amd64/wavelet.c
12+++ liboil-0.3.17/liboil/amd64/wavelet.c
13@@ -21,14 +21,14 @@ deinterleave2_asm (int16_t *d1, int16_t
14 asm volatile ("\n"
15 " sub $2, %%rcx\n"
16 "1:\n"
17- " movw (%1,%%rcx,4), %%ax\n"
18- " movw %%ax, (%0,%%rcx,2)\n"
19- " movw 2(%1,%%rcx,4), %%ax\n"
20- " movw %%ax, (%2,%%rcx,2)\n"
21- " movw 4(%1,%%rcx,4), %%ax\n"
22- " movw %%ax, 2(%0,%%rcx,2)\n"
23- " movw 6(%1,%%rcx,4), %%ax\n"
24- " movw %%ax, 2(%2,%%rcx,2)\n"
25+ " movw (%q1,%%rcx,4), %%ax\n"
26+ " movw %%ax, (%q0,%%rcx,2)\n"
27+ " movw 2(%q1,%%rcx,4), %%ax\n"
28+ " movw %%ax, (%q2,%%rcx,2)\n"
29+ " movw 4(%q1,%%rcx,4), %%ax\n"
30+ " movw %%ax, 2(%q0,%%rcx,2)\n"
31+ " movw 6(%q1,%%rcx,4), %%ax\n"
32+ " movw %%ax, 2(%q2,%%rcx,2)\n"
33 " sub $2, %%rcx\n"
34 " jge 1b\n"
35 : "+r" (d1), "+r" (s_2xn), "+r" (d2), "+c" (n)
36@@ -53,20 +53,20 @@ deinterleave2_mmx (int16_t *d1, int16_t
37 asm volatile ("\n"
38 " xor %%rcx, %%rcx\n"
39 "1:\n"
40- " movq (%1,%%rcx,4), %%mm0\n"
41- " movq 8(%1,%%rcx,4), %%mm1\n"
42+ " movq (%q1,%%rcx,4), %%mm0\n"
43+ " movq 8(%q1,%%rcx,4), %%mm1\n"
44 " pslld $16, %%mm0\n"
45 " pslld $16, %%mm1\n"
46 " psrad $16, %%mm0\n"
47 " psrad $16, %%mm1\n"
48 " packssdw %%mm1, %%mm0\n"
49- " movq %%mm0, (%0,%%rcx,2)\n"
50- " movq (%1,%%rcx,4), %%mm0\n"
51- " movq 8(%1,%%rcx,4), %%mm1\n"
52+ " movq %%mm0, (%q0,%%rcx,2)\n"
53+ " movq (%q1,%%rcx,4), %%mm0\n"
54+ " movq 8(%q1,%%rcx,4), %%mm1\n"
55 " psrad $16, %%mm0\n"
56 " psrad $16, %%mm1\n"
57 " packssdw %%mm1, %%mm0\n"
58- " movq %%mm0, (%2,%%rcx,2)\n"
59+ " movq %%mm0, (%q2,%%rcx,2)\n"
60 " add $4, %%rcx\n"
61 " cmp %3, %%ecx\n"
62 " jl 1b\n"
63@@ -93,10 +93,10 @@ deinterleave2_mmx_2 (int16_t *d1, int16_
64 asm volatile ("\n"
65 " xor %%rcx, %%rcx\n"
66 "1:\n"
67- " pshufw $0xd8, (%1,%%rcx,4), %%mm0\n"
68- " movd %%mm0, (%0,%%rcx,2)\n"
69- " pshufw $0x8d, (%1,%%rcx,4), %%mm0\n"
70- " movd %%mm0, (%2,%%rcx,2)\n"
71+ " pshufw $0xd8, (%q1,%%rcx,4), %%mm0\n"
72+ " movd %%mm0, (%q0,%%rcx,2)\n"
73+ " pshufw $0x8d, (%q1,%%rcx,4), %%mm0\n"
74+ " movd %%mm0, (%q2,%%rcx,2)\n"
75 " add $2, %%rcx\n"
76 " cmp %3, %%ecx\n"
77 " jl 1b\n"
78@@ -123,16 +123,16 @@ deinterleave2_mmx_3 (int16_t *d1, int16_
79 asm volatile ("\n"
80 " xor %%rcx, %%rcx\n"
81 "1:\n"
82- " movq (%1,%%rcx,4), %%mm1\n"
83- " movq (%1,%%rcx,4), %%mm2\n"
84- " movq 8(%1,%%rcx,4), %%mm0\n"
85+ " movq (%q1,%%rcx,4), %%mm1\n"
86+ " movq (%q1,%%rcx,4), %%mm2\n"
87+ " movq 8(%q1,%%rcx,4), %%mm0\n"
88 " punpcklwd %%mm0, %%mm1\n"
89 " punpckhwd %%mm0, %%mm2\n"
90 " movq %%mm1, %%mm0\n"
91 " punpcklwd %%mm2, %%mm0\n"
92 " punpckhwd %%mm2, %%mm1\n"
93- " movq %%mm0, (%0,%%rcx,2)\n"
94- " movq %%mm1, (%2,%%rcx,2)\n"
95+ " movq %%mm0, (%q0,%%rcx,2)\n"
96+ " movq %%mm1, (%q2,%%rcx,2)\n"
97 " add $4, %%rcx\n"
98 " cmp %3, %%ecx\n"
99 " jl 1b\n"
100@@ -159,26 +159,26 @@ deinterleave2_mmx_4 (int16_t *d1, int16_
101 asm volatile ("\n"
102 " xor %%rcx, %%rcx\n"
103 "1:\n"
104- " movq (%1,%%rcx,4), %%mm1\n"
105+ " movq (%q1,%%rcx,4), %%mm1\n"
106 " movq %%mm1, %%mm2\n"
107- " movq 8(%1,%%rcx,4), %%mm0\n"
108- " movq 16(%1,%%rcx,4), %%mm5\n"
109+ " movq 8(%q1,%%rcx,4), %%mm0\n"
110+ " movq 16(%q1,%%rcx,4), %%mm5\n"
111 " punpcklwd %%mm0, %%mm1\n"
112 " movq %%mm5, %%mm6\n"
113 " punpckhwd %%mm0, %%mm2\n"
114- " movq 24(%1,%%rcx,4), %%mm4\n"
115+ " movq 24(%q1,%%rcx,4), %%mm4\n"
116 " movq %%mm1, %%mm0\n"
117 " punpcklwd %%mm4, %%mm5\n"
118 " punpcklwd %%mm2, %%mm0\n"
119 " punpckhwd %%mm4, %%mm6\n"
120 " punpckhwd %%mm2, %%mm1\n"
121 " movq %%mm5, %%mm4\n"
122- " movq %%mm0, (%0,%%rcx,2)\n"
123+ " movq %%mm0, (%q0,%%rcx,2)\n"
124 " punpcklwd %%mm6, %%mm4\n"
125- " movq %%mm1, (%2,%%rcx,2)\n"
126+ " movq %%mm1, (%q2,%%rcx,2)\n"
127 " punpckhwd %%mm6, %%mm5\n"
128- " movq %%mm4, 8(%0,%%rcx,2)\n"
129- " movq %%mm5, 8(%2,%%rcx,2)\n"
130+ " movq %%mm4, 8(%q0,%%rcx,2)\n"
131+ " movq %%mm5, 8(%q2,%%rcx,2)\n"
132 " add $8, %%rcx\n"
133 " cmp %3, %%ecx\n"
134 " jl 1b\n"
135@@ -252,13 +252,13 @@ interleave2_mmx (int16_t *d_2xn, int16_t
136 asm volatile ("\n"
137 " xor %%rcx, %%rcx\n"
138 "1:\n"
139- " movq (%1,%%rcx,2), %%mm0\n"
140- " movq (%2,%%rcx,2), %%mm1\n"
141+ " movq (%q1,%%rcx,2), %%mm0\n"
142+ " movq (%q2,%%rcx,2), %%mm1\n"
143 " movq %%mm0, %%mm2\n"
144 " punpckhwd %%mm1, %%mm0\n"
145 " punpcklwd %%mm1, %%mm2\n"
146- " movq %%mm2, (%0,%%rcx,4)\n"
147- " movq %%mm0, 8(%0,%%rcx,4)\n"
148+ " movq %%mm2, (%q0,%%rcx,4)\n"
149+ " movq %%mm0, 8(%q0,%%rcx,4)\n"
150 " add $4, %%rcx\n"
151 " cmp %3, %%ecx\n"
152 " jl 1b\n"
153@@ -285,12 +285,12 @@ lift_add_shift1_mmx (int16_t *d, int16_t
154 asm volatile ("\n"
155 " xor %%rcx, %%rcx\n"
156 "1:\n"
157- " movq (%2,%%rcx,2), %%mm1\n"
158- " movq (%3,%%rcx,2), %%mm2\n"
159+ " movq (%q2,%%rcx,2), %%mm1\n"
160+ " movq (%q3,%%rcx,2), %%mm2\n"
161 " paddw %%mm2, %%mm1\n"
162 " psraw $1, %%mm1\n"
163- " paddw (%1,%%rcx,2), %%mm1\n"
164- " movq %%mm1, (%0,%%rcx,2)\n"
165+ " paddw (%q1,%%rcx,2), %%mm1\n"
166+ " movq %%mm1, (%q0,%%rcx,2)\n"
167 " add $4, %%rcx\n"
168 " cmp %4, %%ecx\n"
169 " jl 1b\n"
170@@ -317,13 +317,13 @@ lift_sub_shift1_mmx (int16_t *d, int16_t
171 asm volatile ("\n"
172 " xor %%rcx, %%rcx\n"
173 "1:\n"
174- " movq (%2,%%rcx,2), %%mm1\n"
175- " movq (%3,%%rcx,2), %%mm2\n"
176- " movq (%1,%%rcx,2), %%mm0\n"
177+ " movq (%q2,%%rcx,2), %%mm1\n"
178+ " movq (%q3,%%rcx,2), %%mm2\n"
179+ " movq (%q1,%%rcx,2), %%mm0\n"
180 " paddw %%mm2, %%mm1\n"
181 " psraw $1, %%mm1\n"
182 " psubw %%mm1, %%mm0\n"
183- " movq %%mm0, (%0,%%rcx,2)\n"
184+ " movq %%mm0, (%q0,%%rcx,2)\n"
185 " add $4, %%rcx\n"
186 " cmp %4, %%ecx\n"
187 " jl 1b\n"
188@@ -350,12 +350,12 @@ lift_add_shift2_mmx (int16_t *d, int16_t
189 asm volatile ("\n"
190 " xor %%rcx, %%rcx\n"
191 "1:\n"
192- " movq (%2,%%rcx,2), %%mm1\n"
193- " movq (%3,%%rcx,2), %%mm2\n"
194+ " movq (%q2,%%rcx,2), %%mm1\n"
195+ " movq (%q3,%%rcx,2), %%mm2\n"
196 " paddw %%mm2, %%mm1\n"
197 " psraw $2, %%mm1\n"
198- " paddw (%1,%%rcx,2), %%mm1\n"
199- " movq %%mm1, (%0,%%rcx,2)\n"
200+ " paddw (%q1,%%rcx,2), %%mm1\n"
201+ " movq %%mm1, (%q0,%%rcx,2)\n"
202 " add $4, %%rcx\n"
203 " cmp %4, %%ecx\n"
204 " jl 1b\n"
205@@ -382,13 +382,13 @@ lift_sub_shift2_mmx (int16_t *d, int16_t
206 asm volatile ("\n"
207 " xor %%rcx, %%rcx\n"
208 "1:\n"
209- " movq (%2,%%rcx,2), %%mm1\n"
210- " movq (%3,%%rcx,2), %%mm2\n"
211- " movq (%1,%%rcx,2), %%mm0\n"
212+ " movq (%q2,%%rcx,2), %%mm1\n"
213+ " movq (%q3,%%rcx,2), %%mm2\n"
214+ " movq (%q1,%%rcx,2), %%mm0\n"
215 " paddw %%mm2, %%mm1\n"
216 " psraw $2, %%mm1\n"
217 " psubw %%mm1, %%mm0\n"
218- " movq %%mm0, (%0,%%rcx,2)\n"
219+ " movq %%mm0, (%q0,%%rcx,2)\n"
220 " add $4, %%rcx\n"
221 " cmp %4, %%ecx\n"
222 " jl 1b\n"
diff --git a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/no-tests.patch b/meta-multimedia/recipes-support/liboil/liboil-0.3.17/no-tests.patch
deleted file mode 100644
index 892d44131..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil-0.3.17/no-tests.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1Upstream-Status: Inappropriate [disable feature]
2
3--- liboil-0.3.9/liboil/liboilfunction.c.old 2006-09-18 13:03:20.000000000 +0100
4+++ liboil-0.3.9/liboil/liboilfunction.c 2006-09-18 13:04:10.000000000 +0100
5@@ -345,7 +345,9 @@
6 return;
7 }
8
9- test = oil_test_new (klass);
10+ klass->chosen_impl = klass->reference_impl;
11+ klass->func = klass->reference_impl->func;
12+/* test = oil_test_new (klass);
13 if (test == NULL) {
14 OIL_ERROR ("failed to test function class %s", klass->name);
15 return;
16@@ -385,7 +387,7 @@
17 klass->chosen_impl = min_impl;
18 klass->func = min_impl->func;
19
20- oil_test_free (test);
21+ oil_test_free (test);*/
22 }
23
24 static void
diff --git a/meta-multimedia/recipes-support/liboil/liboil_0.3.17.bb b/meta-multimedia/recipes-support/liboil/liboil_0.3.17.bb
deleted file mode 100644
index 654ee1e88..000000000
--- a/meta-multimedia/recipes-support/liboil/liboil_0.3.17.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Library of simple functions optimized for various CPUs"
2HOMEPAGE = "http://liboil.freedesktop.org/"
3BUGTRACKER = "https://bugs.freedesktop.org/"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ad80780d9c5205d63481a0184e199a15 \
7 file://liboil/liboil.h;endline=28;md5=95c794a66b88800d949fed17e437d9fb \
8 file://liboil/liboilcpu.c;endline=28;md5=89da69a61d88eedcba066f42353fb75a \
9 file://examples/example1.c;endline=29;md5=9d4dad9fcbbdf0441ee063f8af5170c9 \
10 file://testsuite/trans.c;endline=29;md5=380ecd43121fe3dcc0d8d7e5984f283d"
11
12DEPENDS = "glib-2.0"
13PR = "r5"
14
15SRC_URI = "http://liboil.freedesktop.org/download/${BPN}-${PV}.tar.gz \
16 file://no-tests.patch \
17 file://fix-unaligned-whitelist.patch \
18 file://0001-Fix-enable-vfp-flag.patch \
19 file://liboil_fix_for_x32.patch \
20 file://0001-math_vfp_asm.S-Convert-fldmia-fstmia-instructions-to.patch \
21 file://fix_riscv_unaligned_access.patch \
22 "
23
24SRC_URI[md5sum] = "47dc734f82faeb2964d97771cfd2e701"
25SRC_URI[sha256sum] = "105f02079b0b50034c759db34b473ecb5704ffa20a5486b60a8b7698128bfc69"
26
27inherit autotools pkgconfig
28
29ARM_INSTRUCTION_SET = "arm"