summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-06-26 11:50:51 +0300
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:32 -0700
commit56c9e522e831a507697b6021d11f8caaf0d0750a (patch)
tree2e57159ba92dbb0d917438ee7d0dbe1247edcf7d /meta-multimedia
parentdb4b115ef39250cbe4f8c5ec806c790d707fd0e4 (diff)
downloadmeta-openembedded-56c9e522e831a507697b6021d11f8caaf0d0750a.tar.gz
gssdp: Merge inc
This recipe stopped having multiple versions in 2014. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gssdp.inc20
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gssdp_1.0.2.bb25
2 files changed, 20 insertions, 25 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gssdp.inc b/meta-multimedia/recipes-connectivity/gupnp/gssdp.inc
deleted file mode 100644
index 23f17eddf..000000000
--- a/meta-multimedia/recipes-connectivity/gupnp/gssdp.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "Resource discovery and announcement over SSDP"
2DESCRIPTION = "GSSDP implements resource discovery and announcement over SSDP (Simpe Service Discovery Protocol)."
3LICENSE = "LGPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5DEPENDS = "glib-2.0 libsoup-2.4"
6
7inherit autotools pkgconfig gobject-introspection vala
8
9# Copy vapigen.m4 so that it doesn't get removed by vala class
10# (normally this would be the right thing to do, but in gssdp the vapigen.m4 has only a custom macro)
11do_configure_prepend() {
12 cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true
13}
14
15PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)}"
16PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk,gtk+"
17
18PACKAGES =+ "gssdp-tools"
19
20FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.0.2.bb b/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.0.2.bb
index b60d1ea44..6088ef195 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.0.2.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.0.2.bb
@@ -1,9 +1,24 @@
1require gssdp.inc 1SUMMARY = "Resource discovery and announcement over SSDP"
2 2DESCRIPTION = "GSSDP implements resource discovery and announcement over SSDP (Simpe Service Discovery Protocol)."
3inherit gtk-doc 3LICENSE = "LGPLv2"
4 4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
5PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk,gtk+3" 5DEPENDS = "glib-2.0 libsoup-2.4"
6 6
7SRC_URI = "${GNOME_MIRROR}/${BPN}/1.0/${BPN}-${PV}.tar.xz" 7SRC_URI = "${GNOME_MIRROR}/${BPN}/1.0/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "b30c9a406853c6a3a012d151d6e7ad2c" 8SRC_URI[md5sum] = "b30c9a406853c6a3a012d151d6e7ad2c"
9SRC_URI[sha256sum] = "a1e17c09c7e1a185b0bd84fd6ff3794045a3cd729b707c23e422ff66471535dc" 9SRC_URI[sha256sum] = "a1e17c09c7e1a185b0bd84fd6ff3794045a3cd729b707c23e422ff66471535dc"
10
11inherit autotools pkgconfig gobject-introspection vala gtk-doc
12
13# Copy vapigen.m4 so that it doesn't get removed by vala class
14# (normally this would be the right thing to do, but in gssdp the vapigen.m4 has only a custom macro)
15do_configure_prepend() {
16 cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true
17}
18
19PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)}"
20PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk,gtk+3"
21
22PACKAGES =+ "gssdp-tools"
23
24FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"