diff options
author | Cliff Brake <cbrake@bec-systems.com> | 2013-10-18 00:38:29 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-10-21 12:15:03 +0200 |
commit | 17872764a5cfc402b0b33a1ac9e6d3f9e2e827da (patch) | |
tree | 3da7c8c8909f9f394e34d946298009f0f6456491 /meta-multimedia | |
parent | 6e6e0f4faf1b7db0acdbedd15a940bc83c444d2a (diff) | |
download | meta-openembedded-17872764a5cfc402b0b33a1ac9e6d3f9e2e827da.tar.gz |
coriander: add recipe
Initial recipe created by Khem Raj
Signed-off-by: Cliff Brake <cbrake@bec-systems.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/coriander/coriander/cross-compile.patch | 17 | ||||
-rwxr-xr-x | meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb | 15 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/coriander/coriander/cross-compile.patch b/meta-multimedia/recipes-multimedia/coriander/coriander/cross-compile.patch new file mode 100644 index 000000000..49350fe18 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/coriander/coriander/cross-compile.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | In a cross compile environment adding paths like /usr are not correct. | ||
2 | With this patch we make it so that its relative to sysroot if the compiler | ||
3 | defines one. | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | Index: a/src/Makefile.am | ||
8 | =================================================================== | ||
9 | --- a/src/Makefile.am 2013-02-08 22:35:08.000000000 -0800 | ||
10 | +++ b/src/Makefile.am 2013-10-13 01:31:38.812869080 -0700 | ||
11 | @@ -33,5 +33,5 @@ | ||
12 | video_encode.c video_encode.h \ | ||
13 | subtitles.c subtitles.h | ||
14 | |||
15 | -coriander_LDADD = -L/usr/X11R6/lib/ @PACKAGE_LIBS@ $(INTLLIBS) $(LIBTIFF_LIBS) $(FTPLIB_LIBS) $(SDLLIB_LIBS) $(LIBDC_LIBS) $(LIBRAW_LIBS) $(XV_LIBS) $(COR_LFS_LDFLAGS) -lgthread-2.0 $(FFMPEG_LIBS) $(X11_LIBS) | ||
16 | +coriander_LDADD = -L=/usr/X11R6/lib/ @PACKAGE_LIBS@ $(INTLLIBS) $(LIBTIFF_LIBS) $(FTPLIB_LIBS) $(SDLLIB_LIBS) $(LIBDC_LIBS) $(LIBRAW_LIBS) $(XV_LIBS) $(COR_LFS_LDFLAGS) -lgthread-2.0 $(FFMPEG_LIBS) $(X11_LIBS) | ||
17 | |||
diff --git a/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb b/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb new file mode 100755 index 000000000..64ccc9b60 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/coriander/coriander_2.0.2.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Control and capture GUI for IIDC compliant cameras" | ||
2 | HOMEPAGE = "http://damien.douxchamps.net/ieee1394/coriander/" | ||
3 | SECTION = "applications" | ||
4 | LICENSE = "GPL-3.0" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
6 | DEPENDS = "gtk+ libgnomeui libraw1394 libdc1394 libxv" | ||
7 | |||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${PN}/coriander-2/${PV}/${P}.tar.gz \ | ||
9 | file://cross-compile.patch \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "431d98fb013217681f97ade168201fb8" | ||
13 | SRC_URI[sha256sum] = "5c7fd31cb58d398e2742352bf1ffbd2ca22e06686c6668ecfd437735c2b79123" | ||
14 | |||
15 | inherit autotools gettext | ||