diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2013-05-20 18:08:06 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 11:01:09 +0200 |
commit | 450940b3a6757eb451031361a27e7d0831a0f340 (patch) | |
tree | a2924ee7b7fed8438b3cbd3fca2c3d89b8962d4d /meta-multimedia | |
parent | ecdc4af9bc4c3df5ef5a32b6a8bf11301e53faea (diff) | |
download | meta-openembedded-450940b3a6757eb451031361a27e7d0831a0f340.tar.gz |
bigbuckbunny: Add 480p, 720p and 1080p movies
This provides a recipe to install the movies in the rootfs; these
allow for people to make demo images which carry the movies for show.
These recipes are based on Angstrom ones. Thanks by their base work.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia')
3 files changed, 48 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb new file mode 100644 index 000000000..93a52c079 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Big Buck Bunny movie - 1080P" | ||
2 | LICENSE = "CC-BY" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/big_buck_bunny_1080p_surround.avi;md5=223991c8b33564eb77988a4c13c1c76a" | ||
4 | |||
5 | SRC_URI = "http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_1080p_surround.avi" | ||
6 | SRC_URI[md5sum] = "223991c8b33564eb77988a4c13c1c76a" | ||
7 | SRC_URI[sha256sum] = "69fe2cfe7154a6e752688e3a0d7d6b07b1605bbaf75b56f6470dc7b4c20c06ea" | ||
8 | |||
9 | inherit allarch | ||
10 | |||
11 | do_install() { | ||
12 | install -d ${D}${datadir}/movies | ||
13 | install -m 0644 ${WORKDIR}/big_buck_bunny_1080p_surround.avi ${D}${datadir}/movies/ | ||
14 | } | ||
15 | |||
16 | FILES_${PN} += "${datadir}/movies" | ||
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb new file mode 100644 index 000000000..31a90cacf --- /dev/null +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Big Buck Bunny movie - 480P" | ||
2 | LICENSE = "CC-BY" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/big_buck_bunny_480p_surround-fix.avi;md5=ed7ed01e9aefba8ddd77c13332cec120" | ||
4 | |||
5 | SRC_URI = "http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_480p_surround-fix.avi" | ||
6 | SRC_URI[md5sum] = "ed7ed01e9aefba8ddd77c13332cec120" | ||
7 | SRC_URI[sha256sum] = "40d1cf5bc8e1b0e55dac7bb2e3fbc2aea05b6679444864781299b24db044634f" | ||
8 | |||
9 | inherit allarch | ||
10 | |||
11 | do_install() { | ||
12 | install -d ${D}${datadir}/movies | ||
13 | install -m 0644 ${WORKDIR}/big_buck_bunny_480p_surround-fix.avi ${D}${datadir}/movies/ | ||
14 | } | ||
15 | |||
16 | FILES_${PN} += "${datadir}/movies" | ||
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb new file mode 100644 index 000000000..61cdfdcff --- /dev/null +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Big Buck Bunny movie - 720P" | ||
2 | LICENSE = "CC-BY" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/big_buck_bunny_720p_surround.avi;md5=0da8fe124595f5b206d64cb1400bbefc" | ||
4 | |||
5 | SRC_URI = "http://download.blender.org/peach/bigbuckbunny_movies/big_buck_bunny_720p_surround.avi" | ||
6 | SRC_URI[md5sum] = "0da8fe124595f5b206d64cb1400bbefc" | ||
7 | SRC_URI[sha256sum] = "b957d6e6212638441b52d3b620af157cc8d40c2a0342669294854a06edcd528c" | ||
8 | |||
9 | inherit allarch | ||
10 | |||
11 | do_install() { | ||
12 | install -d ${D}${datadir}/movies | ||
13 | install -m 0644 ${WORKDIR}/big_buck_bunny_720p_surround.avi ${D}${datadir}/movies/ | ||
14 | } | ||
15 | |||
16 | FILES_${PN} += "${datadir}/movies" | ||